Bug 1664 - SD card not recognized (status error)
: SD card not recognized (status error)
Status: RESOLVED FIXED
Product: Core
Kernel
: 1.0
: N800 Maemo
: Low critical with 2 votes (vote)
: ---
Assigned To: unassigned
: linux-kernel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-07-17 00:28 UTC by erik
Modified: 2008-12-06 16:11 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description erik (reporter) 2007-07-17 00:28:40 UTC
My N800 no longer recognizes internal SD memory cards. I don't think the card
itself is an issue (it works when placed in the external memory card slot).

It this more likely a hardware problem (with the internal memory card
slot/reader)?

Messages from /proc/kmsg:

<6>[14497.654693] bat_cover (GPIO 110) is now open
<6>[14497.654785] mmci-omap mmci-omap.1: cover is now open
<4>[14497.655364] menelaus: Setting voltage 'VMMC' to 3100 mV (reg 0x0a, val
0xf0)
<4>[14497.751922] menelaus: Setting voltage 'VMMC' to 2800 mV (reg 0x0a, val
0x70)
<3>[14497.912170] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14497.912231] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14497.921020] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14498.061706] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14498.414398] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14498.414459] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14498.415924] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14498.489257] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14498.489318] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14498.600921] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14498.601013] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14498.855957] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14498.980438] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14499.396270] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14499.396331] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14499.591827] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14499.750732] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14499.750793] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14499.770660] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14499.965057] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14499.965118] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14499.966735] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14500.199310] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14500.199371] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14500.201507] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14500.476623] mmci-omap mmci-omap.1: command timeout (CMD41)
<3>[14500.691711] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14500.691772] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14500.709045] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14501.029113] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14501.029174] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14501.030578] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14501.077392] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14501.145843] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14501.145904] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14501.147064] mmci-omap mmci-omap.1: card status error (CMD55)
<3>[14501.218170] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<4>[14501.243347] menelaus: Setting voltage 'VMMC' to 0 mV (reg 0x0a, val 0x30)
<6>[14538.981048] bat_cover (GPIO 110) is now closed
<6>[14538.981109] mmci-omap mmci-omap.1: cover is now closed
<4>[14539.008178] menelaus: Setting voltage 'VMMC' to 3100 mV (reg 0x0a, val
0xf0)
<4>[14539.137298] menelaus: Setting voltage 'VMMC' to 2800 mV (reg 0x0a, val
0x70)
<3>[14539.629547] mmci-omap mmci-omap.1: command CRC error (CMD55, arg
0x00000000)
<3>[14539.629638] mmci-omap mmci-omap.1: card status error (CMD55)
Comment 1 erik (reporter) 2007-07-17 00:32:17 UTC
Memory cards used (both work fine in external slot):

SanDisk SD Extreme III (2 GB)
SanDisk SD Ultra II (2 GB)
Comment 2 Eero Tamminen nokia 2007-08-10 12:10:04 UTC
The latest release reads & uses also extended card information from
the SD cards, so the kernel MMC driver behaviour is different between
the latest 26-8 release and the previous one.

We've just found out that some (Sandisk) cards which are readable with
the previous release, are not readable with the latest one (we're not yet
sure whether the problem is with the information the card provides or how
it is interpreted).  Although this was with the external slot, would it be
possible for you to test whether your card still works in the internal slot
if you flash the previous release?

Thanks!
Comment 3 Neil MacLeod maemo.org 2007-08-10 13:24:42 UTC
As an alternative to reverting back to 3.2007 firmware, you could also try the
4.2007 kernel with official mainline Linux MMC/SDHC patches[1]. Nokia didn't
apply all of the MMC/SDHC patches while attempting to fix bug #1204.

I've been using the community kernel[1] for several weeks now and have not
suffered any corruption and enjoyed improved performance, yet with the official
Nokia kernel and SDHC patches within a week I experienced a corrupt filesystem
(and the official MMC/SDHC patches throttle performance).

1. http://intr.overt.org/blog/?p=54
Comment 4 Eero Tamminen nokia 2007-08-16 18:31:33 UTC
There's another bug 1107 where the user has an issue with the other slot.
Comment 5 Kimmo Hämäläinen nokia 2007-09-25 09:47:10 UTC
kernel
Comment 6 Phillip Dubov 2007-10-19 18:16:47 UTC
I have lived with this problem since 8.22.07.

Others have reported this in the ITT forums:

http://www.internettablettalk.com/forums/showthread.php?t=8405&highlight=internal+memory+slot+failure
Comment 7 Eero Tamminen nokia 2007-10-22 10:56:55 UTC
> Memory cards used (both work fine in external slot):
> 
> SanDisk SD Extreme III (2 GB)
> SanDisk SD Ultra II (2 GB)

I haven't heard about problems in this respect at least for the latter
card, only about MMC corruption.


Please test this with the MMC fix release (you should anyway be using
it as you have SanDisk card >= 2GB).  Besides fixing the power management
issue when the device went to sleep (which could cause internal MMC
corruption with some cards), it had some fixes for the MMC detection.
Comment 8 Eero Tamminen nokia 2007-12-04 12:47:15 UTC
As there were no comments that this would have happened after the MMC-fix
release (see bug #1204) or Chinook (beta), marking this as fixed. 
Please re-open if this is not the case.