Bug 1629 - (int-75613) finger virtual keyboard does not appear reliably
(int-75613)
: finger virtual keyboard does not appear reliably
Status: RESOLVED FIXED
Product: Desktop platform
Virtual keyboard (fullscreen)
: 1.0
: All All
: Unspecified minor with 5 votes (vote)
: 4.1
Assigned To: unassigned
: fkb-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-07-07 18:32 UTC by Eric Cooper
Modified: 2008-06-05 01:07 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Eric Cooper (reporter) 2007-07-07 18:32:02 UTC
After I flashed my N800 with 4.2007.26-8, the finger virtual keyboard no longer
comes up reliably when I touch a text-entry area with my finger (for example,
the Google search bar applet that is installed by default on the desktop).
Most of the time, the stylus virtual keyboard appears instead.
Comment 1 Per Wille 2007-07-09 11:37:10 UTC
I experience the exact same problem. I tried all steps on the "required
pressure" slider (Control panel -> Text input settings -> thumb board) Still
the activation of the thumboard is unreliable.
Comment 2 Roope Rainisto nokia 2007-07-30 14:19:34 UTC
Is this related to a specific text input field / application (like the Home
applet, or the browser), or do you encounter the same behaviour in all of the
applications?
Comment 3 Per Wille 2007-07-30 15:03:37 UTC
(In reply to comment #2)
> Is this related to a specific text input field / application (like the Home
> applet, or the browser), or do you encounter the same behaviour in all of the
> applications? 

In all applications. 

I have just done some testing. To me it seems that the shorter time my thumb
actually touches the screen the bigger are the chances of the vkb to appear.

So: 
Pressing the screen with my thumb for 1 sec produces the stylus keyboard
Tapping the screen with my thumb for <<1sec produces the virtual keyboard
Comment 4 Jake Kunnari 2007-08-17 15:46:11 UTC
How often you are getting "wrong" keyboard? I have tested this with same IT OS
version, and my results are 1 out of 10 attemps wrong keyboard.
Comment 5 Per Wille 2007-08-20 14:40:28 UTC
(In reply to comment #4)
> How often you are getting "wrong" keyboard? I have tested this with same IT OS
> version, and my results are 1 out of 10 attemps wrong keyboard.

Pressing screen with thumb (like I would have done with the old fw): 10 out of
10 wrong

Tapping screen with thumb (see #3): 1 out of 10 wrong
Comment 6 Jake Kunnari 2007-08-21 12:11:15 UTC
Re-assigned to correct person.
Comment 7 Roope Rainisto nokia 2007-08-21 12:18:02 UTC
Sounds like a technical issue, adding Tomas to CC.
Comment 8 pgruebele 2008-01-08 16:23:14 UTC
This problem still exists in the released OS2008, so I tried to change bug
version to 4.0 but was unable.  Can the assignee do this?  Also, priority
should be Normal, I think because this is pretty annoying...

In addition to requiring a VERY short touch to bring up the finger keyboard, it
also requires a rather firm touch.  There should be a way to set this
sensitivity....  I am a new N800 user but my impression is that previous OS
versions had a feature for setting pressure level?
Comment 9 Eero Tamminen nokia 2008-01-08 16:48:42 UTC
(In reply to comment #8)
> In addition to requiring a VERY short touch to bring up the finger keyboard,
> it also requires a rather firm touch.  There should be a way to set this
> sensitivity....

Thumb detection is based on "pressure" reported by the touchscreen
hardware and the touched area affects this more than the force you use.
If you use the flat side of your fingers instead of the side, it works
better.
Comment 10 pgruebele 2008-01-08 16:53:52 UTC
I do use the flat part of my thumb and it works very poorly.  As I said, others
I know also have the same problem.  It's just not usable...  It does not seem
to matter whether I use the flat side or not.  What matters is that I press
hard and VERY fast.
Comment 11 Lex Landa 2008-01-19 05:24:48 UTC
I have an N800 running OS2008 2.2007.50-2.  I've never been able to activate
the finger keyboard, unless input settings are set to 'launch finger keyboard
with [cursor button]'.  Since upgrading to 2.2007.50-2, the touch screen
response seems erratic.
Comment 12 Delio 2008-03-01 00:13:02 UTC
Recently flashed OS2007 on my N800 and found that I can reliably bring up the
thumb keyboard while in OS2008 it just does not work (once in 5 attempts).

Also noticed using maemopadplus that pressure information applies to brush
color/size on OS2007 while on OS2008 pressure makes no difference.
Comment 13 Leif Ryge 2008-03-01 01:31:59 UTC
I too am unable to launch the finger keyboard with a finger tap on OS2008.
I've tried many times, and it has not worked for me (even once) since
upgrading.
Comment 14 Matti Savolainen 2008-03-29 02:27:04 UTC
Light is seen at the end of the tunnel... on wk 13 Diablo firmware the finger
detection appear to work. :-)
Comment 15 Andre Klapper maemo.org 2008-06-04 12:06:55 UTC
This will be fixed in Diablo (4.1) - looking forward to user comments when it's
out.

Forwarding from the internal ticket:

"------- Comment  #35 From 2008-03-31 15:00:37 -------

* Notes and Email applications invoke the finger keyboard clearly better now.
It is still not perfect but usable. The touch is recognized as a finger more
reliably if the touch area is large, so instead of applying just the finger tip
one should press so that everything till the first joint of the finger (about
20 mm) touches the screen. The push should preferably be rather heavy. There is
some variation depending on the part of the screen that is pressed.

* It is difficult to get the finger keyboard visible by pressing a narrow touch
area like the Google search bar (Home view and Browser start page) or the URL
box (Browser).

My verdict is satisfactory and verified."
Comment 16 Ryan Abel maemo.org 2008-06-05 01:07:25 UTC
*** Bug 2621 has been marked as a duplicate of this bug. ***