Bug 1621 - (int-93774) gpsd installed in /usr/sbin/ instead of /usr/bin/
(int-93774)
: gpsd installed in /usr/sbin/ instead of /usr/bin/
Status: RESOLVED WONTFIX
Product: Location
General
: 4.1.2 (4.2008.36-5)
: All Maemo
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: location-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-07-06 12:16 UTC by Jussi Kukkonen
Modified: 2008-12-30 18:26 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jussi Kukkonen (reporter) 2007-07-06 12:16:42 UTC
I've spent a day trying to get the libgpsbt examples working before I realized
that gpsbt looks for gpsd in the path, when it's actually in /usr/sbin/.

Possible solutions:
 * gpsd should be in the path (debian has gpsd in /usr/bin/, 
   I don't know why it's moved to /usr/sbin/ in osso-gpsd)
 * alternatively GPSD_PROG environment variable could be set to
"/usr/sbin/gpsd".
Comment 1 Karsten Br├Ąckelmann 2008-05-23 15:00:47 UTC
Re-setting the assignee, since Carlos moved on to other tasks.

Please note that this does not affect the legitimacy of the bug in any way.
It's a purely administrative operation. Sorry for the noise.
Comment 2 Eero Tamminen nokia 2008-06-26 10:41:12 UTC
This seems to belong to connectivity.


> I've spent a day trying to get the libgpsbt examples working before I realized
> that gpsbt looks for gpsd in the path, when it's actually in /usr/sbin/.

/usr/sbin/ isn't in users PATH even in desktop.


> Possible solutions:
>  * gpsd should be in the path (debian has gpsd in /usr/bin/, 
>    I don't know why it's moved to /usr/sbin/ in osso-gpsd)

I'd say that the bug is frivolous difference to upstream package and that
is what should be fixed.  Maemo packaging policy forbids that (without
valid, publicly documented reason).
Comment 3 Andre Klapper maemo.org 2008-07-15 18:28:52 UTC
so is this a feature request or a bug? if the latter i'm going to forward this
to the internal system, if the former i can only cross fingers currently...
Comment 4 Jussi Kukkonen (reporter) 2008-07-21 13:19:14 UTC
(In reply to comment #3)
> so is this a feature request or a bug? if the latter i'm going to forward this
> to the internal system, if the former i can only cross fingers currently...

Andre, when I filed the bug the libgpsbt examples on maemo.org failed miserably
because of this, so it is/was definitely a bug. Those examples do not exist
anymore (for 4.x) but my test app is available[1], see the "setenv" I had to
add to get it working. Sorry, can't test what happens on 4.1 myself (no
environment available at the moment, not to mention less interest in debugging
closed components like gpsbt).

[1]
https://garage.maemo.org/plugins/scmsvn/viewcvs.php/gpstest/gps-test.c?revision=17&root=geoclue&view=markup
Comment 5 Andre Klapper maemo.org 2008-12-01 12:46:26 UTC
WONTFIX for Diablo and INVALID for Fremantle because of some underlying changes
that will "fix" this.
Comment 6 Quim Gil nokia 2008-12-30 18:26:01 UTC
Resolving as WONTFIX instead of INVALID.

The report is valid, but it won't be fixed.