Bug 1568 - generate PDFs for each maemo.org page
: generate PDFs for each maemo.org page
Status: RESOLVED FIXED
Product: Developer Guide
maemo.org wiki
: unspecified
: All Linux
: Low enhancement (vote)
: ---
Assigned To: Henri Bergius
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-06-23 17:46 UTC by Ferenc Szekely
Modified: 2010-05-17 16:23 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ferenc Szekely (reporter) maemo.org 2007-06-23 17:46:22 UTC
There is a demand of having PDF versions of many of the maemo.org pages. Please
enable PDF generation for each page. 
Later this may involve some style changes (adding a pdf icon to pages?), so I
cc: Niels from the beginning. 
The issue is assigned to Oskari for now. Oskari, please reassign it if
necessary.
Comment 1 Oskari Kokko 2007-06-26 15:45:10 UTC
Reassigning, this is somethting that rambo will have to think
Comment 2 eero.afheurlin 2007-06-27 14:17:17 UTC
HTMLDoc (http://www.htmldoc.org/index.php) can be used to create PDFs from HTML
pages (single or collections).

Making a simple component that accepts and URL as GET/POST parameter and
returns whatever htmldoc does should be just a few hours, extra points for
proper cache and expiry handling (otherwise it must operate in no-cache mode to
bypass squid).
Comment 3 Ferenc Szekely (reporter) maemo.org 2007-07-06 16:02:28 UTC
Sounds good. When can we schedule this?
Comment 4 Ferenc Szekely (reporter) maemo.org 2007-07-16 11:46:36 UTC
Can we get an estimate please?
Comment 5 Ferenc Szekely (reporter) maemo.org 2007-08-06 18:04:19 UTC
Any news on this?
Comment 6 Ferenc Szekely (reporter) maemo.org 2007-08-14 02:51:09 UTC
Seems you don't like this request :) Whom shall I assign it to?
Comment 7 Jarmo Tikka nokia 2008-06-26 14:39:16 UTC
For Diablo we now have all release documentation available also as PDF files.
http://maemo.org/maemo_release_documentation/maemo4.1.x/
Comment 8 Andre Klapper maemo.org 2008-10-30 19:02:04 UTC
Moving Documentation component from maemo.org to Development Platform since the
bugs there refer to official developer documentation and this falls out of the
responsibility of the community.
Sorry for the noise, you can filter your bugmail by searching for this comment.
Comment 9 Andre Klapper maemo.org 2010-05-17 16:23:59 UTC
[Rearrangement of Documentation bug reports.]
Mass-moving old closed Developer Platform > Documentation tickets.
You can filter bugmail by searching for this comment.