Bug 1553 - Headphone hardware button should act as pause button
: Headphone hardware button should act as pause button
Status: RESOLVED MOVED
Product: Media player
General
: 5.0/(1.2009.44-1)
: All Maemo
: Low normal with 12 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-06-18 02:35 UTC by David Hagood
Modified: 2010-12-03 23:17 UTC (History)
14 users (show)

See Also:


Attachments
A simple program that (un)pauses media player on headphone button press (1.87 KB, text/x-csrc)
2009-03-02 12:11 UTC, Santtu Lakkala
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description David Hagood (reporter) 2007-06-18 02:35:09 UTC
In the first version of the N800 firmware, the button on the headphone would
pause and resume the media player, assuming the media player was playing a clip
and was the active application.

Now the button does nothing. XEV shows the button is still generating the
X86_Phone key event, so the flesh is willing, but the spirit is weak.

Steps to reproduce:
1) Plug in the Nokia supplied headset into the N800
2) Start media player.
3) Start a clip playing.
4) Press button on the headset.

Expected results.
Player should pause and resume.

Actual results.
No change in player behavior.
Comment 1 Faheem Pervez maemo.org 2008-06-22 18:18:33 UTC
Bumpage, but I wrote a daemon which pauses/plays the currently playing track by
pressing the headset button:
http://www.internettablettalk.com/forums/showthread.php?p=194256#post194256

It works in the latest OS2008 version fine and it should be version independent
(works on monitoring DBUS for the dbus signal that is received when pressing
the button and sending the pause signal to osso-media-server)
Comment 2 Andre Klapper maemo.org 2008-10-29 16:47:46 UTC
Still an issue, I assume?
Probably wontfix as there is a solution available...
Comment 3 Neil MacLeod maemo.org 2008-10-29 19:35:02 UTC
(In reply to comment #2)
> Probably wontfix as there is a solution available...

Andre - all credit to Faheem for providing a workaround for this bug, but is
adding another daemon or any other kind of community workaround really the best
solution in this case?

Surely the best - and correct - solution is for Nokia to fix the regression
that has resulted in the previously useful Media Player functionality from
somehow breaking in a later firmware release.

I don't think this should be closed as WONTFIX simply because there is a
workaround - the original functionality should be restored and users should not
have to download and install community workarounds to restore functionality
that used to work out of the box.

The only reason this (and any similar) bug should be marked as WONTFIX is if
there is a plausible justification for why the original feature cannot be
restored (hardware problem with the headphone socket, for example). I doubt
that is the case here.
Comment 4 Andre Klapper maemo.org 2008-11-25 17:31:40 UTC
> In the first version of the N800 firmware, the button on the headphone would
> pause and resume the media player, assuming the media player was playing a clip
> and was the active application.

Is this feature documented somewhere? Any URL? I can't find it mentioned in the
N800/N810 user guides. If it's more of an undocumented feature then you can't
expect support, stable API or testing for this, and it becomes an enhancement
request. The ITt thread also does not mention that it's a regression.
Comment 5 Neil MacLeod maemo.org 2008-11-25 18:45:01 UTC
You're right this functionality isn't mentioned in the N800 user guide but then
the user guide makes no mention of headphones or the supplied HS-48 headset
with microphone and answer button at all!

I guess we need someone to comment who has access to the specification,
hopefully someone saw fit to document this useful feature.
Comment 6 Andre Klapper maemo.org 2008-12-02 13:43:12 UTC
(In reply to comment #5)
> I guess we need someone to comment who has access to the specification,
> hopefully someone saw fit to document this useful feature.

Found this chapter in an old version of the Media Player Spec:

"Interaction affected by headset
The Media player supports basic wired headphones. Speaker output should be
routed to headphones while plugged in. No interaction with possible buttons of
headset is used."
Comment 7 Quim Gil nokia 2009-01-31 00:15:11 UTC
I can reproduce the original report with Fremantle and the N810 headset. Worth
looking at Fremantle specs since headset support is improved at least in the BT
side, so maybe...
Comment 8 Quim Gil nokia 2009-01-31 23:06:41 UTC
Argh, wait.

I didn't think about the obvious: Fremantle needs to be compatible with the
headset(s) _coming with it_ , so to say. I have no idea about the plans but
just in case I'll try to find one of those headsets with more buttons shipped
with e.g. th N95 and test to see what happens.
Comment 9 Neil MacLeod maemo.org 2009-01-31 23:24:52 UTC
(In reply to comment #8)
> Argh, wait.
> 
> I didn't think about the obvious: Fremantle needs to be compatible with the
> headset(s) _coming with it_ , so to say. I have no idea about the plans but
> just in case I'll try to find one of those headsets with more buttons shipped
> with e.g. th N95 and test to see what happens.
> 

Exactly. Just as the N800 and N810 both came with the same set of headphones
with a single button (which, as we know on the N800 originally functioned as
play/pause) and virtually all Nokia phones now seem to come with a headset with
at least one button (for example, the N85 comes with an in-line multi-media
remote control - pause/play, stop, ff, rew, call answer/end, volume up/down -
that can be used with my own headphones/headset) I think it highly likely that
the future Freemantle tablet WILL be supplied with a headset of some
description with at least one button...

Adding support for the N85 remote control would be going beyond the call of
duty but would certainly protect yourself from the product planners who may
slip one into the packaging! :) They probably cost pennies, but are great
value-add.
Comment 10 Andre Klapper maemo.org 2009-02-02 12:40:39 UTC
(In reply to comment #7)
> I can reproduce the original report with Fremantle and the N810 headset. Worth
> looking at Fremantle specs since headset support is improved at least in the BT
> side, so maybe...

Current Fremantle Media Player Spec mentions:
"Some headsets that are compatible with the device may have some keys. These
keys [...] work like they were the UI keys."

So I'm going to close this as FIXED for Fremantle as it's a requirement to work
with headsets that were defined as compatible.
Comment 11 Santtu Lakkala 2009-03-02 12:11:07 UTC
Created an attachment (id=1131) [details]
A simple program that (un)pauses media player on headphone button press

This is a little hack prog that listens for the hal event on the button press
and calls appropriate method on media server (why isn't it's API public, had to
use dbus-monitor to dig out the specifics).

Compile with cc hp-btn.c -o hp-btn `pkg-config dbus-1 --cflags --libs`;
requires libdbus-1-dev and osso-systemsound-dev.
Comment 12 Lucas Maneos 2009-06-09 05:22:56 UTC
Another data point: I recently bought a Nokia WH-700 headset, which is listed
as compatible with the N810WE
(<http://europe.nokia.com/find-products/accessories/all-accessories/headsets/wired-headsets/nokia-stereo-headset-wh-700/compatibility>,
with the tablet link pointing to the "vanilla" N810 product page).

None of the buttons do anything: no dbus or xev events, doesn't answer VoIP
calls etc.  The HS-48 works fine of course.  In hindsight I shouldn't have made
any compatibility assumptions (I have every tablet except the WiMax model), 
caveat emptor and all that.

Still, it would be interesting to know: do the WH-700 buttons work on the
N810WE, and if so is the difference on the hardware or software side? 
Basically I'm wondering if there's any tweaking (eg custom kernel or hal
config) that could make multi-button headsets functional...
Comment 13 Lucas Maneos 2009-10-17 14:23:51 UTC
(In reply to comment #8)
> Fremantle needs to be compatible with the headset(s) _coming with it_

Reopening: the N900-bundled headset's buttons do nothing in media player, and
Nokia_N900_Rover_en-US_es-LAM.pdf says:

> Headset
> 
> You can connect a compatible headset or compatible
> headphones to your device. Nokia headsets with music
> controls can also be used, but the device does not support
> the music controls.

The on-device guide doesn't mention wired headsets at all.
Comment 14 Andre Klapper maemo.org 2009-10-17 15:03:12 UTC
Just a general comment: Nokia_N900_Rover_en-US_es-LAM.pdf is not online anymore
and was not the final version.
Comment 15 Andre Klapper maemo.org 2009-10-27 17:05:31 UTC
*** Bug 5843 has been marked as a duplicate of this bug. ***
Comment 16 Lucas Maneos 2009-10-30 10:51:41 UTC
*** Bug 5904 has been marked as a duplicate of this bug. ***
Comment 17 Lucas Maneos 2009-10-30 11:12:46 UTC
This may be related: after connecting the bundled headset (WH-205) to the N900,
the icon that appears in the status area is the headphones instead of the
headset one.  Cf the on-device documentation at
<file:///home/user/MyDocs/.documents/User%20Guides/.en/GUID-AC4CE924-A020-4665-B123-E9AE0494A4CD.html#d0e1282>.

This headset is listed as compatible with the 770, N810, N810WE and N900
(strangely not the N800) at
<http://europe.nokia.com/find-products/accessories/all-accessories/headsets/wired-headsets/nokia-stereo-headset-wh-205/compatibility>.
Comment 18 Alex 2009-11-26 20:21:01 UTC
If this gets implemented I would suggest also having double-tap/triple tap
headset button for track skip. It would be nice for commuting/walking around.
Comment 19 Andre Klapper maemo.org 2009-12-02 17:09:05 UTC
*** Bug 6486 has been marked as a duplicate of this bug. ***
Comment 20 Pelau Vadim 2010-01-11 18:10:07 UTC
(In reply to comment #1)
> Bumpage, but I wrote a daemon which pauses/plays the currently playing track by
> pressing the headset button:
> http://www.internettablettalk.com/forums/showthread.php?p=194256#post194256
> 
> It works in the latest OS2008 version fine and it should be version independent
> (works on monitoring DBUS for the dbus signal that is received when pressing
> the button and sending the pause signal to osso-media-server)
> 

I suggested we should have a control panel applet that could recognize and
configure the input from more than one headset type, please check my
brainstorm:
http://maemo.org/community/brainstorm/view/headset_button_input_reader
Comment 21 Quim Gil nokia 2010-01-12 15:36:46 UTC
Changing severity to Normal in order to be treated as a bug.
Comment 22 Andre Klapper maemo.org 2010-01-13 21:07:35 UTC
(In reply to comment #20)
> I suggested we should have a control panel applet that could recognize and
> configure the input from more than one headset type, please check my
> brainstorm:
> http://maemo.org/community/brainstorm/view/headset_button_input_reader


I tend to close this as "MOVED to Brainstorm" as per comment 20.
Any objections, agreements, rants? ;-)
Comment 23 Pelau Vadim 2010-01-13 21:53:52 UTC

(In reply to comment #22)
> (In reply to comment #20)
> > I suggested we should have a control panel applet that could recognize and
> > configure the input from more than one headset type, please check my
> > brainstorm:
> > http://maemo.org/community/brainstorm/view/headset_button_input_reader
> 
> 
> I tend to close this as "MOVED to Brainstorm" as per comment 20.
> Any objections, agreements, rants? ;-)
> 

I'd agree but a voting boost would be nice as well, but I fear some of the guys
aren't that active anymore, or are they?

NOW I SEE THE VOTES GOT LOST, PREVIOUSLY HTERE WER 10! maybe because I edited
it?

Anyway here's the link:
http://maemo.org/community/brainstorm/view/headset_button_input_reader
Comment 24 Andre Klapper maemo.org 2010-01-13 22:07:55 UTC
(In reply to comment #23)
> NOW I SEE THE VOTES GOT LOST, PREVIOUSLY HTERE WER 10! maybe because I edited
> it?

No need for capital letters, please be nice towards my eyes. ;-)
If you are totally sure that votes have been lost, feel free to file a bug
report against Brainstorm (Bugzilla > maemo.org Website > Brainstorm) with good
info, if possible.
Comment 25 Pelau Vadim 2010-01-13 22:15:47 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > NOW I SEE THE VOTES GOT LOST, PREVIOUSLY HTERE WER 10! maybe because I edited
> > it?
> 
> No need for capital letters, please be nice towards my eyes. ;-)
> If you are totally sure that votes have been lost, feel free to file a bug
> report against Brainstorm (Bugzilla > maemo.org Website > Brainstorm) with good
> info, if possible.
> 

Sorry, but it's very disappointing.
I posted a thread in the brainstorm forums for now...
Comment 26 Andre Klapper maemo.org 2010-01-15 17:41:27 UTC
The scope of bugs.maemo.org are bugs and only very specific and no-brainer
enhancement requests. This report contains a feature request that is too
generic for bugs.maemo.org. Please post this problem and propose your
solution in Maemo Brainstorm instead:
  http://maemo.org/community/brainstorm/

More information: http://wiki.maemo.org/Maemo_brainstorm
Comment 27 Andre Klapper maemo.org 2010-02-09 01:28:41 UTC
*** Bug 8367 has been marked as a duplicate of this bug. ***
Comment 28 Andre Klapper maemo.org 2010-12-03 23:17:28 UTC
*** Bug 11660 has been marked as a duplicate of this bug. ***