Bug 1381 - No maemo wiki specific search
: No maemo wiki specific search
Status: CLOSED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All All
: Medium major (vote)
: ---
Assigned To: Ferenc Szekely
:
: http://maemo.org/community/wiki
:
:
:
  Show dependency tree
 
Reported: 2007-05-10 10:54 UTC by Jarmo Tikka
Modified: 2007-11-30 11:13 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jarmo Tikka (reporter) nokia 2007-05-10 10:54:10 UTC
With new maemo wiki is is no longer possible to search only wiki any more. the
scope of maemo search is the whole site including mailing list archives etc.

It would be very nice feature to be able to define the scope of search. 
- whole site, 
- only wiki, 
- only official documentation, 
- only maemo 3.x documents, 
- etc.
Comment 1 Ferenc Szekely maemo.org 2007-05-10 14:12:17 UTC
there was no requirement for this.
Comment 2 Jussi Kukkonen 2007-05-10 14:45:06 UTC
(In reply to comment #1)
> there was no requirement for this.

I don't think WONTFIXing a serious usability bug is the right option even if
it's 'as designed'... maybe mark as LATER if you really have to resolve it?

The search engine hasn't indexed the new site yet, but if the results are
anything like the current ones, there is a serious problem with searching: All
search results are dominated by mailing list archives, with all other good hits
buried several pages down in the results list. Previously this wasn't a problem
as wiki had a search of its own.

Example: search for "repositories". There are several very relevant pages about
that subject in the wiki, but still the first wiki hit (wiki front page) is on
page 4 of the results. The "correct" wiki hit, ApplicationRepositories-page is
nowhere to be seen.

Complex search options aren't necessarily needed. The primary requirement is
that wiki pages are discoverable by searching. This can be achieved by tweaking
the "pagerank algorithm" or adding a wiki-specific search.
Comment 3 Jarmo Tikka (reporter) nokia 2007-05-10 14:58:46 UTC
Reopened because this is enhancement request and not bug report.

If technical study shows that search scopes are not doable with current
Google mini search engine or Midgard does not support search in wiki
close this again. Otherwise add this to the roadmap of coming maemo.org
releases.
Comment 4 Quim Gil nokia 2007-05-10 16:25:36 UTC
This is a functionality that existed in the previous wiki and is useful. Oskar
is looking at setting a search wiki-wide, it is apparently doable.

Once this is solved and the major problems are out of the way we will see what
we do with the search since overall is currently not satisfactory. If someone
wants to come up with a feature request detailing the perfect search engine
functionality now is the right time to do it. In a new report, please, so here
we stay focused in the wiki search.
Comment 5 Quim Gil nokia 2007-06-29 12:50:54 UTC
Please don't work on this until we have decided what to do with the wiki.
Thanks.
Comment 6 Ferenc Szekely maemo.org 2007-07-04 12:03:10 UTC
I take this. Now we got the google license upgrade, so we can index the wiki
pages.
Comment 7 Quim Gil nokia 2007-07-16 03:20:05 UTC
Still not working and people keeps complaining frequently. Considered major
issue.
Comment 8 Ferenc Szekely maemo.org 2007-07-16 11:34:07 UTC
It does work. Even searching through the frontpage will return wiki results,
but you can also specify the wiki collection at search.maemo.org.
Comment 9 Jarmo Tikka (reporter) nokia 2007-11-21 16:56:54 UTC
Reopened this bug. You are still not able to scope the search. In advanced
search we have predefined scopes and even they do not work. E.g. searching
using maemo documentation as scope returns search results also from maemo
planet, rss feeds, Intro roadmap etc...
Comment 10 Quim Gil nokia 2007-11-22 09:23:41 UTC
Removing the "High" flag, although Ferenc is working on the search these days
and he might want to pick this up.

From comment #8 

> you can also specify the wiki collection at search.maemo.org

No, you can't.  :)

If the current scopes don't work then please file a new bug (if it's not
created yet, haven't checked).

In any case the plan as for today is to have the wiki converted to
docs.maemo.org merging official and unofficial documentation and having a fully
functional search.
Comment 11 Ferenc Szekely maemo.org 2007-11-27 02:28:44 UTC
fixed. check http://search.maemo.org. you can select to search only in
maemo.org wiki. please don't report a bug on outdated index, the crawler is
being indexing all pages again.
Comment 12 timeless 2007-11-27 13:19:12 UTC
verified:
there is a wiki specific search
http://search.maemo.org/search?q=&site=wiki&output=xml_no_dtd&client=maemo-org&proxystylesheet=maemo-org

or reachable from:
http://search.maemo.org and selecting it in the drop down.

however, the search field for this bug's url <http://maemo.org/community/wiki>
takes to a different specific search which yields slightly different results.
- that probably deserves its own bug (please don't reopen)

comment 0 asked for a number of searches, the following exist:

<option value="maemo-org" selected>maemo.org documentation</option>
<option value="wiki">maemo.org wiki</option>
<option value="mail_archive">Mail Archive</option>
<option value="garage">garage projects</option>
<option value="applications">Application Catalog</option>
<option value="profiles">user profiles</option>

these definitely don't:
- only official documentation, 
- only maemo 3.x documents, 

however, they should be requested as distinct bugs (morphing bugs results in
zombies, don't do it).
Comment 13 Jake Kunnari 2007-11-28 13:03:37 UTC
Closing. Resolution has been verified.