Bug 1282 - (int-109976/110265) List new applications in Application Manager
(int-109976/110265)
: List new applications in Application Manager
Status: RESOLVED WONTFIX
Product: Settings and Maintenance
Application manager
: 5.0-beta
: All All
: Low enhancement with 28 votes (vote)
: ---
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-05-02 20:58 UTC by pepitoe
Modified: 2010-06-09 12:24 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description pepitoe (reporter) 2007-05-02 20:58:46 UTC
Currently there does not appear to be a way to find out what new applications 
have been added to the repositories from application manager.  It would be 
nice if there could be 'New' tags shown next to recently published 
applications, it would also be good if the applications could be sort by date 
added/updated.  At the moment after you have added a few repositories you end 
up with a long list of applications and it is hard to spot anything 
new/interesting.
Comment 1 Andre Klapper maemo.org 2008-07-21 13:21:39 UTC
*** Bug 2942 has been marked as a duplicate of this bug. ***
Comment 2 konemail35 2008-10-06 18:10:15 UTC
*** Bug 3778 has been marked as a duplicate of this bug. ***
Comment 3 Ville Reijonen 2008-10-31 19:02:28 UTC
There should be a separate view where all the new software additions would be
visible, sorted by the appearance date. This way one could see the new
additions from few day ago even after few repository refreshes. (See
maemo.org/downloads -> fresh for example)
Comment 4 Quim Gil nokia 2008-12-09 10:53:25 UTC
Now this enhancement request is in the top 10 of the Bug Jar. And at the same
time the AM is moving to open development. 

Any feature bringing significant UI changes (and this one does, apparently)
needs to hurry in order to make it to Fremantle official, although there is a
git and an svn for all kinds of parallel experimentation.
Comment 5 Quim Gil nokia 2009-01-08 18:00:04 UTC
Marius,any plans todeliver this feature in Fremantle? If not, any
plans/opinions for Harmattan?
Comment 6 Andre Klapper maemo.org 2009-01-26 16:37:09 UTC
(In reply to comment #5)
> Marius,any plans todeliver this feature in Fremantle? If not, any
> plans/opinions for Harmattan?

Marius: ping
Comment 7 Andre Klapper maemo.org 2009-03-24 13:57:04 UTC
Marius, any plans to deliver this feature in Fremantle? If not, any
plans/opinions for Harmattan?
Comment 8 Javier Jardón 2009-03-29 20:31:06 UTC
This bug is still valid in 4.1.3 (5.2008.43-7) release
Comment 9 Andre Klapper maemo.org 2009-04-09 13:15:36 UTC
*** Bug 2941 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2009-05-05 17:39:38 UTC
WONTFIX for Fremantle (would require excessive changes) according to Nokia.
Patches welcome. Crossing fingers for Harmattan. :-/
Comment 11 Ryan Abel maemo.org 2009-05-05 18:25:59 UTC
(In reply to comment #10)
> WONTFIX for Fremantle (would require excessive changes) according to Nokia.
> Patches welcome. Crossing fingers for Harmattan. :-/
> 

WONTFIX, but patches welcome. Does that mean _no_ chance for integration in
Fremantle? . . . Harmattan better be 5.1. :\
Comment 12 Andre Klapper maemo.org 2009-05-05 18:51:08 UTC
(In reply to comment #11)
> WONTFIX, but patches welcome. Does that mean _no_ chance for integration in
> Fremantle? . . . Harmattan better be 5.1. :\

I don't know exactly how strict Nokia's guidelines are here, and I don't know
whether we have passed any internal freezes already (e.g. a feature freeze).
It is definitely not planned for Fremantle as this seems to be more complex
than expected.
Comment 13 Andre Klapper maemo.org 2009-05-05 19:08:04 UTC
So, forwarding an internal comment again here:
"It requires extensive changes in the Application manager, though, since it
would need to start keeping track of when a package was first seen.  I don't
think there is any information in the repositories that could be used to sort
packages by age. (Maybe I am wrong, I would have to check carefully.)"
Comment 14 Javier Jardón 2009-05-05 19:29:04 UTC
aptitude ( http://en.wikipedia.org/wiki/Aptitude_(program) ) already has this
functionality. Maybe you can take a look on it
Comment 15 Andre Klapper maemo.org 2009-05-05 19:49:04 UTC
(In reply to comment #14)
> aptitude ( http://en.wikipedia.org/wiki/Aptitude_(program) ) already has this
> functionality. Maybe you can take a look on it 

This is not helpful - completely different codebase.
Comment 16 Daniel Martin Yerga 2009-05-05 23:04:32 UTC
(In reply to comment #10)
> WONTFIX for Fremantle (would require excessive changes) according to Nokia.
> Patches welcome. Crossing fingers for Harmattan. :-/
> 

Where is the code for the Fremantle Application Manager? Is the one available
in the SDK?
Comment 17 Niels Breet maemo.org 2009-05-06 10:34:20 UTC
(In reply to comment #16)
> Where is the code for the Fremantle Application Manager? Is the one available
> in the SDK?
> 
I guess the current code is available here:
http://repository.maemo.org/pool/maemo5.0beta/free/h/hildon-application-manager/
Comment 18 Daniel Martin Yerga 2009-05-06 21:05:19 UTC
(In reply to comment #17)
> I guess the current code is available here:
> http://repository.maemo.org/pool/maemo5.0beta/free/h/hildon-application-manager/
> 

Yeah, I know where that code is ;)
I was asking if this code is going to be in the device with Maemo 5 or the code
is far different from the one available in the SDK repository.

It's not very useful start hacking that code if the real Application Manager
bundled in the device is not the same. Just want to be sure before I try
something.
Comment 19 Quim Gil nokia 2009-05-06 22:50:00 UTC
The AM shipped in the beta is the same of the internal releases. The gap now is
few weeks, which shouldn't be that relevant for patches since they are
basically in bugfix mode now.
Comment 20 Ryan Abel maemo.org 2009-05-06 23:08:11 UTC
(In reply to comment #19)
> The AM shipped in the beta is the same of the internal releases. The gap now is
> few weeks, which shouldn't be that relevant for patches since they are
> basically in bugfix mode now.
> 

Yeesh, what have they been doing for the past year, then?
Comment 21 Andre Klapper maemo.org 2010-06-09 12:24:50 UTC
This is not planned for the Application Manager in Maemo6 (also as some
concepts will change but too early to tell).