Bug 12726 - Cannot submit a bug report
: Cannot submit a bug report
Status: NEW
Product: maemo.org Website
Garage
: unspecified
: other other
: Low normal (vote)
: ---
Assigned To: Ferenc Szekely
: garage@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2014-02-05 15:07 UTC by Sami Tainio
Modified: 2014-02-05 20:10 UTC (History)
1 user (show)

See Also:


Attachments
Step-by-step with screenshots. (386.86 KB, application/zip)
2014-02-05 15:07 UTC, Sami Tainio
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Sami Tainio (reporter) 2014-02-05 15:07:59 UTC
Created an attachment (id=3478) [details]
Step-by-step with screenshots.

EXACT STEPS LEADING TO PROBLEM: 

See attachments as step by step how to reproduce this issue. I tested this with
Firefox 27 and Internet Explorer 11. This issue was reproduced on both of them.

1. https://garage.maemo.org/tracker/?atid=5565&group_id=1544&func=browse
- Choose the Submit New.
2. https://garage.maemo.org/tracker/?func=add&group_id=1544&atid=5565
- Fill in the information and click Submit.
3. https://garage.maemo.org/tracker/index.php?group_id=1544&atid=5565
- After clicking the submit it gives the error:

"ERROR

Artifact: ERROR: syntax error at or near "accounts" LINE 27: if \'accounts\'
not in self.config.sections: ^"

EXPECTED OUTCOME: Successful submitting of a bug report.

ACTUAL OUTCOME: "ERROR

Artifact: ERROR: syntax error at or near "accounts" LINE 27: if \'accounts\'
not in self.config.sections: ^" See attachment 3 [details].png for screenshot of this.

REPRODUCIBILITY: Tested with Firefox 27 and Internet Explorer 11.

EXTRA SOFTWARE INSTALLED: Firefox has an add-on called HTTPS Everywhere.

OTHER COMMENTS: https://garage.maemo.org/ gives error about its security
certificate: "Windows does not have enough information to verify this
certificate.

Issued to: *.maemo.org
Issued by: maemo.org Tech Root CA
Valid from: 8.4.2013 to 8.4.2015

The issuer of this certificate could not be found."
Comment 1 Ferenc Szekely maemo.org 2014-02-05 20:02:07 UTC
Thanks for taking your time and reporting the bug. 

I tried to reproduce it within 2 different garage projects. First as an admin
user and second time as a non admin user. I was able to submit the new bug in
both projects. However this does not mean that the issue is invalid.

For more through analysis one should access the PHP code of garage and do some
tracing / debugging. I used to have access, but I am no longer an active
maintainer of the server(s). I would suggest to forward this issue to the
community council by email or via irc.
Comment 2 Joerg Reisenweber 2014-02-05 20:10:53 UTC
alas there's nothing council could do about it. Council are not maintainers, as
well as techstaff members are not automatically maintainers of all arbitrary
subsystems. Currently there's no maintainer for neither garage nor bugzilla

BR
jOERG (councilor)