Bug 1271 - Can't install python2.5-runtime 0.4-9 on N800
: Can't install python2.5-runtime 0.4-9 on N800
Status: RESOLVED INVALID
Product: Settings and Maintenance
Application manager
: 3.0
: N800 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: application-manager-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-04-27 09:41 UTC by Michael Bernhard Arp Sørensen
Modified: 2008-06-13 15:58 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Michael Bernhard Arp Sørensen (reporter) 2007-04-27 09:41:43 UTC
I can't install python on my N800.

I have version 2.2006.51-6. No changes in standard repositories.

Procedure:
- Open program management.
- Update program/package list.
- Search installable programs.
- All
- Select python2.5-runtime 0.4-9
- Click install
- OK to install
- Fails on dependencies:
libglade2-0 (>=1:2-3-6)
libsdl-ttf2.0-0
libgdbm3

There are even more available programs that is not installable due to missing 
dependencies.

Thanks in advance.
Comment 1 Andre Klapper maemo.org 2008-06-10 12:39:13 UTC
Well...
Can you please install libglade2-0 (>=1:2-3-6), libsdl-ttf2.0-0 and libgdbm3
then? You may need to enable additional repositories for this.
Comment 2 Daniel Martin Yerga 2008-06-12 10:51:27 UTC
I am not the OP, but I will try to explain the problems that existed installing
python previously.

Python was depending on these packages (libglade, etc) that were in the SDK
repository and was necessary to activate this one.  
Nowadays these packages are in extras repository.

Btw, python is a 3rd party application and doesn't belong to bugs.maemo.org
(yet?), this way this bug IMO would be invalid.
Comment 3 Andre Klapper maemo.org 2008-06-13 15:58:12 UTC
Correct - Python is not officially supported at the moment. 

Michael, if this is still an issue please file a bug against PyMaemo at
https://garage.maemo.org/tracker/?atid=229&group_id=40&func=browse .
Thanks in advance!