Bug 12668 - Upgrade libx11 and dependencies
: Upgrade libx11 and dependencies
Status: UNCONFIRMED
Product: Maemo 5 Community SSU
general
: unspecified
: N900 Maemo
: Unspecified enhancement with 1 vote (vote)
: ---
Assigned To: unassigned
: general
:
:
:
:
  Show dependency tree
 
Reported: 2012-09-16 11:39 UTC by Marcin Mielniczuk
Modified: 2012-09-16 11:39 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Mielniczuk (reporter) 2012-09-16 11:39:05 UTC
SOFTWARE VERSION: 
T4-thumb16

EXACT STEPS LEADING TO PROBLEM: 
libX11 and similar are outdated in Maemo 5. The problem is visible for example
here:
1. Run app which uses e.g. XIQueryVersion (e.g. Icy Tower for MeeGo) with
MeeCoLay
2. Undefined symbol error shown

EXPECTED OUTCOME: app runs ok

ACTUAL OUTCOME: Undefined symbol error shown

REPRODUCIBILITY: 
always

EXTRA SOFTWARE INSTALLED: MeeCoLay

OTHER COMMENTS: Note the libxau6 with non-power kernel issue
(http://talk.maemo.org/showthread.php?t=83939)