Bug 12612 - Community Council election process isn't working at all
: Community Council election process isn't working at all
Status: VERIFIED FIXED
Product: maemo.org Website
Elections
: unspecified
: All All
: High blocker with 1 vote (vote)
: ---
Assigned To: Niels Breet
: elections
:
:
:
:
  Show dependency tree
 
Reported: 2012-05-10 22:41 UTC by Piotr Jawidzyk
Modified: 2012-05-16 19:12 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Piotr Jawidzyk (reporter) maemo.org 2012-05-10 22:41:20 UTC
SOFTWARE VERSION: 
All

EXACT STEPS LEADING TO PROBLEM: 
1. Wake up on 6th May, 2012.
2. Check Your mail or maemo.rg website.

EXPECTED OUTCOME: 
Every user with enough karma to participate in voting, should find invitation
to take part in Council election on her/his e-mail. Also, voting process should
start on maemo.org website.

ACTUAL OUTCOME: 
Despite fact that it's 10th May already, voting process haven't started at all.

REPRODUCIBILITY: 
Always.

OTHER COMMENTS: 
During April meeting with Council, SD69 - current Council representative - got
ensured, that Council election "is covered". Despite this, people having access
to infrastructure, haven't push the big red "activate" button in due time.
Please, fix it ASAP.
Comment 1 Dave Neary maemo.org 2012-05-10 23:12:43 UTC
Hi,

(In reply to comment #0)
> During April meeting with Council, SD69 - current Council representative - got
> ensured, that Council election "is covered". Despite this, people having access
> to infrastructure, haven't push the big red "activate" button in due time.
> Please, fix it ASAP.

This got assigned to me, but I have not been involved in Maemo for about 2 to 3
years at this point. I am not even sure that I still have access to the
resources in question (and I never had access to the Midgard user list).

I don't know who this should be assigned to, however. Who is the Nemein contact
for Maemo infrastructure these days?

Dave.
Comment 2 Piotr Jawidzyk (reporter) maemo.org 2012-05-11 01:23:26 UTC
Thanks for Your fast reply, Dave, especially, considering that it shouldn't be
assigned to You.

AFAIK X-Fade is responsible for Maemo infrastructure. At least, he was the one
who assured us, that election is covered...

Thanks again for picking it up. I hope it get covered soon, because, to be
honest, this situations is quite miserable.

/Estel (Piotr Jawidzyk)
Comment 3 Quim Gil nokia 2012-05-11 04:30:14 UTC
Assigning to Niels.
Comment 4 Niels Breet maemo.org 2012-05-11 11:51:01 UTC
I didn't get any specific request from the council yet. I've promised that I
would do the technical part, but need input from the council.

Dates, confirmed list of candidates and text for the election mails is what I
need for setting up the mailing.
Comment 5 Quim Gil 2012-05-11 17:44:16 UTC
Does anybody have the text that was sent in the previous council elections? It
probably can be recycled as is. I couldn't find it in my mailbox, sorry.

The list of candidates:

    Iván Gálvez Junquera / ivgalvez
    Piotr Jawidzyk / Estel
    Joseph Charpak / jcharpak
    Craig Woodward / woody14619
    Arie Mark / Aries
    Niel Nielsen / NielDK
    R Bauer / SD69 

The URL to be included in the email for voters to consider candidates:

http://wiki.maemo.org/Community_Council/Council_election_May_2012/Candidate_declarations

About the dates, I guess it's the current council who needs to decide them.

http://wiki.maemo.org/Community_Council/Election_process says it's one week.

http://wiki.maemo.org/Community_Council/Council_election_Q1/2_2012#Election_timetable
says

May 6: Voting opens
May 13: Voting closes 

Strictly speaking this is 8 days. A common sense decision at this point would
be to start the clock immediately after all the pieces are in place and close
it exactly 1 week after.

Niels, how long do you think it will take after you have the text that was sent
in previous elections?
Comment 6 Joerg Reisenweber 2012-05-11 18:41:07 UTC
(In reply to comment #5)
> Does anybody have the text that was sent in the previous council elections? It
> probably can be recycled as is. I couldn't find it in my mailbox, sorry.

>>------ 8X (snip) -------------
Eingebettete Nachricht
  Maemo Community Council election Q3 2010
Von: 
dneary (at) maemo (dod) org
  An: 
xxx@xxx.com
  Datum: 
2010-09-16 10:14

Dear Paul,

The election of the Maemo Community Council is now open, and you have
received this email as you are eligible to vote. The Maemo Community Council
consists of 5 members who serve a 6 month term, representing the community
to Maemo and helping facilitate community activities. You can learn more 
about the community council at:

    http://wiki.maemo.org/Community_Council

CANDIDATES
----------

The candidates for election are:

   1. Andrea Grandi
   2. Tim Samoff
   3. R�ĵdiger Schiller
   4. Cosimo Kroll
   5. Andrew Flegg
   6. Stephen Gadsby
   7. Felipe Crochik
   8. Robin Burchell
   9. Kathy Smith
  10. Attila Csipa

A full list of candidates and their reasons for running can be found at:

   
http://wiki.maemo.org/Community_Council/Council_election_Q3_2010/Candidate_declarations

HOW TO VOTE
-----------
Voting will run from September 16th 00:00 UTC until September 22 2010, 23:59
UTC.

Your voting credentials are:

   URL: http://maemo.org/vote/ 
E-mail: xxx.xxx@xxx
Vote token: 9X7H??????

After authenticating yourself, you can choose your preferred candidates 
in order of preference. You will have an opportunity to verify and 
confirm your vote afterwards.

Once you have confirmed your vote, a unique secret identifier will be 
given to you which will allow you to verify after the election that your 
vote was counted correctly.

Once you have voted, you will not be able to vote again.

Thank you for your vote!

Regards,
Dave Neary, on behalf of the Maemo community.
>>------ 8X (snip) -------------





>>------ 8X (snip) -------------
Maemo Community Council election Q3 2010
Von: 
dneary ad maemo dod org
  An: 
joerg (at) openmoko (dot) org
  Datum: 
2010-09-17 15:43

Dear Joerg,

Due to reports from several people about problems with voting tokens being 
blocked by mail relays, we are sending this reminder to everyone who has not 
yet voted in the elections, confirming your voting credentials. If you have
already received a voting token and have not yet voted, excuse me for any
disruption.

The election of the Maemo Community Council is now open, and you have
received this email as you are eligible to vote. The Maemo Community Council
consists of 5 members who serve a 6 month term, representing the community
to Maemo and helping facilitate community activities. You can learn more 
about the community council at:

    http://wiki.maemo.org/Community_Council

CANDIDATES
----------

The candidates for election are:

   1. Andrea Grandi
   2. Tim Samoff
   3. R�ĵdiger Schiller
   4. Cosimo Kroll
   5. Andrew Flegg
   6. Stephen Gadsby
   7. Felipe Crochik
   8. Robin Burchell
   9. Kathy Smith
  10. Attila Csipa

A full list of candidates and their reasons for running can be found at:

   
http://wiki.maemo.org/Community_Council/Council_election_Q3_2010/Candidate_declarations

HOW TO VOTE
-----------
Voting will run from September 16th 00:00 UTC until September 22 2010, 23:59
UTC.

Your voting credentials are:

   URL: http://maemo.org/vote/ 
Emil: joerg ad openmoko dod org
Vote token: XiOFQ6???????

After authenticating yourself, you can choose your preferred candidates 
in order of preference. You will have an opportunity to verify and 
confirm your vote afterwards.

Once you have confirmed your vote, a unique secret identifier will be 
given to you which will allow you to verify after the election that your 
vote was counted correctly.

Once you have voted, you will not be able to vote again.

Thank you for your vote!

Regards,
Dave Neary, on behalf of the Maemo community.
>>------ 8X (snip) -------------


HTH
/j
Comment 7 Niels Breet maemo.org 2012-05-14 12:23:34 UTC
I've prepared the data for the election. 

I could send out the mails tomorrow (15th) if everybody agrees.

Dates I set in mails and database for election:
start:  2012-05-15 00:00:00
stop:   2010-05-22 23:59:59

5 spots on the council out of 7 candidates,

Candidate list in mail:
* Ivan Galvez Junquera (ivgalvez)
* Piotr Jawidzyk (Estel)
* Joseph Charpak (jcharpak)
* Craig Woodward (woody14619)
* Arie Mark (Aries)
* Niel Nielsen (NeilDK)
* R Bauer (SD69)


Links in mail:
http://wiki.maemo.org/Community_Council
http://wiki.maemo.org/Community_Council/Council_election_May_2012/Candidate_declarations

Does this all look ok?
Comment 8 Joerg Reisenweber 2012-05-14 12:33:08 UTC
(In reply to comment #7)
> I've prepared the data for the election. 
> 
> I could send out the mails tomorrow (15th) if everybody agrees.
...
> Does this all look ok?

Please send me a testmail, same content (minus token), same sender and
addressee as you plan to send tomorrow. We had problems with spamfilters etc.

Thanks
/j
Comment 9 Niels Breet maemo.org 2012-05-14 13:55:04 UTC
(In reply to comment #8)
> Please send me a testmail, same content (minus token), same sender and
> addressee as you plan to send tomorrow. We had problems with spamfilters etc.
> 

Mail sent.
Comment 10 Joerg Reisenweber 2012-05-14 14:11:55 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Please send me a testmail, same content (minus token), same sender and
> > addressee as you plan to send tomorrow. We had problems with spamfilters etc.
> > 
> 
> Mail sent.

works. 
You might consider posting the text template here, for some others to proofread
as well. Though to me it basically looks fine.

Nevertheless I'm wondering if starting voting period tomorrow is in line with
schedules as defined by the statutes. Anyway I'd prefer a at least a week of
lead time from sending mails to start of voting (not that this ever had been
done like this in previous council elections).

http://wiki.maemo.org/Community_Council#Get_in_contact <- *sigh* on "Finally,
Council members are usually present over IRC at freenode.net/maemo and are
always happy to chat with you." - if only the council members knew about that
;-)

Many thanks Niels for your help!
Comment 11 Quim Gil 2012-05-14 19:51:01 UTC
(In reply to comment #7)
> I could send out the mails tomorrow (15th) if everybody agrees.

I don't know who should agree with. :) Considering that SD69 (current active
Concil member) expected Nials and me to push this, we will act accordingly. 


> Dates I set in mails and database for election:
> start:  2012-05-15 00:00:00
> stop:   2010-05-22 23:59:59

Works for me. At this point it is difficult to interpret how to handle properly
http://wiki.maemo.org/Community_Council/Election_process but one criteria seems
to be clearer: we are late and we need to kick the election.


> 5 spots on the council out of 7 candidates,
> 
> Candidate list in mail:
> * Ivan Galvez Junquera (ivgalvez)
> * Piotr Jawidzyk (Estel)
> * Joseph Charpak (jcharpak)
> * Craig Woodward (woody14619)
> * Arie Mark (Aries)
> * Niel Nielsen (NeilDK)
> * R Bauer (SD69)

Correct.


> Links in mail:
> http://wiki.maemo.org/Community_Council
> http://wiki.maemo.org/Community_Council/Council_election_May_2012/Candidate_declarations
> 
> Does this all look ok?

+1 Good to go at 2012-05-15 00:00:00
Comment 12 Joerg Reisenweber 2012-05-14 20:13:17 UTC
(In reply to comment #11)
> (In reply to comment #7)
> > I could send out the mails tomorrow (15th) if everybody agrees.
> > Does this all look ok?
> 
> +1 Good to go at 2012-05-15 00:00:00

seems a bit colliding to me. I'd guess mails MUST be sent out _before_ start of
voting period.
I'd also assume proper lead times are more important than trying to keep an
arbitrarily picked schedule for the whole process (regarding the "we're late
anyway so let's hurry" argument)

A minimum lead time of 2 days from sending mails to start of voting is needed
to make sure there are no problems with mail delivery - we've seen that with
election before last(?). 
The idea being that everybody received his ballot and can use the full 7 days
voting period from start to end. Otherwise some users are wronged. Esp since
there's been no announcement of when the voting actually starts, some users
might even miss the whole 7 days due to e.g. just staying abroad for next 9
days. With proper timely announcement they might have taken measures to make
sure they poll their mail or whatever. Thus I strongly suggest to start voting
with a longer lead time from sending mails/ballots, maybe Mo 21. of May

/j
Comment 13 Quim Gil 2012-05-14 20:43:46 UTC
... and now here we are Niels and me in this situation where actually none of
us has any preference - neither it's us who should make this call.

Joerg, you have a point. And in any case common sense says that if there is no
consensus the best option is to wait instead of trigger.

http://wiki.maemo.org/Community_Council/Election_process says:
> "The date of the next election will be set by the council chair"

Therefore:

Niels - please DON'T send the emails until the current Council tell us what to
do. I'll reach to SD69.
Comment 14 Quim Gil 2012-05-14 20:48:20 UTC
Sent to council maemo org with copy to Niels:

Please decide election date

Hi, Niels and me are stuck on the point of deciding when should be email sent
and when should the election effectively start.

See https://bugs.maemo.org/show_bug.cgi?id=12612#c13 and previous comments in
that bug report.

Please tell us what to do. It doesn't feel right that Niels or me are the ones
deciding this on behalf of the Council chairman.

-- 
Quim
Comment 15 Jeremiah C. Foster 2012-05-14 22:25:12 UTC
I'm not the council chair (I don't recall us deciding upon a
chairperson) but I am one of the current council members. I think that
we should go ahead on the proposed date, May 15th. I don't think it is
fair to wait much longer than that. We have a number of    nominees, we
have participation from people willing to run the election, and I think
it has been discussed a good deal in this forum and in others, time to
get to a vote.

Regards,

Jeremiah
Comment 16 Piotr Jawidzyk (reporter) maemo.org 2012-05-14 22:57:52 UTC
I don't agree with Jeremiah, and agree with Joerg. After so much time, 2 buffer
days won't do much harm, and got good probability of bringing benefit. 

While this whole "announce via mail" voting system isn't my favorite, we're
working using current statute, and sending mail 2 days before actual voting
start is absolutely minimum, IMO. It also allow us to write proper dates in
Council election page on wiki - now, dates are filled by placeholders...

As so, in my opinion, voting should start on 17th May, and mails announcing it
should be sent ASAP.

/Estel
Comment 17 Niels Breet maemo.org 2012-05-14 23:53:40 UTC
(In reply to comment #16)
> As so, in my opinion, voting should start on 17th May, and mails announcing it
> should be sent ASAP.
> 
Maybe it is just me, but sending out a mail telling me that I can start to vote
in a few days and have one week after the start to complete, seems annoying to
me. 

I like mails with things I can act on now, not wait 2 days after and with the
possibility to forget all about it. 

People tend to vote in directly after they have received their mail with their
token. Do you really want to rely on people remembering to vote in 2 days?
Comment 18 Jeremiah C. Foster 2012-05-15 00:05:47 UTC
Niels is right. It is time to send the mail and activate the vote.
Comment 19 Joerg Reisenweber 2012-05-15 00:14:46 UTC
if you're sending mails out in 6 h and declare a 7 day period of voting to
start in 3 h, you're violating one of the elementary rules in statutes, which
is

2. Elections last for 1 week.

Even worse, you're not allowing all voters an equal time span they can vote,
due to different propagation delays of mail.

Honestly, "annoying to wait", "forgetting to vote during 48h"? c'mon.
Comment 20 Joerg Reisenweber 2012-05-15 00:33:58 UTC
anyway it seems to me the best option is to not at all mention the exact date
of vote period start in mails, and send them out NOW.

In mails you refer to the appropriate wiki-et-al pages (you already do), and
you state that 

beginning of vote period will be announced there in wiki, 

and it will be open for 7 days after opening. Keeps all your options while not
instantly introducing delays to next mandatory step: sending ballots/tokens as
soon as possible.
Comment 21 Piotr Jawidzyk (reporter) maemo.org 2012-05-15 10:44:25 UTC
Niels & Jeremiah, we can't pivot informing about voting to out personal
preferences. Keeping mail/ballots for 2 days isn't hard and doesn't hurt. On
the other hand, getting mail that You can vote for 7 days from NOW - when
You're abroad for a week, or whatsnot, can definitely hurt.

Yet, I can't agree with Joerg, to send mail without election date - I feel it
could bring more confusion than benefit, especially, that date isn't still
present on wiki. For goodness sake, just set voting  date as 17th or 18th and
send e-mails now, and I, or anyone at hand, will update wiki accordingly.

It's quite miserable to debate about "principles" of 3 days for a week or so,
and this is what we;re heading into.

/estel
Comment 22 Jeremiah C. Foster 2012-05-15 11:16:37 UTC
(In reply to comment #21)

Piotr,

> Niels & Jeremiah, we can't pivot informing about voting to out personal
> preferences. 

This is not based on personal preference. This is based on consistency. We
discuss, then we act. Long pauses in between the process only means that people
drop out because they're distracted. 

> Keeping mail/ballots for 2 days isn't hard and doesn't hurt. On
> the other hand, getting mail that You can vote for 7 days from NOW - when
> You're abroad for a week, or whatsnot, can definitely hurt.

I'm thoroughly unpersuaded by your argument. Besides, there is always going to
be *some* kind of arbitrary time period, we can't extend the time period to
necessarily accommodate everyone.

> Yet, I can't agree with Joerg, to send mail without election date - I feel it
> could bring more confusion than benefit, especially, that date isn't still
> present on wiki. For goodness sake, just set voting  date as 17th or 18th and
> send e-mails now, and I, or anyone at hand, will update wiki accordingly.
> 
> It's quite miserable to debate about "principles" of 3 days for a week or so,
> and this is what we;re heading into.

Let's stay on topic and just get this process running. We can iterate and
change things in the next election cycle. I'm sure you'd hate to ruin your
chances of election by delaying the vote. :^)

Jeremiah
Comment 23 Andrew Flegg maemo.org 2012-05-15 12:12:36 UTC
(In reply to comment #17)
>
> Maybe it is just me, but sending out a mail telling me that I can start to vote
> in a few days and have one week after the start to complete, seems annoying to
> me. 
> 
> I like mails with things I can act on now, not wait 2 days after and with the
> possibility to forget all about it. 
> 
> People tend to vote in directly after they have received their mail with their
> token. Do you really want to rely on people remembering to vote in 2 days?

I agree with Niels: turn-out and participation rates are higher if you can
receive an email and act on it.

However, Joerg also has a good point - some people have broken email addresses
recorded etc. But waiting 2 days is entirely arbitrary. Why not 3, 4, 5?

IMHO, the election starts when the ballots/tokens are sent out and last until 7
days after that. Problems with email deliveries need further thought, and an
arbitrary delay doesn't help with that.

However, this election (and the preceding one) has been a shambles. Even the
council members who are engaged are disinterested in organising and publicising
a well run election. The reason the dates are supposed to be publicised well in
advance is so that people can ensure they are able to vote if they want to
(e.g. if there are holidays). That has failed. Waiting 2 days doesn't solve it
either. I'd almost argue that the current Council have failed in their
covenant.

There are two viable options, I think:

 1) Election starts at 2012-05-15T12:00Z and runs to 2012-05-22T11:59Z
       http://timeanddate.com/worldclock/fixedtime.html?iso=20120515T1200
       http://timeanddate.com/worldclock/fixedtime.html?iso=20120522T1159

 2) A new timetable for elections is drawn up, *properly* publicised and
    giving time for the the election to be well managed (including, for
    example, reach-out to TMO accounts which meet the eligibility requirements)

Given the failures to date, I can only think that (1) is the right option.

(In reply to comment #16)
> 
> While this whole "announce via mail" voting system isn't my favorite [...]

I suggest you raise an alternative on maemo-community. Direct mail seems
*exactly* the right thing to me. Additional announcements should also be made
on the Council blog so people know who to contact if they have a problem.
Comment 24 Jeremiah C. Foster 2012-05-15 12:23:31 UTC
(In reply to comment #23)

>  I'd almost argue that the current Council have failed in their
> covenant.

Seems a little over the top Jaffa. Yes, the elections are a shambles, but part
of the reason for that was the community deserted their posts -- only three
people ran for five spots last time! And there was no contribution for running
a proper election from Nokia, which as you can see is integral for things
working smoothly. To say people "failed in their covenant" seems to have a
nasty biblical ring to it, especially when some of those who ran did it to keep
the Maemo Council alive at all. 

> There are two viable options, I think:
> 
>  1) Election starts at 2012-05-15T12:00Z and runs to 2012-05-22T11:59Z
>        http://timeanddate.com/worldclock/fixedtime.html?iso=20120515T1200
>        http://timeanddate.com/worldclock/fixedtime.html?iso=20120522T1159
> 
>  2) A new timetable for elections is drawn up, *properly* publicised and
>     giving time for the the election to be well managed (including, for
>     example, reach-out to TMO accounts which meet the eligibility requirements)
> 
> Given the failures to date, I can only think that (1) is the right option.

I fully concur.

> 
> (In reply to comment #16)
> > 
> > While this whole "announce via mail" voting system isn't my favorite [...]
> 
> I suggest you raise an alternative on maemo-community. Direct mail seems
> *exactly* the right thing to me. Additional announcements should also be made
> on the Council blog so people know who to contact if they have a problem.

+1
Comment 25 Andrew Flegg maemo.org 2012-05-15 12:39:43 UTC
(In reply to comment #24)
> 
> Seems a little over the top Jaffa.

Possibly. Off-topic related to getting this election going, but on-topic within
"Community Council election process isn't working at all".

> [...] And there was no contribution for running a proper election from Nokia,
> which as you can see is integral for things working smoothly.

I'm afraid I don't see that. It requires effort from *Nemein*, but shouldn't
require any input from Nokia. The voting finally seems to be happening because
of Estel & qgil liaising with SD69 & X-Fade, but both in their capacities as
community members. If SD69 and X-Fade had been clearer with each other and
followed up on the actions resulting from the meeting (even, if there'd
actually been *minutes*), this wouldn't have happened. (More detail at
http://talk.maemo.org/showpost.php?p=1205207&postcount=866)
Comment 26 Joerg Reisenweber 2012-05-15 13:19:08 UTC
honestly this is no best-effort guessing needed here.
there is http://wiki.maemo.org/Community_Council/Election_process
which we should adhere to as much as possible. It's completely irrelevant what
somebody thinks about attention span of users, or boring-ness of a certain
sequence, about "spoiling your chances on election"(SIC! OMG), about merely any
subjective consideration how you think this election should be held.

For your convenience I post the relevant parts here again:

1. Nominations will be accepted [until] 2 weeks before the election begins
((from any community member with a karma of 100 or above.)) 
2. Elections last for [at least] 1 week.
8. The date of the next election will be set by the council chair, [to take
place] not more than 6 months after the previous election.
[and most notably:]
9. The [exact] election date must be publicised at least 1 month in advance of
the election.

Now breaking rule #8 doesn't open opportunity to mess with all other rules, to
minimize that one breakage. Since #8 already moot afaik, it doesn't matter at
all to run the election in June or even July, if that allows to obey the other
rules.

I thought that's obvious, seems it isn't for all of us.
Comment 27 Andrew Flegg maemo.org 2012-05-15 13:31:27 UTC
(In reply to comment #26)
> honestly this is no best-effort guessing needed here.
> there is http://wiki.maemo.org/Community_Council/Election_process
> which we should adhere to as much as possible.

Except you're adding stuff yourself! ;-)

> 2. Elections last for [at least] 1 week.

There's not "at least" expressed or implied.

> 8. The date of the next election will be set by the council chair, [to take
> place] not more than 6 months after the previous election.
> [and most notably:]
> 9. The [exact] election date must be publicised at least 1 month in advance of
> the election.

Point #8 is superceded by #11.1 anyway. I'll give you that "exact" is implied.
But "publicised" isn't defined, nor is it defined what happens if the Council
fails to deliver the timetable therein. That puts it in the realm of
intepretation, and making points to either come to consensus or - at least -
conclusion.

> Now breaking rule #8 doesn't open opportunity to mess with all other rules, to
> minimize that one breakage. Since #8 already moot afaik, it doesn't matter at
> all to run the election in June or even July, if that allows to obey the other
> rules.

I take your point.
Comment 28 Andrew Flegg maemo.org 2012-05-15 14:12:47 UTC
I think Joerg has persuaded me on option #2.

As he says, the process is clear:

"The election date must be publicised at least 1 month in advance of the
election."

Since elections run for a week, that means that the Council blog should
announce the timescale ASAP. Assuming that's today, I propose the following
timescale:

  * Voting tokens sent out: 2012-06-06 00:00 UTC[1] and can be used immediately
  * Contact X-Fade if you expect a voting token and haven't received it:
    2012-06-07 12:00 UTC[2]
  * Voting closes: 2012-06-12 23:59 UTC[3]
  * Next council provisional results announced by: 2012-06-13 23:59 UTC[4]
  * Deadline for any objections: 2012-06-19 23:59 UTC[5]

This blog post should also link to the candidate declarations and perhaps could
be used by the outgoing Council to talk about their work over the past 6
months.

This would put the deadline for the next election to be held by 13th December.

[1] http://timeanddate.com/worldclock/fixedtime.html?iso=20120606T0000
[2] http://timeanddate.com/worldclock/fixedtime.html?iso=20120607T1200
[3] http://timeanddate.com/worldclock/fixedtime.html?iso=20120612T2359
[4] http://timeanddate.com/worldclock/fixedtime.html?iso=20120613T2359
[5] http://timeanddate.com/worldclock/fixedtime.html?iso=20120619T2359
Comment 29 Andrew Flegg maemo.org 2012-05-15 14:20:23 UTC
(In reply to comment #28)
> I think Joerg has persuaded me on option #2.

By the way, I forgot to say *why* I was persuaded. His arguments reminded me
that this kind of administrative cock-up was exactly the reason the dates are
prescribed. And I'll play the "I know, cos I wrote them" card ;-)

One reason which has been cited is that it's fair to the voters may be away
from their primary Internet connections (particularly as we're getting to the
summer), and can plan accordingly.

However, the biggest reason is that it's fairest to the *candidates*. How can
they be realistically expected to campaign and communicate (although none of
them seems to have a blog syndicated to planet.maemo.org, or not posted on the
topic, anyway) if they don't know the dates?

So, although I don't think anyone on the current council should be re-elected
(most of them aren't standing) due to the cock-ups over their *one* well
defined job, I think the community (including those looking to stand on the
council) should show an example of how it should be done.

PS. Regarding my blog post above, SD69 seems to want to excuse himself from the
election process as he's a candidate:
http://talk.maemo.org/showpost.php?p=1204680&postcount=849 This might mean
someone else has to take the decisions.
Comment 30 Quim Gil 2012-05-15 17:01:19 UTC
Hi, let's resolve on this. 2 of the 3 current Council members have answered and
their answer is to start mailing and voting asap. That is the opinion of Niels
as well. I'll interpret this a decision.

Niels, let's start mailing and voting at midnight UTC today. And let's keep it
for a week.

I understand all the other considerations but it's not really Niels' or my role
to interpret the majority lr consensus ln ypur behalf. If the current council
is not deciding the next one will have its chance. To me personally all this
feels like a new council is really needed and therefore I also think that
sooner is better than later. 

Important note: even if SD69 mentioned my name as the Nokia contact there is
definitely nothing in my Nokia role saying that I just take these roles. I'm
doing it as community guy with the best of my intentions, hoping that the next
Council avoids falling again in this kind of situation.

Thank you everybody for your understanding.
Comment 31 Piotr Jawidzyk (reporter) maemo.org 2012-05-15 23:38:34 UTC
As a Community member (and a candidate) I agree with Quim. While I see point in
Andrew's idea, and agree that it would be sticking to statute more "literally",
I don't see any benefit in keeping Community in current state for another month
- especially considering projects like COBS and device seeding activity, that
are outgoing already.

To be understood properly - I don't see voting now or month later as
influencing "chances" of being elected at all - I'll refrain from commenting
it, as it's not forum (+Joerg's comment "SIC! OMG" is more than enough).

It's just that current situation is effect of a stall, that happened when
Jeremian and Momcilo deserted (without any notice) their Council roles, leaving
SD69 as only one active Council member. Prolonging this stall isn't benefiting
Community at all.

BTW, election date *was* announced more than a month ago - it just didn't
started, due to mentioned problems/stall. Everyone actively interested in
voting is already watching event carefully, and everyone other will get
invitation/BIG FAT thread title on TMO/ announcement on IRC/ mail invitation.

If someone actively interested in voting won't be able to due to mentioned mess
- there is a time for signing objections. Heck, if voting would end up with
difference of few votes between candidates, those objections could even be
valid - but I seriously doubt that (and getting any objections at all).
---

X-Fade, it's almost end of 15th - please start voting machine ASAP with voting
time 7 full days, as per Qgil request.

/Estel
Comment 32 Niels Breet maemo.org 2012-05-16 03:17:16 UTC
Mails sent. I got the first few bounces on the return email address and a
request to be removed from the mailinglist.
Comment 33 Andrew Flegg maemo.org 2012-05-16 08:30:18 UTC
Jeremiah - could you please post the timetable on
http://maemo.org/community/council/

If someone expects a token but hasn't received it  they should contact X-Fade.
Comment 34 Piotr Jawidzyk (reporter) maemo.org 2012-05-16 08:50:41 UTC
Thanks a lot, Niels. Mail with voting token received here too. I've changed
status of this bug to "FIXED".

/Estel
Comment 35 Dave Neary maemo.org 2012-05-16 16:42:04 UTC
Hi,

(In reply to comment #25)
> Possibly. Off-topic related to getting this election going, but on-topic within
> "Community Council election process isn't working at all".
> 
> > [...] And there was no contribution for running a proper election from Nokia,
> > which as you can see is integral for things working smoothly.
> 
> I'm afraid I don't see that. It requires effort from *Nemein*, but shouldn't
> require any input from Nokia.

For posterity: I went to a lot of effort to ensure that elections were
documented to the point where they could be run with very little input from
anyone. 

The process involved is documented here:
http://wiki.maemo.org/Maemo.org_team/Creating_an_election and the code for the
election pages is here:
https://garage.maemo.org/plugins/scmsvn/viewcvs.php/maemo-elections/?root=maemo2midgard

There are two steps which need either access or someone's help in the context
of Maemo elections:

1. Request a dump of maemo.org accounts including karma and account creation
date from someone at the karma cut-off date.
2. Create election in the maemoelections database on test.maemo.org

In fact, you could run an election using another database on another host and
by-pass the need for access in step 2. Obviously, getting a list of email
addresses of everyone registered with maemo.org who has a karma greater than or
equal to 10 requires someone with access to that data, and that's a small
number of people, but everything else (including hosting the database and
website) could, in principle, be done by someone with no intervention from
maemo.org.

Was my documentation not clear enough?

Dave.
Comment 36 Joerg Reisenweber 2012-05-16 18:34:18 UTC
(In reply to comment #35)
> For posterity: I went to a lot of effort to ensure that elections were
> documented to the point where they could be run with very little input from
> anyone. 
> 
> The process involved is documented here:
> http://wiki.maemo.org/Maemo.org_team/Creating_an_election and the code for the
> election pages is here:
> https://garage.maemo.org/plugins/scmsvn/viewcvs.php/maemo-elections/?root=maemo2midgard
> 
>[...]
> Was my documentation not clear enough?
> 
> Dave.

Probably simply unknown to the ones who'd need to know. A pity.

thanks, Dave! :-)

Makes me wonder who's supposed to introduce council to their resources and
duties, when no "experienced" council member is running for a second term.

/j
Comment 37 Andrew Flegg maemo.org 2012-05-16 18:47:57 UTC
(In reply to comment #36)
> 
> Makes me wonder who's supposed to introduce council to their resources and
> duties, when no "experienced" council member is running for a second term.

The outgoing chair stays on the council@maemo.org list for the first month (or
less) to assist in the handover and get the new council up & running.

Except we don't have a chair this time (apparently).
Comment 38 Quim Gil 2012-05-16 18:52:50 UTC
Dave, the documentation you left is very good - that is not the problem. The
problem has been that except Niels, probably nobody knew/remembered it existed.

http://wiki.maemo.org/Special:Whatlinkshere/Maemo.org_team/Creating_an_election
- maybe that page could be linked from more places e.g.
http://wiki.maemo.org/Community_Council or
http://wiki.maemo.org/Community_Council/Election_process

IMH and very personal O the problem has been that the council felt it had
concluded its mission before the election and the maemo.org team didn't feel it
was its job to push that alone. We are beyond that point now and this problem
has been FIXED this time, but the new council needs to find a more robust
process to ensure everything works like a clock.

I won't argue about the rules of the MCC but just looking how democracies work
out there:

In any democratic system the current government organizes the elections and
stays until bringing the keys to the newly elected government.

In any democratic system there is a bureaucratic body with the actual knowledge
on how things work that goes through elections and ensures the machine keeps
working.

A simple chat 3 months before the estimated election date can solve all these
problems.

PS: in a council with only one active member my eye has no hesitation
recognizing who is the chair - but this discussion is also moot at this point.
Please let's stop this dicussion, let's move forward and put the effort making
sure we get a high participation in this election. The new board and maemo.org
deserves it!
Comment 39 Dave Neary maemo.org 2012-05-16 19:12:44 UTC
(In reply to comment #38)
> Dave, the documentation you left is very good - that is not the problem. The
> problem has been that except Niels, probably nobody knew/remembered it existed.
> 
> http://wiki.maemo.org/Special:Whatlinkshere/Maemo.org_team/Creating_an_election
> - maybe that page could be linked from more places e.g.
> http://wiki.maemo.org/Community_Council or
> http://wiki.maemo.org/Community_Council/Election_process

A fair point Quim - and something to be fixed, for sure.