Bug 1261 - Let user define minimum brightness
: Let user define minimum brightness
Status: RESOLVED FIXED
Product: UI Specification
General
: 4.1 (4.2008.23-14)
: N800 Maemo
: Low enhancement with 11 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: Quim Gil
: ui-specification-bugs
:
:
:
: 375 3436
  Show dependency tree
 
Reported: 2007-04-23 23:04 UTC by Sean Luke
Modified: 2008-12-29 16:03 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sean Luke (reporter) 2007-04-23 23:04:53 UTC
1. Set the N800 to minimum brightness
2. Wait for it to kick in screen dimming.  It gets DIMMER.

I'd very much like to be able to set this minimum brightness by default.
Comment 1 Michele Giorgini 2007-09-15 01:09:21 UTC
And also to set brightness more precisely... Perhaps using personal settings,
modifiable by the user
Comment 2 Frantisek Dufka maemo.org 2007-11-28 00:27:19 UTC
see also very old bug #375
Comment 3 Jussi Kukkonen 2008-01-10 16:21:12 UTC
Confirming that this is a bug specifically on N800.

In a dark room N800 brightness level 1 is about the same as N810 brightness
level 4 (levels being the steps available in the UI). 

QA must have forgotten the old product, eh? I'm upping severity, this makes
using the device in some conditions very unpleasant.
Comment 4 Frantisek Dufka maemo.org 2008-02-05 10:14:05 UTC
Just to add some findings. Looks like this is caused by missing light sensor in
N800. You can remove filter-brightness-als module in /etc/mce/mce.ini and N810
then behaves exactly the same like N800. Looks like there are only five levels
in the applet to allow some room for the sensor to adjust brightness down in
each level. Without sensor the value is highest possible for specific level.

Still there is same question (asked also in bug #375), why to limit brightness
to few steps? Why simple slider with full range available by hardware is not
the best and natural solution to this just like with sound volume? Imagine
sound volume having only five steps :-)
Comment 5 Ryan Abel maemo.org 2008-02-05 10:21:38 UTC
(In reply to comment #4)
> Still there is same question (asked also in bug #375), why to limit brightness
> to few steps?

Nokia knows best!

Since it seems incredibly unlikely that we'll see some sense come out of Nokia
with this bug, there's an alternative available that gives you full control
over the backlight: https://garage.maemo.org/projects/adv-backlight/
Comment 6 Quim Gil nokia 2008-06-19 11:48:35 UTC
Moving to appropriate component.

I have reformulated the summary and change this as an enhancement request: let
the user control the brightness 0-100%.

The is third party software doing this, therefore the priority is lower.
Comment 7 Andre Klapper maemo.org 2008-10-09 11:59:47 UTC
Quim, do you know if the affected part of the code will become open source now
that dsme/mce will be reorganized?

Having a third party software is certainly nice, but being able to merge
functionality would be even better. ;-)
Comment 8 Frantisek Dufka maemo.org 2008-10-09 12:15:41 UTC
(In reply to comment #7)
> Quim, do you know if the affected part of the code will become open source now
> that dsme/mce will be reorganized?

Also will N8x0 devices get any firmware that is based on such restructured/open
sourced code so we can actually use such open code on current devices? Is this
next Diablo update thing or Fremantle thing?
Comment 9 Quim Gil nokia 2008-10-09 14:56:54 UTC
For what I know the functionality has moved to mce.

I'm discussing the feature itself with David Weinehall and Jane, responsible of
engine and UI respectively. We'll let you know when/if there is something new
in this front.

Details about the opened dsme should be better asked in maemo-developers or in
the garage project when it's created (soon).
Comment 10 Ryan Abel maemo.org 2008-10-09 16:20:20 UTC
(In reply to comment #9)
> For what I know the functionality has moved to mce.
> 

Which, sadly, basically makes dsme a token open sourcing. As the brightness
stuff was really the only stuff that might've been useful for community hack.
Comment 11 Quim Gil nokia 2008-10-13 14:22:05 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > For what I know the functionality has moved to mce.
> > 
> 
> Which, sadly, basically makes dsme a token open sourcing. As the brightness
> stuff was really the only stuff that might've been useful for community hack.

I disagree but this is not the point of discussion here.  :)

Just dropping a line to say that the UI team plans to address "Let user define
minimum brightness" in Fremantle.
Comment 12 Quim Gil nokia 2008-11-26 13:06:31 UTC
Fixed in Fremantle