Bug 12604 - POP3 emails deleted from server though "Leave messages on server" is checked
: POP3 emails deleted from server though "Leave messages on server" is checked
Status: RESOLVED DUPLICATE of bug 12285
Product: Maemo 5 Community SSU
modest
: stable
: N900 Maemo
: Unspecified major with 1 vote (vote)
: ---
Assigned To: unassigned
: general
:
:
:
:
  Show dependency tree
 
Reported: 2012-04-20 15:25 UTC by g0r
Modified: 2012-04-20 16:50 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description g0r (reporter) 2012-04-20 15:25:57 UTC
SOFTWARE VERSION: 
CSSU stable 21.2011.38-1Smaemo3
Modest v3.2

EXACT STEPS LEADING TO PROBLEM: 

1.Create a POP3 e-mail account on the phone then tick the option box LEAVE
MESSAGE ON SERVER.

2.Retrieve emails on the phone from the server deleting the ones you don't
need/want to keep.

3.At the time when another "send and receive" is done on the phone the previous
deleted emails on the phone will incorrectly be deleted from the pop3 server.

4.Switch on PC and retrieve the same POP3 emails.

EXPECTED OUTCOME:
All POP3 emails are received on the PC - even though some emails on phone have
been deleted. 

ACTUAL OUTCOME: 
FAIL: Emails that have been deleted on the phone have been deleted from the
server and can not be retrieved by the PC

REPRODUCIBILITY: 
Always 100%.

EXTRA SOFTWARE INSTALLED: 
Lots, but no reason to believe anything else is to blame.

OTHER COMMENTS: 
This bug has been reported before PR 1.3 and was RESOLVED/FIXED see BUG: 10435
https://bugs.maemo.org/show_bug.cgi?id=10435 

Because of this bug I have lost some emails that could never be found again.
This bug should be fixed ASAP!
Comment 1 Christian Ratzenhofer 2012-04-20 16:50:39 UTC
I hope soon someone picks this up, sadly Sc0rpius is missing, (he still idle's
24/7 on irc though) and he was the main (only) guy working on modest.

*** This bug has been marked as a duplicate of bug 12285 ***