Bug 12544 - Stock Rss feed app not updating or downloading favicons and leaving residue after full phone flash
: Stock Rss feed app not updating or downloading favicons and leaving residue a...
Status: NEW
Product: Maemo 5 Community SSU
general
: testing
: N900 Maemo
: Unspecified critical with 1 vote (vote)
: ---
Assigned To: unassigned
: general
:
:
:
:
  Show dependency tree
 
Reported: 2012-01-12 10:48 UTC by dattadude
Modified: 2012-01-12 15:26 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description dattadude (reporter) 2012-01-12 10:48:38 UTC
SOFTWARE VERSION: 
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Add a feed using stock browser. 
2. Notice that the favicons of most sites do not load.
3. Once added, Feeds do not update manually or automatically, i.e the app shows
no posts for a feed or just shows the same old posts.
4. After flashing phones OS and mass memory using latest pr1.3 and latest
vanilla bin, the rss feed widget and app will still have added feeds before
flash.

EXPECTED OUTCOME: The rss feeds should be added with the appropriate favicons
and update manually or automatically over 2g, 3g and wifi networks and there
should be no rss residue after a full phone flash.

ACTUAL OUTCOME: The rss feed cannot be added with the appropriate favicons and
update manually or automatically over 2g, 3g networks.

REPRODUCIBILITY: 
Always

EXTRA SOFTWARE INSTALLED: Stock rss app.

OTHER COMMENTS: hey guys i found some pretty scary bugs!!!

these bugs are all related to the stock rss feed reader! when adding a feed or
updating on (CSSU testing) it doesnt download the favicon at all. . there is no
png in the favicon flolder. . but it does work for some sites. . also tested on
(CSSUstable). . it turns out tht the rss feed wont update or allow me to add
feeds while using a 2g or 3g connection. and this problem will only happen wit
my sim. if u se my sim on another n900 wit cssu it updates flawlessly or use
someone elses sim on my cssu n900 it wrks flawlessly . . plz dont try on satble
as u will never be able to update using ur sim. and this cannot be fixed wit
even a 100 flashes! . . yes. . this bug will still occur even after a full emmc
and os flash!

one last find. . (in CSSU testing)

i flashed my phone . n to my suprise even after a full flash the rss feed app
and widget still had my rss feeds from before, you may find it impossible but i
have teste d it over 5 times n reproduce this bug 100%!. . and you are welcome
to try!

plz look into this issue too.. it seems the cssu can access the unflashable
areas of the n900.

and please do not say i havnt flashed correctly. . i have flashed correctly.
and an n900 which has never had cssu does not show these problems after a
flash.

i have posted these bugs but lost hope as no one has the answer. . these bugs
persist even after a full flash and must be given crictical importance.

once again thk u guys for all ur great wrk!
Comment 1 Andre Klapper maemo.org 2012-01-12 12:00:25 UTC
In case that you tried isolating the problem, could you clarify if these
problems also happen with stock Maemo 5 (=official Nokia version without CSSU)?
Comment 2 Christian Ratzenhofer 2012-01-12 14:49:49 UTC
confirmed the missing favicon.

Stable seems not to have the problem, but on testing I noticed it.
Comment 3 dattadude (reporter) 2012-01-12 15:26:39 UTC
(In reply to comment #1)
> In case that you tried isolating the problem, could you clarify if these
> problems also happen with stock Maemo 5 (=official Nokia version without CSSU)?

(In reply to comment #1)
> In case that you tried isolating the problem, could you clarify if these
> problems also happen with stock Maemo 5 (=official Nokia version without CSSU)?

Yes all these problems have been found on only an n900 with cssu installed.

Also tested on an n900 which has always been on stock. Problems do not occur
there.

Another find,

It seems maemo and many other sites wont show the favicon or update, but some
sites like kotaku do load the favicon flawlessly.

if i try to update maemo talk i only shows me old post and no new posts.

Refresh progress bar rises for a second and then stops, sometimes a site will
show no posts at all, and the rss app will show text saying, No posts.

Only deleting the osso.feed.reader folder in home/user will fix this issue.