Bug 12463 - transitions.ini got corrupt
: transitions.ini got corrupt
Status: RESOLVED INVALID
Product: Maemo 5 Community SSU
hildon-desktop
: unspecified
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: general
:
:
:
:
  Show dependency tree
 
Reported: 2011-10-13 20:30 UTC by Marcin Mielniczuk
Modified: 2012-01-31 16:35 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Mielniczuk (reporter) 2011-10-13 20:30:38 UTC
SOFTWARE VERSION: 

latest CSSU 20.2010.36-2maemo16.8

EXACT STEPS LEADING TO PROBLEM: 

1. Installed CSSU
2. Used for such a long time
3. (This time surfing with MicroB and listening to music)

EXPECTED OUTCOME: 

Everything allright

ACTUAL OUTCOME: 

Hildon panel (on the top) gets loaded several times. All widgets are painted on
one desktop one above another. The panel dissappears.
transitions.ini got corrupt and I needed to restore it via terminal

REPRODUCIBILITY: less than 1/10

EXTRA SOFTWARE INSTALLED: speedpatch, dynamic cpu tweak 

OTHER COMMENTS:
It should be examined so that transitions.ini won't get corrupt by itself
Comment 1 Marcin Mielniczuk (reporter) 2011-12-27 14:57:49 UTC
Here's more on this:
http://talk.maemo.org/showthread.php?p=1142077#post1142077
Comment 2 Mohammad Abu-Garbeyyeh 2012-01-31 16:24:21 UTC
We never write to transitions.ini manually, the only way it could get corrupt
is due to filesystem corruption, this would usually happen because of
overclocking (unsafe shutdowns might cause that too but afaik UBIFS and oneNAND
try to prevent that - I'm no engineer so I might be wrong).

Regardless, this isn't caused by the CSSU itself.

P.S. please don't move bugs to the wiki, there's a bug tracker for a reason.
Comment 3 Marcin Mielniczuk (reporter) 2012-01-31 16:35:59 UTC
I suspect that's a speedpatch-related problem: without it I've got no problems. 
But I've got a nearly fresh system, so if something happens, I'll report it.
To the people experiencing this problem: are you using speedpatch?