Bug 12393 - Blue border next to top or bottom of the board
: Blue border next to top or bottom of the board
Status: RESOLVED FIXED
Product: Miniature
UI
: master
: N950 Harmattan
: Unspecified enhancement (vote)
: 0.5
Assigned To: unassigned
: general
:
:
: 12390
:
  Show dependency tree
 
Reported: 2011-09-11 00:02 UTC by Uwe Kaminski
Modified: 2011-10-13 09:08 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot showing the blue border on bottom (154.54 KB, image/png)
2011-09-11 00:04 UTC, Uwe Kaminski
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2011-09-11 00:02:34 UTC
SOFTWARE VERSION: 
master

EXACT STEPS LEADING TO PROBLEM: 
1. Run Miniature, connect to FICS and run a game (not in TESTING MODE)
2. Make a move (as white)

EXPECTED OUTCOME:
No blue border next to the upper side of the board

ACTUAL OUTCOME: 
A blue border is shown next to the top of the board.

After the next move the blue border is shown on bottom. It's always visible on
the side of the player which does not have to move.

REPRODUCIBILITY: 
always
Comment 1 Uwe Kaminski (reporter) 2011-09-11 00:04:24 UTC
Created an attachment (id=3416) [details]
Screenshot showing the blue border on bottom

This Screenshot is showing the blue border on bottom (it's blacks turn).
Comment 2 Quim Gil 2011-09-11 02:35:40 UTC
This is not a bug but a feature! It helps you seeing when there is a change of
turn to move and who is on the move at any time.

You could say seeing the timer moving is enough but at least I had to check
many times and it was not always visible when the opponent had moved.

We can discuss if we need this once the last move visual signal is implemented
- bug 12390
Comment 3 Uwe Kaminski (reporter) 2011-09-11 12:36:08 UTC
Hi Quim, thanks for sharing your thoughts. Now I am able to understand what was
the goal of this behaviour.

But I really think:
1. As it is, it looks more than a little graphical error than a wanted feature.
Let's ask some people during games. They should decide which player's move it
is. I'm sure nearly nobody would give the correct answer. The blue border is
too unspectacular.
2. Does it not work mentally: I always think it's the turn of the player with
the blue boarder but it is the other way around: If it is black's move, the
blue border is on the white's side of the board.

So I suggest to reopen this bug until we have a better way to visualize which
player's move it is.
Comment 4 Quim Gil 2011-09-11 18:40:39 UTC
(In reply to comment #3)
> 1. As it is, it looks more than a little graphical error than a wanted feature.
> Let's ask some people during games. They should decide which player's move it
> is. I'm sure nearly nobody would give the correct answer. The blue border is
> too unspectacular.

Being too unspectacular is actually a design goal, since you don't want to be
distracted during the game with too many effects. If you have a better
suggestion to solve this problem please share it.

I have to say that after the last changes handling the timers now it looks
slightly different as originally intended: the little corners that now stay
white/black should also turn cornblue like the bar, giving it an aspect more
integrated (not "broken"). I have tried to solve this now in a rush by doing 

Rectangle {
            id: localCorners
            color: localSide.active ? "cornblue" : localSide.color

but this won't fix it and I need more time to see why not.


> 2. Does it not work mentally: I always think it's the turn of the player with
> the blue boarder but it is the other way around: If it is black's move, the
> blue border is on the white's side of the board.

??? In the current version in master at least for me the blue goes always for
the active player. It would be weird if it would be otherwise since currently 

Rectangle {
            ...
            visible: localSide.active

Please check again.


> So I suggest to reopen this bug until we have a better way to visualize which
> player's move it is.

CCing mikhas to have at least a third opinion.
Comment 5 Uwe Kaminski (reporter) 2011-09-11 22:13:47 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > 1. As it is, it looks more than a little graphical error than a wanted feature.
> > Let's ask some people during games. They should decide which player's move it
> > is. I'm sure nearly nobody would give the correct answer. The blue border is
> > too unspectacular.
> 
> Being too unspectacular is actually a design goal, since you don't want to be
> distracted during the game with too many effects. If you have a better
> suggestion to solve this problem please share it.

I asked some friend of mine using the screenshot I attached in Comment #1:

"This is a chess game and a situation during a match. Please tell me which
player's has to make a move?"

None of them get it. Than I told them about the blue line and they told me it's
too unspectacular for them.

Since I am knowing what the blue line means it's better. I am looking
systematical to the possible positions of the blue line. But even now I think
its a little bit too hard to detect.

My suggestion:
a) paint the backround of the player's name blue (only the name - not the time
and rating)
b) place a big blue dot next to the player's name. 

> I have to say that after the last changes handling the timers now it looks
> slightly different as originally intended: the little corners that now stay
> white/black should also turn cornblue like the bar, giving it an aspect more
> integrated (not "broken").

I like this more than the version with blue corners. Now it is a small blue
line but it does not look like a "graphical failure".

> > 2. Does it not work mentally: I always think it's the turn of the player with
> > the blue boarder but it is the other way around: If it is black's move, the
> > blue border is on the white's side of the board.
> 
> ??? In the current version in master at least for me the blue goes always for
> the active player. It would be weird if it would be otherwise since currently 
>
> Rectangle {
>             ...
>             visible: localSide.active
> 
> Please check again.

You are right. The behaviour I described was from an older version of
Miniature. So this is no problem any more.

> CCing mikhas to have at least a third opinion.

Good idea, thanks. :)
Comment 6 Quim Gil 2011-09-12 01:28:33 UTC
I fixed the corners and now the behavior looks as intended:
https://gitorious.org/miniature/miniature/commit/671daf3632ceaf26a36772bb3b6b2b99aa40ef95

(In reply to comment #5)

> I asked some friend of mine using the screenshot I attached in Comment #1:

A screenshot is not enough, or actually proves my point: a visual signal that
doesn't disturb the game (it didn't disturb your friends looking at a
screenshot) but it's noticeable when switching sides and it's clearly visible
at any time.


> "This is a chess game and a situation during a match. Please tell me which
> player's has to make a move?"
> 
> None of them get it. Than I told them about the blue line and they told me it's
> too unspectacular for them.

I don't think this makes justice for a real situation when you are the player,
a timer is moving and a blue line is switching sides...


> My suggestion:
> a) paint the backround of the player's name blue (only the name - not the time
> and rating)
> b) place a big blue dot next to the player's name. 

I have tried other things before, and they look more ugly because they easily
fall in asymetries left/right or up/down, which actually tend to distract. 

I find the current solution elegant and functional and I propose to leave this
debate for post-0.4, when we will have more feedback from real users.

> I like this more than the version with blue corners. Now it is a small blue
> line but it does not look like a "graphical failure".

Well, it just happens that the little corners add a little more blue, making
the whole line more visible. Having the blue line crossing the white/black was
ugly.
Comment 7 Quim Gil 2011-09-15 19:39:52 UTC
I'm happy removing the blue lines once this is implemented:

Bug 12390 - Make last turn visible
Comment 8 Quim Gil 2011-10-13 09:08:23 UTC
(In reply to comment #7)
> I'm happy removing the blue lines once this is implemented:
> 
> Bug 12390 - Make last turn visible

... and lines removed, as promised:

http://gitorious.org/miniature/miniature/commit/1644b34e05567ecb97aae1bdca0fbbd5c2a3969a