Bug 12284 - kernel-power in maemo.org package interface
: kernel-power in maemo.org package interface
Product: maemo.org Website
: unspecified
: N900 Maemo
: Unspecified blocker with 7 votes (vote)
: ---
Assigned To: Niels Breet
: repositories@maemo.bugs
  Show dependency tree
Reported: 2011-06-23 14:23 UTC by Pali Rohár
Modified: 2013-01-18 12:18 UTC (History)
3 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Pali Rohár (reporter) 2011-06-23 14:23:36 UTC
1. New version v47 of kernel-power is in extras-devel repository, but not in
maemo.org package interface. So I'm not able to promote new version to

maemo.org packages sites (where new version is missing):

extras-devel repository (here builded deb package of new version v47):

New version is possible to install via HAM or apt-get without problems.

2. I tried to promote old version v46 to extras-testing. On maemo.org page I
see in log:


kernel-power | 2.6.28-maemo46    | Fremantle Extras-devel free armel    |
Package promoted    Pali Rohár    | 2011-06-07 17:56 UTC

But package is still not in extras-devel. After two weeks of promotion package
should be moved.
Comment 1 demolition 2011-09-30 18:33:11 UTC
I would like to confirm this bug!
Frequency: Always.

Bug seems to be in a number of parts, including:

1. There is a conflict between the repositories and the package interface:

2. v0.46 has been in the -devel repository (correctly stated by the interface)
18th November 2010. The package interface claims this item (v0.46) has been
promoted by the maintainer (from extras-devel to extras-testing in 7th June
2011). However, the interface lists the package as in -devel, while in the
-devel repository v0.46 has been superseded by later versions so is not visible
via a package UI tool. 

Is it possible the term "promote" also relates to use of a new maintainer? And,
to move it from -devel to -testing it would need a further promotion?

Does this reveal a greater problem of package ownership/maintenance when a
maintainer leaves this community? Especially, without notice?
Comment 2 Niels Breet maemo.org 2011-10-03 11:16:18 UTC
In this case Pali made a mistake to touch the original source package, so the
checksum failed and the import was rejected.

We discussed that and he knows how to fix the issue.

If the original maintainer leaves, I'd suggest to mention this on the -dev
mailinglist. We can discuss it in public there. It is easy to add another
maintainer, but we need to make sure the original maintainer isn't interested
Comment 3 Pali Rohár (reporter) 2011-10-03 13:32:42 UTC
Month ago I uploaded new version v48 with orig.tar.gz tarball from v46 (all
versions expect v47 has same tarball). But It did not help and package
interface still does not see v48.

So which tarball I should upload for v49? That which is used in <= v46 + v48 or
tarball from v47?
Comment 4 demolition 2011-10-05 16:58:41 UTC
Re: Part 2, v46 still being in -devel and ont -testing:
I can confirm this for both the repository and the interface. v42 is the latest
version in both places.
What does the interface mean by "Promoted" in this instance?

Irrespective of the problems with v >= 47, v46 is supposed to have been
promoted to -testing but remains in -devel.

Re: Part 1, mismatch between repository and interface:
Once again, I can confirm that the repo says v48 and the interface says v46. It
appears Pali is using the correct means of packaging and preparing the kernels
so unless there's something else he needs to do, the bug still stands. Could it
be that the problem package (v47) is blocking things up?

How can this bug report be changed from Unconfirmed to Confirmed?

Thanks for looking into this and for mailing list info.
Comment 5 Eric Shattow 2011-11-14 01:35:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Pali Rohár (reporter) 2011-11-19 14:25:42 UTC
@Niels Breet:

Bug is still not fixed. I pushed to Extras-devel two new versions
(2.6.28-10power48 and 2.6.28-10power49) with same original kernel tarball but
maemo package interface still does not show new versions!

Autobuilder builded package without any problem, you can see source and binary
packages on:

I'm sure that I pushed both new versions with correct files (orig.tar.gz, diff,
dsc and source.changes). So this is really bug!

Can you look at it again? Can you manually import kernel-power-* packages into
maemo package interfcae?

After 6 months I'd like to promote kernel-power into extras-testing.
Comment 7 Pali Rohár (reporter) 2012-01-30 20:48:27 UTC
Problem is now fixed. Now I promoted packages to extras-testing.
Comment 8 Pali Rohár (reporter) 2012-03-19 15:24:09 UTC
I pushed new version v50 and it new version again missing in maemo.org package
interface, see http://maemo.org/packages/view/kernel-power/