Bug 12260 - 1.1 does not play .ogg files shorter than 1 second
: 1.1 does not play .ogg files shorter than 1 second
Status: CLOSED FIXED
Product: ogg-support
Vorbis
: unspecified
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: Tuomas Kulve
: general
:
:
:
:
  Show dependency tree
 
Reported: 2011-06-13 02:20 UTC by Dennis Nienhüser
Modified: 2011-07-27 11:55 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dennis Nienhüser (reporter) 2011-06-13 02:20:46 UTC
SOFTWARE VERSION: 1.1 from extras-testing

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Upgrade ogg-support from 1.0.5 to 1.1
2. Voice navigation (which plays .ogg files) in Marble does not work anymore
3. Same behavior in media player when trying to play the same .ogg files

EXPECTED OUTCOME:
.ogg files should be played

ACTUAL OUTCOME: 
.ogg files are not played

REPRODUCIBILITY: 
Always

EXTRA SOFTWARE INSTALLED: 

OTHER COMMENTS:
Same behavior with earlier versions in extras-testing. This may be related to
bug 12259.

For some reason downgrading (to have it work again) is not too easy:
- Install ogg-support 1.0.5.
- Reinstall decoders-support
- Reboot
- Reinstall decoders-support (second time)
Might be related to dbus timeouts reported in the shell during installation.

The .ogg files in question are all rather short (one or a couple of seconds). I
can't upload them somewhere for copyright reasons, but here's a way to access
them if you want to give it a try:
Open http://www.gps-data-team.com/pda-gps-navigation/links/index.php and
download "UK Radio Vicki Archer". Feed it to
http://nienhueser.de/marble/voices/ and get another .zip file back. Extract it
to get the .ogg files in question.
Comment 1 Tuomas Kulve 2011-06-13 17:57:35 UTC
I didn't find the mentioned .zip file in the mentioned address but googling for 
"UK Radio Vicki Archer" was as helpful as always.

I played all the oggs through and none of them made a sound. The longest one is
2.5 secs, most being between 1 and 2 seconds.

Here's the gst-launch log of one attempt:

/GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0.GstGhostPad:src0: caps =
audio/x-raw-int, rate=(int)22050, signed=(boolean)true, channels=(int)1,
endianness=(int)1234, width=(int)16, depth=(int)16
/GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20.GstDecodePad:src0:
caps = audio/x-raw-int, rate=(int)22050, signed=(boolean)true, channels=(int)1,
endianness=(int)1234, width=(int)16, depth=(int)16
/GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/GstAVAudioDec:avaudiodec0.GstPad:src:
caps = audio/x-raw-int, rate=(int)22050, signed=(boolean)true, channels=(int)1,
endianness=(int)1234, width=(int)16, depth=(int)16
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Got EOS from element "playbin20".
Execution ended after 7965086 ns.
Setting pipeline to PAUSED ...
Comment 2 Matti Savolainen 2011-06-15 04:10:52 UTC
I did encounter the same problem in Marble: No sounds. N900 built in Media
Player does not play these audio files either. (I have latest ogg support from
extras testing installed.)

However, Mediabox and SMPlayer do play these when using mplayer backend. I was
wondering how difficult it is to change Marble to use the mplayer for voice
guidance until ogg support gets fixed?
Comment 3 Piotr Jawidzyk maemo.org 2011-06-25 23:18:29 UTC
I can confirm that files mentioned worked in 1.0.5 and don't work in 1.1
Comment 4 Felipe Contreras 2011-07-15 18:52:07 UTC
The problem was with clips shorter than 1 second.

Fixed in gst-av 0.5.3-1.
Comment 5 Tuomas Kulve 2011-07-19 10:42:33 UTC
Ogg-support 1.1.1 in extras-testing depends now on the newest version of gst-av
from Felipe.

Please re-test and provide the feedback here:

http://maemo.org/packages/package_instance/view/fremantle_extras-testing_free_armel/ogg-support/1.1.1/
Comment 6 Dennis Nienhüser (reporter) 2011-07-19 23:59:04 UTC
Thanks for tracking this down. Currently my N900 is out for repair, so I can't
test myself unfortunately.

However, reinob confirms it's working for him in [1] and [2], but also mentions
that the track that is being played is longer than one second -- something
which I expect the majority of our tracks to be. Is the one second in the title
definite or just a synonym for short?

I hope I can leave a thumbs-up in the 1.1.1. page when my N900 is back :-)

Regards,
Dennis

[1] http://talk.maemo.org/showpost.php?p=1054253&postcount=139
[2] http://talk.maemo.org/showpost.php?p=1054253&postcount=140
Comment 7 Tuomas Kulve 2011-07-20 00:05:50 UTC
(In reply to comment #6)
> which I expect the majority of our tracks to be. Is the one second in the title
> definite or just a synonym for short?

Maybe Felipe can answer this more precisely but I tested oggs that were between
0.5 secs and 2.5 secs and none of them played before and all of them played
now.
Comment 8 Felipe Contreras 2011-07-20 13:51:30 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > which I expect the majority of our tracks to be. Is the one second in the title
> > definite or just a synonym for short?
> 
> Maybe Felipe can answer this more precisely but I tested oggs that were between
> 0.5 secs and 2.5 secs and none of them played before and all of them played
> now.

It actually depends on the format, but basically 192000 bytes.
Comment 9 Tuomas Kulve 2011-07-27 11:55:53 UTC
Closing resolved and released Ogg Support bugs.