Bug 1210 - video playback on Media Player gets jerky or freezes
: video playback on Media Player gets jerky or freezes
Status: RESOLVED WORKSFORME
Product: Media player
General
: 3.2
: N800 Maemo
: Medium normal with 1 vote (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
: moreinfo, performance
:
:
  Show dependency tree
 
Reported: 2007-04-11 23:37 UTC by Hanno Zulla
Modified: 2009-02-01 23:10 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Hanno Zulla (reporter) 2007-04-11 23:37:10 UTC
Simple UI usage during video playback can mess up the media player. Actions
such
as the following:

- switching to fullscreen and back
- pause during playback and continue
- fast forward and rewind

may result in jerky playback or a frozen video.

This behaviour is not reproducable. It doesn't happen at specific video
positions. Sometimes it works fine, sometimes it crashes, but it crashes rather
often. The crash is always related to user interaction with the device's UI.

Sometimes, it can be resolved by moving the playback position within the video,
sometimes it can't and one has to restart media player.

(Btw.: changing the volume using the +/- keys works fine and never crashes
playback.)

I can provide sample files if needed. They were converted using Andrew Flegg's
770-encode.pl.
Comment 1 Daniel Stone nokia 2007-04-13 14:24:08 UTC
when it freezes, does the whole device freeze, or just the media player?
Comment 2 Hanno Zulla (reporter) 2007-04-13 14:27:35 UTC
Just the media player.

Thanks, Hanno.
Comment 3 Daniel Stone nokia 2007-04-13 14:29:19 UTC
okay, so it's just a media player problem, rather than a driver problem. 
thanks
for the followup.
Comment 4 Hanno Zulla (reporter) 2007-04-13 14:34:17 UTC
Don't know if it's the player or gstreamer, as I know too little about that.


Btw, the player has a weird way of handling this:

- pause the video while in fullscreen playback
- wait
- let screen blanking apply and let the device turn the screen to black

When you unblank the device from that state, the screen will show a broken frame
from the film with large green sections. Usually, the player recovers from this,
but it's a weird sight.
Comment 5 Frederic Crozat 2007-04-13 14:49:12 UTC
I've also noticed audio soundtrack continues to play when switching to / from
fullscreen, while video playback pauses and framerate lags for about two seconds.
Comment 6 Hanno Zulla (reporter) 2007-04-13 15:47:40 UTC
Yes, audio playback continues. But when I experience this, the video usually
does not recover after 2 seconds, but continues to stall.
Comment 7 Hanno Zulla (reporter) 2007-04-26 17:01:44 UTC
To clarify: This issue does not CRASH the video player, but playback freezes or
gets jerky and the video player then reacts very slowly when trying to close it.

(Sorry. English is not my 1st language.)
Comment 8 Andre Klapper maemo.org 2008-06-24 17:55:25 UTC
Is this still an issue on the IT2008 (providing a different media player)? I
don't expect any updates for IT2007...
Comment 9 Quim Gil nokia 2009-02-01 23:10:08 UTC
Resolving as WORKSFORME since the media player in Diablo seems to be quite
robust.

Pleas reopen if you are still finding problems.