Bug 11961 - Random email application (modest) crashes with CSSU
: Random email application (modest) crashes with CSSU
Status: RESOLVED FIXED
Product: Maemo 5 Community SSU
modest
: unspecified
: N900 Maemo
: Unspecified major with 21 votes (vote)
: ---
Assigned To: unassigned
: general
:
: crash
:
:
  Show dependency tree
 
Reported: 2011-02-20 17:01 UTC by Jari Tenhunen
Modified: 2012-03-05 15:49 UTC (History)
20 users (show)

See Also:


Attachments
Patched libtinymail-camel with what it looks like a memory leak (601.45 KB, application/octet-stream)
2011-05-10 00:30 UTC, naikel
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Jari Tenhunen (reporter) 2011-02-20 17:01:43 UTC
SOFTWARE VERSION: 
20.2010.36-2 CSSU 36-2maemo11

EXACT STEPS LEADING TO PROBLEM: 
1. Have GMail and MfE accounts configured
2. Use them normally, e.g. try to open a new email message

EXPECTED OUTCOME:
email works more or less as reliably as in officially supported firmware

ACTUAL OUTCOME:
Modest definitely crashes more often than it did with the official 36-2.

REPRODUCIBILITY: 
less than 1/10

EXTRA SOFTWARE INSTALLED: 
lots
Comment 1 Andre Klapper maemo.org 2011-02-20 19:44:26 UTC
Core dump of the crash would be welcome (or gdb output). See
http://wiki.maemo.org/Extras-testing#Tools_for_testers for more info, but note
that coredumps can contain private data.
Comment 2 Andrew Flegg maemo.org 2011-02-20 21:37:20 UTC
Possible dupe of bug 11861?
Comment 3 David Mery 2011-03-01 19:53:56 UTC
Crashes appear to be caused by speed of scrolling. Fast scrolling of emails
tend to crash modest. Scrolling slowly doesn't.

Speculation: some routine in modest can't cope with the amount of data
generated when scrolling fast. Data generated by the scrolling can't be
processed and possibly do a buffer overrun or similar issue.

(Sorry not to provide any log, but I do not have the tools installed)
Comment 4 Matti Viljanen 2011-03-02 15:25:59 UTC
Confirming/voted.

For me it crashes most frequently while checking for new emails, say, 4/10. I
have two IMAP accounts configured, neither of them are GMail or MfE.
Comment 5 Benedict Meier 2011-03-05 19:19:00 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 sophocha 2011-03-06 02:04:24 UTC
Mine always does it when I skype call and try to check emails.8/10 will
instantly crash when I open the email client.It happens less frequently when I
play videos (tvcatchup stream while checking emails) maybe 3/10 and 1/10 when I
try to browse and check emails at the same time.It looks like it crashes when I
multitask.It doesn`t happen (so far) when I just check emails without anything
intensive happening.Bear in mind that my phone is overclocked @1000 AND was
solid stable for the past year at that speed with nothing crashing but since
the SSU update the email client is affected.
Comment 7 monkeysaintfun 2011-03-14 13:14:16 UTC
For me, Modest crashes constantly even when I am not using it..

I have disabled it from starting up automatically but if I try to open Modest I
get an instant crash.

Whenever I connect to the internet (both wifi and 3g) modest tries to open in
the background but crashes instantly resulting in an error notification. Never
had this problem with CSSU until the most recent update.

I have tried installing an older version of Modest but I still get this error
so it isn't a problem with Modest itself but maybe the CSSU update changed
permissions to an area Modest loads from??
Comment 8 monkeysaintfun 2011-03-14 13:14:49 UTC
For me, Modest crashes constantly even when I am not using it..

I have disabled it from starting up automatically but if I try to open Modest I
get an instant crash.

Whenever I connect to the internet (both wifi and 3g) modest tries to open in
the background but crashes instantly resulting in an error notification. Never
had this problem with CSSU until the most recent update.

I have tried installing an older version of Modest but I still get this error
so it isn't a problem with Modest itself but maybe the CSSU update changed
permissions to an area Modest loads from??
Comment 9 sophocha 2011-03-14 14:05:11 UTC
With the latest update the story on my phone is different.I have no longer any
email crashes!I even overclocked my phone to 1500Mhz (up from 1000) to prove my
point.No more crashes!It looks like its not the CSSU update fault but a third
party application that makes your phone behave like that.I would suggest a
clean format and install of CSSU without any other software involved.Only then
you will be sure that it`s not CSSUs fault.

(In reply to comment #8)
> For me, Modest crashes constantly even when I am not using it..
> I have disabled it from starting up automatically but if I try to open Modest I
> get an instant crash.
> Whenever I connect to the internet (both wifi and 3g) modest tries to open in
> the background but crashes instantly resulting in an error notification. Never
> had this problem with CSSU until the most recent update.
> I have tried installing an older version of Modest but I still get this error
> so it isn't a problem with Modest itself but maybe the CSSU update changed
> permissions to an area Modest loads from??
Comment 10 kolos 2011-03-18 11:25:48 UTC
Default modest (3.4.8+0m5) doesn't cause me these caches. I have 7 email
accounts and I'm wondering if maybe this has something to do with it. Usually
people have 2-3 accounts. Crashes happens when I'm updating accounts or
deleting emails.
Comment 11 Jari Tenhunen (reporter) 2011-04-11 22:03:42 UTC
(In reply to comment #9)
> With the latest update the story on my phone is different.I have no longer any
> email crashes!I even overclocked my phone to 1500Mhz (up from 1000) to prove my
> point.No more crashes!It looks like its not the CSSU update fault but a third
> party application that makes your phone behave like that.I would suggest a
> clean format and install of CSSU without any other software involved.Only then
> you will be sure that it`s not CSSUs fault.

i find it hard to believe that a 3rd party app would cause modest to crash. I
got the latest cssu update (...maemo14) and for me it still crashes, most often
while scrolling a message.
Comment 12 Jari Tenhunen (reporter) 2011-04-14 10:40:01 UTC
What is the status of this?

The crashes are getting really frequent which makes email almost unusable. Who
is maintaining modest in CSSU? If a newer version of modest is included in
CSSU, I think there should be an accountable maintainer for it.
Comment 13 kolos 2011-04-14 18:49:32 UTC
Despite new update (14.1) I still experience random crashes, but because
everything else works very well, I'm not prepared to reflash my N900. I hope
that these crashes won't become more frequent.
Comment 14 Paul Ortyl 2011-04-14 19:20:09 UTC
I confirm frequent crashes with 3.90.7-8.
Comment 15 sophocha 2011-04-14 20:04:12 UTC
(In reply to comment #3)
> Crashes appear to be caused by speed of scrolling. Fast scrolling of emails
> tend to crash modest. Scrolling slowly doesn't.
> Speculation: some routine in modest can't cope with the amount of data
> generated when scrolling fast. Data generated by the scrolling can't be
> processed and possibly do a buffer overrun or similar issue.
> (Sorry not to provide any log, but I do not have the tools installed)

Guys! This is what is happening.I thought a third party app would crash the
email client, or an overclock or something else, but it`s not.I`ve tried
opening up the client and then before it loads everything do a fast scroll on
one of my email accounts.....result....crash! So I confirm this even with the
newest update.But when I leave it load up everything and do a fast scroll it
doesn`t crash.
Comment 16 Paul Ortyl 2011-04-14 21:58:30 UTC
Could someone post a link with howto:
1. Enable core dumps on Maemo
2. Get debug info for the modest binary
3. Get gdb on the device or get the core dump analysed on the PC

These crashes happen a few times a day so with a few core dumps it should be
possible to get some info...
Comment 17 Benedict Meier 2011-04-14 22:01:15 UTC
When my phone rebooted after the last cssu update automaticly, the message
"operationg system updated" AND -at the same time- "application 'email' closed"
appeared without even touching the phone. that means that without user
interaction the bug occurs.
Comment 18 Andrew Flegg maemo.org 2011-04-15 13:35:20 UTC
(In reply to comment #12)
> What is the status of this?

Waiting on the debug information requested by Andre in comment #1.

(In reply to comment #16)
> Could someone post a link with howto:
> 1. Enable core dumps on Maemo
> 2. Get debug info for the modest binary
> 3. Get gdb on the device or get the core dump analysed on the PC

See comment #1.
Comment 19 Andrew Flegg maemo.org 2011-04-20 10:51:14 UTC
*** Bug 12175 has been marked as a duplicate of this bug. ***
Comment 20 Robert 2011-04-20 16:06:24 UTC
(In reply to comment #19)
> *** Bug 12175 has been marked as a duplicate of this bug. ***
Hi Andrew. I have some questions regarding a core-dump. Shoul I use
sp-rich-core? Or is there anything else. And does the process need to be
started or is it done automatically? Because the crashes are quite random. I
had to start modest from x-term quite a few times to try and see the output of
the error. Frankly I was quite disappointed from the small output. Hopefully a
core-dump may help you better but I am a bit unsure on how to do that.
Comment 21 Robert 2011-04-21 16:28:23 UTC
These are four core-dumps that I got of modest. I couldn't attach them here due
to file size: http://www.mediafire.com/?7zdiznlva4z973k

Modest Version: 3.90.7-8
E-Mail Accounts: GMail, Hotmail, MFE, Nokia Messaging (all done using Wizard) +
POP3 account entered manually.

Core-Dumps were generated during random events like Send/Receive, Read E-Mail.

The four crashes all occurred within 2 minutes.
Comment 22 Robert 2011-04-26 11:20:16 UTC
I wonder is anyone taking care of these problems? I posted 4 core-dumps 5 days
ago and received no feedback. I don't even know if they would be useful.

Anyway I have more core-dumps to post if they can help anyone. Here's a link:
http://www.mediafire.com/?j33rsld3w5hgxxd

I don't know how to analyse them myself(if anyone can share please do). For me
they are just gibberish.

The e-mail client is frankly a pain to use with all these crashes. I have
decided to install the normal version of the e-mail client. For any of you in
this mailing list who experience these random crashes and wish to do so too
here's how (without quotes obviously): "apt-get install modest=3.4.8+0m5"

I hope the crashes stop now.

If anyone wishes to submit core-dumps but doesn't know how it is quite easy
actually.

1. Add the following repository to your N900 using the default application
manager (Open App. Manager > Drop-Down-Menu > Application Catalogs > New).

Name: fremantle tools
Address: http://repository.maemo.org
Distribution: fremantle/tools
Components: free non-free

Then press Save.

2. Close the application manager and open X-Terminal. In xterm enter the
following commands as root (you need the rootsh package).

root
apt-get update
apt-get install sp-rich-core
mkdir /media/mmc1/core-dumps

This will save core-dumps to your memory card in a folder called core-dumps.
Hope this helps.
Comment 23 Andre Klapper maemo.org 2011-04-26 13:31:33 UTC
(In reply to comment #22)
> I wonder is anyone taking care of these problems? I posted 4 core-dumps 5 days
> ago and received no feedback.

Volunteers tend to take a look when they have time and interest...
Comment 24 Robert 2011-04-26 15:23:51 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > I wonder is anyone taking care of these problems? I posted 4 core-dumps 5 days
> > ago and received no feedback.
> 
> Volunteers tend to take a look when they have time and interest...

I understand. I just wanted an acknowledgement. Like the one you just posted.
That someone will look into this eventually. I was in no way expecting someone
to look into it now.
Comment 25 naikel 2011-05-10 00:29:33 UTC
I analized every single core dump posted by Robert and all of them are Out Of
Memory crashes.

Most of the crashes are reserving a new GSlice of memory using GLIB GSlice
functions like g_slice_alloc(), g_slice_new().  There are also crashes in
g_strdup and derivates (g_strdup_vprintf) and the like.

All of the crashes are in Camel functions inside Tinymail.

My Modest has never ever crashed so I wonder what could be different. 
Mailboxes with thousand of folders? 

My Modest is configured with two IMAP accounts, three Nokia Messaging accounts
and one POP3 account (Hotmail) for a total of 6 accounts and I can't get a
crash.  I have viewed 13,000 of emails clicking next several times and going in
and outside folders hundreds of times with no results.  I have left it open for
several days, polling all my accounts every 10 minutes, and not even a single
crash so far.

Now, even though I see there could be a memory leak in
tny_camel_store_account_get_folders_default() by not freeing the
camel_store_get_folder_info() call results, I still wonder why Modest 3.4 works
for you with absolutely no crashes since they both use the same version of
Tinymail.

Now if you tell me that stock Modest 3.4 crashes but not that often as 3.90
CSSU then maybe we have a lead.

So if anyone want to give a try install the .deb attached, reboot your device
and test for more crashes.  New dumps will help.
Comment 26 naikel 2011-05-10 00:30:43 UTC
Created an attachment (id=3365) [details]
Patched libtinymail-camel with what it looks like a memory leak
Comment 27 Robert 2011-05-10 09:23:38 UTC
(In reply to comment #26)
> Created an attachment (id=3365) [details] [details]
> Patched libtinymail-camel with what it looks like a memory leak

Hi thanks for your response. When I downgraded I broke the CSSU installation
but everything still worked quite well. But there still were crashes. I was
quite disappointed. I am pretty sure I never had crashes (or very rarely)
before.

This also happened before CSSU. When I upgraded to v3.9 released by MAG, these
crashes started. When I downgraded again, the crashes stopped (or became rare).

After installing CSSU, the crashes started again but downgrading didn't help,
or didn't help much. I had broken the CSSU installation and the crashes were
still there with v3.4 So now I fixed everything and am working with v3.9.

I may have some core-dumps of crashes I had with v3.4 if you want.

Thanks a lot.
Comment 28 Ashley Hooper 2011-05-17 08:31:12 UTC
Modest became unuseable for me, post-CSSU upgrade.

I have 2 Gmail accounts configured, 30 min refresh interval over Wifi. I purged
almost everything from my Inboxes, hid all but 8 or so of my Gmail folders
using the Gmail IMAP tweaker, and deleted my local IMAP caches. At 12 pm, the
background refresh crashed (I got the usual crash notification). I wonder if
it's related to CPU/load? That could explain why it crashes on scrolling for
some people?

I presume the new auto-rotation is monitoring D-Bus for notification of
rotation. Since that's the principal area of the code that was changed, perhaps
something is timing out? of 

In the space of 10 minutes, I opened my mailbox 6 or so times and Modest
crashed each time when I clicked a message to view. sometimes while Inbox was
opening.

Robert, thanks for your message. I have downgraded like you, and can open
messages again. I am trying the patched libtinymail also.

I respect the devs are volunteers, but I feel this bug may not be getting the
attention it deserves.
Comment 29 Robert 2011-05-17 16:41:16 UTC
Hi naikel. I tried the patch you attached but I feel the problem got even
worse. It may be my impression but I think it is crashing more frequently. I
reverted to the previous version I had now. If you want I can post some more
core-dumps. Thank you very much for looking into this.

Hi Ashley. I am glad v3.4 is working fine for you. I had no such luck
unfortunately :).
Comment 30 naikel 2011-05-17 19:05:28 UTC
Please forget about the tinymail patch I posted earlier. It really seems it
worsened the situation for several people.

I still see that all the crashes happen in functions that handle memory.  I
could catch some crashes in my own N900.  All of them under
camel_store_get_folder_info() and usually in a g_free() or something, so I'm
gonna try another approach and use something like dmalloc to see if all memory
is addressed and freed correctly.

Another thing I want to comment: CSSU uses Modest 3.90.7.  After that version
we started bug fixing and few enhancements.  The stock PR1.3 Modest is 3.4.8. 
As you can see there's a long way from 3.4.8 to 3.90.7 where CSSU wasn't
involved, and I strong believe these crashes are not the cause of CSSU
modifications to Modest (most of them just to make Modest look good in
Portrait).

I'm pretty sure that if you compile the original Modest 3.90.7 (not CSSU) from
gitorious you'd still get the crashes.  CSSU didn't introduce them.

CSSU team will of course do anything possible to fix bugs that we believe were
introduced by the original Modest coders by mistake.  And, we thank them
(Modest coders) because of them at least we have a decent email client.
Comment 31 Ashley Hooper 2011-05-19 05:42:05 UTC
I was thinking, perhaps we could drop back a few minor versions in the upstream
code and see where the crashing begins?

I'd be happy to test Modest packages based on upstream and report back.
Comment 32 Andrew Flegg maemo.org 2011-07-06 11:06:05 UTC
*** Bug 12298 has been marked as a duplicate of this bug. ***
Comment 33 Mehul J. Rajput 2011-07-07 22:31:30 UTC
Well not sure if this helps, but I did a reflash of my n900 and install cssu on
top of it. So far there are no crashes with modest, it is up and running
without any issues.

Was there a new patch applied or something? I checked the version installed and
it still seems to be the one which was crashing.
Comment 34 Robert 2011-07-08 02:53:08 UTC
(In reply to comment #33)
> Well not sure if this helps, but I did a reflash of my n900 and install cssu on
> top of it. So far there are no crashes with modest, it is up and running
> without any issues.
> 
> Was there a new patch applied or something? I checked the version installed and
> it still seems to be the one which was crashing.

Well you are lucky. I don't think there were any changes either. However mine
still crashes constantly. When I have some time I will reflash the phone (it
takes time to re-install everything), but I sure will stay away from v3.9 of
modest.

1st time it happened I updated to that version. Installing CSSU didn't help (as
expected). Then I reflashed and everything was fine again..until I made the
mistake of installing the CSSU with this version of modest included.

I really don't know what's causing this. I must have accumulated close to 1GB
of core-dumps..but I don't understand them and don't know how to fix it.
Comment 35 Petr Vanek 2011-08-05 00:41:42 UTC
i have cssu installed and suffer these random scrashes and also 11993 Mangling
email addresses [1]

getting modest=3.4.8+0m5 did help with 11993 Mangling email addresses [1], but
the random crashes remain, so it seems that they are not related to the modest
version as such.

[1] https://bugs.maemo.org/show_bug.cgi?id=11993
Comment 36 Richard Aspden 2011-08-17 14:19:40 UTC
This seems to happen specifically with me when new mail is coming in, and I'm
trying to do anything else with modest, including after a complete
wipe/reinstall. If I try to read an email and others are coming in (MfE and
Nokia Messaging are configured, the latter with 5 IMAP accounts attached),
which can be incredibly frustrating.

Running CSSU 20.2010.36-2maemo15.
Comment 37 Richard Aspden 2011-08-17 14:21:14 UTC
(In reply to comment #36)
If I try to read an email and others are coming in (MfE and
> Nokia Messaging are configured, the latter with 5 IMAP accounts attached),
> which can be incredibly frustrating.

Sorry, that last email sentence should have read "If I try to read an email and
others are coming in (MfE and Nokia Messaging are configured, the latter with 5
IMAP accounts attached), the client crashes, losing whatever I happen to have
been doing - reading or composing - which can be incredibly frustrating.
Comment 38 Robert 2011-09-08 15:48:17 UTC
The new CSSU update didn't fix this issue. Thank god for backupmenu. I tried
updating via HAM and via terminal. Well looking at the updated components there
seem to be little or no change to modest so this was expected. For the past
months, I have been running without CSSU and modest worked perfectly.

Since this problem doesn't seem that it will be fixed anytime soon, is there a
way for me to pin all the required packages associated with modest so that they
don't get upgraded? I wish I could upgrade to CSSU but modest crashes always
start all over again. Or else is there a way to upgrade to CSSU packages
manually and omitting the modest ones?

Thanks.
Comment 39 Petr Vanek 2011-11-24 22:41:06 UTC
(In reply to comment #35)
> i have cssu installed and suffer these random scrashes and also 11993 Mangling
> email addresses [1]
> 
> getting modest=3.4.8+0m5 did help with 11993 Mangling email addresses [1], but
> the random crashes remain, so it seems that they are not related to the modest
> version as such.
> 
> [1] https://bugs.maemo.org/show_bug.cgi?id=11993

actually i have noticed now over time, that with "apt-get install
modest=3.4.8+0m5" modest almost doesn't crash and if it does, it happens very,
very rarely, but i have tested the latest modest from CSSU for two days now and
it does crash all the time, much more that the 3.4.8 does.
Comment 40 Christian Ratzenhofer 2012-03-05 15:49:26 UTC
This got fixed with the latest update, the modest binary was thumb compiled
before
and that lead to all kinds of segfaults.