Bug 11922 - release header files for libbmeipc
: release header files for libbmeipc
Status: UNCONFIRMED
Product: Licensing Change Requests
General
: unspecified
: N900 Maemo
: Unspecified enhancement (vote)
: ---
Assigned To: unassigned
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2011-02-11 16:34 UTC by Jonathan Wilson
Modified: 2011-08-18 22:52 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jonathan Wilson (reporter) 2011-02-11 16:34:49 UTC
Which component(s) or source packages is the licensing change request about?
libbmeipc-dev
Which area is the component in (if you know)? See the openness progress reports
at
http://mer-project.blogspot.com/2010/02/mapping-openness-of-maemo-50-pr11-and.html
System sw/dsm
What is the current licensing of the component?
proprietary
What licensing would you like it to be and why? Examples can be:
open source and openly developed (move to gitorious), open source (select a
license), non-free but redistributable, non-free, published in nokia-binaries,
document the functionality, etc.
I wish for a full set of header files and development bits (documentation too
if its available inside Nokia) for the libbmeipc library to be made available
for developers to use. License can be any license that allows linking into our
code.
Which project(s) would benefit from this licensing change request?
Projects that need to talk to BME and query battery state. MeeGo would benefit
by being able to use libbmeipc to implement a full battery status applet and
related items.
Comment 1 Jonathan Wilson (reporter) 2011-02-11 17:21:44 UTC
btw if there are genuinely sensitive items in these headers (i.e. "this could
ruin your battery or phone if you abuse it" type stuff) then its acceptable to
replace the sensitive bits with comments such as //stuff for doing <blah>
removed because it is sensitive
Comment 2 Andre Klapper maemo.org 2011-02-11 17:35:44 UTC
(Also see http://talk.maemo.org/showpost.php?p=784443&postcount=32 )
Comment 3 Pali Rohár 2011-02-18 20:43:37 UTC
For query battery state you can use this sh script:
http://wiki.maemo.org/N900_Hardware_Charge_Meter/bq-script

Now on kernel mailinglist is series of patches kernel driver bq27x00_battery
(power_supply) for query all battery properties. I posted patches for Maemo
(kernel, battery desktop widget) here:
http://talk.maemo.org/showpost.php?p=925980&postcount=674
Comment 4 Pali Rohár 2011-08-18 22:52:03 UTC
header files + libbmeipc library is now open:
https://meego.gitorious.org/meego-device-adaptation/n900_libbme

Should be this bug closed as fixed?