Bug 11861 - Modest does not start
: Modest does not start
Status: NEW
Product: Maemo 5 Community SSU
modest
: unspecified
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: general
:
:
:
:
  Show dependency tree
 
Reported: 2011-02-03 21:46 UTC by Uwe Kaminski
Modified: 2011-07-06 19:57 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2011-02-03 21:46:08 UTC
EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1.open xterm:

$ modest.launch 
Segmentation fault
~ $ modest        
modest: use 'modest -s' to start from cmdline  with UI
process 16337: arguments to dbus_bus_request_name() were incorrect, assertion
"_dbus_check_is_valid_bus_name (name)" failed in file dbus-bus.c line 1070.
This is normally a bug in some application using the D-Bus library.
Illegal instruction

Modest crashs very often. How I can investigate to get more information about
the reasons?
Comment 1 naikel 2011-02-04 02:14:48 UTC
This is normal behavior. The .launch files are for maemo-invoker:

lrwxrwxrwx    1 root     root           22 Feb  2 17:41 /usr/bin/modest ->
/usr/bin/maemo-invoker
-rwxr-xr-x    1 root     root       690628 Feb  2 01:27 /usr/bin/modest.launch

If you want to launch modest from the command line, just type 'modest'.  That
will load the background process.

If you want the GUI from the command line, you should type: modest -s

Modest have never ever crashed on me.  It's weird that people are reporting
modest crashes.
Comment 2 Eero Tamminen nokia 2011-02-04 16:20:00 UTC
(In reply to comment #0)
> 1.open xterm:
> 
> $ modest.launch 
> Segmentation fault

You're trying to run a shared library, not a program.


> ~ $ modest        
> modest: use 'modest -s' to start from cmdline  with UI
> process 16337: arguments to dbus_bus_request_name() were incorrect, assertion
> "_dbus_check_is_valid_bus_name (name)" failed in file dbus-bus.c line 1070.
> This is normally a bug in some application using the D-Bus library.
> Illegal instruction

Hm.  Have you some program (possible something else than Modest) that is
compiled with Thumb and running at the same time?

(Anything using thumb can cause random crashes in random processes.)
Comment 3 Mohammad Abu-Garbeyyeh 2011-02-11 21:45:17 UTC
Does this still occur on the latest CSSU update? Otherwise, this should be
closed as RESOLVED WORKSFORME, because I'm unable to reproduce this on two
devices.
Comment 4 misterl56 2011-07-06 19:57:31 UTC
hi all,
I have exactly the same bug launching modest from desktop or command line.
it crash randomly with the 'illegal instruction' error a few second after being
launched.

if i try to launch it again it crashes again a few time until it stop and
works.

I have the last CSSU update.
How can i know if i have something compile with thumb?