Bug 11809 - Missing i386 binary package of sdk-fiasco-gen
: Missing i386 binary package of sdk-fiasco-gen
Status: VERIFIED FIXED
Product: maemo.org Website
Packages
: 5.0
: All Maemo
: Low enhancement with 1 vote (vote)
: 5.0
Assigned To: Niels Breet
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2011-01-23 15:32 UTC by Pali Rohár
Modified: 2011-06-28 17:13 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Pali Rohár (reporter) 2011-01-23 15:32:30 UTC
SOFTWARE VERSION: 
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Setup cross compile enviromental (or download madde)
2. Build kernel deb packge (dpkg-buildpackge) in cross compile enviromental
(without qemu or armel host)
3. 

EXPECTED OUTCOME: Successfull compiled deb packge

ACTUAL OUTCOME: Building deb package fails because program fiasco-gen is only
for armel architecture ( http://maemo.org/packages/view/sdk-fiasco-gen/ ). But
it does not depends on architecture, so it can be i386 binary too for compiling
kernel deb package without scratchbox, qemu on native i386 PC.

REPRODUCIBILITY: 
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: 

OTHER COMMENTS:
Comment 1 Marcell Lengyel maemo.org 2011-01-24 11:14:42 UTC
The usecase that you describe is a very special one. fiasco-gen is delivered as
armel only, because the kernel can not be compiled in x86 scratchbox, and madde
is targetting application developers.

What would be your proposal to fix this? Would it help if there we would
release an sdk-fiasco-gen_i386.deb binary package?
Comment 2 Pali Rohár (reporter) 2011-01-24 12:54:18 UTC
If there will be native fiasco-gen package for i386 I can compile armel kernel
without qemu. Linux kernel support cross compiling, so that is not needed host
machine.

But to build n900 kernel deb packages is needed fiasco-gen. And is not possible
to run armel binary of fiasco-gen on build machine without qemu...
Comment 3 Marcell Lengyel maemo.org 2011-01-27 13:59:34 UTC
FYI, we are investigating this, it just takes longer than I anticipated.
Comment 4 Pali Rohár (reporter) 2011-02-26 22:22:20 UTC
Any news/updates?
Comment 5 Marcell Lengyel maemo.org 2011-02-28 18:25:12 UTC
Sorry for the long delay, the x86 version of the sdk-fiasco-gen is now in the
fremantle repository.
Comment 6 Pali Rohár (reporter) 2011-03-26 13:01:10 UTC
I found i386 package on this URL:
http://repository.maemo.org/pool/maemo5.0/non-free/s/sdk-fiasco-gen/

But in maemo.org package section is still missing (there is still only armel
version):
http://maemo.org/packages/view/sdk-fiasco-gen/
Comment 7 Marcell Lengyel maemo.org 2011-04-01 10:54:01 UTC
Technically, that is a different bug, so you should not have had this one
reopened.
Anyway, Niels, could you re-import the SDK package list? Thanks.
Comment 8 Pali Rohár (reporter) 2011-04-25 13:41:31 UTC
I think this is still same bug - no i386 binary on page
http://maemo.org/packages/view/sdk-fiasco-gen/
Comment 9 Marcell Lengyel maemo.org 2011-04-28 14:51:45 UTC
(In reply to comment #8)
> I think this is still same bug - no i386 binary on page
> http://maemo.org/packages/view/sdk-fiasco-gen/

1. sdk-fiasco-gen i386 deb missing from the repository
2. the web interface for the sdk repository does not show the package

In the first case it is not possible to compile a binary. In the second case it
is possible to compile the binary, it is just a cosmetic error that the web
interface does not show the package.

The solution for the 2. is to re-import the packages files from the SDK to the
web service that shows the packages. That one belongs to the maemo.org website,
it has nothing to do with the SDK anymore. That is why I said that this is a
different bug now.
Comment 10 Pali Rohár (reporter) 2011-04-28 15:38:44 UTC
Ok. Then part 1. is solved (i386 package exists) and part 2. is not solved
(missing info on web site).

I see that you changed product info for web page (part 2). Can I create new bug
about part 2 now or not?
Comment 11 Niels Breet maemo.org 2011-06-28 16:46:51 UTC
Package has been imported, it should show up on the site with the next half our
or so.
Comment 12 Pali Rohár (reporter) 2011-06-28 17:13:40 UTC
Ok. It is fixed now.