Bug 11794 - Open Fremantle's MCE
: Open Fremantle's MCE
Status: RESOLVED WONTFIX
Product: Licensing Change Requests
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified enhancement with 6 votes (vote)
: ---
Assigned To: unassigned
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2011-01-16 21:31 UTC by Javier S. Pedro
Modified: 2011-06-03 19:36 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Javier S. Pedro (reporter) 2011-01-16 21:31:48 UTC
Which component(s) or source packages is the licensing change request about?

mce, the Mode Control Entity, version 1.8.126

Which area is the component in (if you know)? 
System sw/dsm
http://stskeeps.subnetmask.net/maemo.org/openness/pr1.1/System%20sw/dsm/bme.html

What is the current licensing of the component?
The Fremantle version is L7 (closed, not redistributable). A recent version of
it has a appeared under http://meego.gitorious.org/meego-middleware/mce
(probably for Harmattan) , this one being L1 (opened, redistributable, no
closed deps).

Unfortunately, according to the Changelog, support for the older devices has
been partially removed from this version. Additionally, not every MCE module
present in the Fremantle base firmware is present (like accelerometer,
vibrator).

What licensing would you like it to be and why?
It is already under open development, but we would like the latest Fremantle
version to be also released under a permissive license.

Which project(s) would benefit from this licensing change request?
There are many customization applications that would benefit for understanding
what mce exactly does and being able to insert hooks into it without crippling
the rest of the system. 
For example, vibrator cannot really be used on Fremantle by games because the
vibrator mce plugin resets the vibrator device every few seconds or whenever
there's user input. Similar examples happen with backlight module, etc.

What technical purpose do you/your project(s) have for wanting the licensing
change?
To be able to ship modified MCE binaries (within a community upgrade, for
example) with proper hooks for easier customization of N900 within the existing
Fremantle environment.

(Related IRC discussion:
http://mg.pov.lt/maemo-irclog/%23maemo.2011-01-16.log.html#t2011-01-16T18:48:06
)
Comment 1 Javier S. Pedro (reporter) 2011-01-16 21:37:31 UTC
Note: correct openness report link is:
http://stskeeps.subnetmask.net/maemo.org/openness/pr1.1/System%20sw/dsm/mce.html
Comment 2 Stefanos Harhalakis 2011-01-21 20:13:49 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Quim Gil nokia 2011-06-03 19:36:18 UTC
MCE for MeeGo is being developed openly at
https://meego.gitorious.org/meego-middleware/mce

There are no plans to open the Fremantle version. Please can contact the MCE
maintainers for more details and support.

(Thanks Pali for the heads up)