Bug 1163 - (int-139950) GtkCellRendererText: Can not edit with virtual keyboard
(int-139950)
: GtkCellRendererText: Can not edit with virtual keyboard
Status: RESOLVED FIXED
Product: Desktop platform
Input method framework
: 5.0/(2.2009.51-1)
: All Maemo
: Medium major (vote)
: 5.0/(10.2010.19-1)
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-22 17:56 UTC by Tommi Komulainen
Modified: 2010-03-15 20:53 UTC (History)
6 users (show)

See Also:


Attachments
minimal testcase (389 bytes, text/x-python)
2009-09-08 19:39 UTC, Thomas Perl
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tommi Komulainen (reporter) nokia 2007-03-22 17:56:03 UTC
(Extracted from bug 1154)

See attachment 254 [details] for testcase.

1. If you edit any TreeView row, you can change the text with the keyboard, but
not with the large  thumb-board.  The text appears to be modified, but when the
thumb-board goes away, the text remains the same.
Comment 1 Tommi Komulainen (reporter) nokia 2007-03-22 18:03:33 UTC
I've seen this on maemopad+ todo lists as well. Over to input methods.
Comment 2 Mohammad Anwari maemo.org 2007-03-26 15:09:07 UTC
Put Tomas in Cc.
Comment 3 Thomas Perl 2008-05-09 14:41:36 UTC
I am also experiencing this problem with applications like Maemopad+ and Todo.
It is really annoying.
Comment 4 Thomas Perl 2008-05-13 22:48:14 UTC
Oh, and the "paste" function of the on-screen keyboard also doesn't work.

I suspect the problem is that when the cellrenderertext loses focus (which is
the case when using "paste" form the on-screen keyboard or opening the thumb
keyboard), it won't be editable anymore.
Comment 5 Andre Klapper maemo.org 2008-06-12 17:32:41 UTC
Can you please post the exact software version you are running (please also
make sure it is the latest) (Control Panel > General > About product)?

Hmm, a pygtk testcase... We don't officially support python... :-/
Comment 6 Thomas Perl 2008-06-12 20:45:27 UTC
It's not pygtk-related. It's gtk-related (and therefore also affects pygtk
applications).

"Product info" screen gives:

Internet Tablet OS: maemo Linux based OS2008
Version: 2.2007.50-2

+ my Bluetooth and W-LAN MAC addresses
Comment 7 Andre Klapper maemo.org 2008-11-24 14:14:36 UTC
How can I trigger this issue in Maemopad+?
Comment 8 Thomas Perl 2008-11-24 14:39:45 UTC
(In reply to comment #7)
> How can I trigger this issue in Maemopad+?

1. Create a new "checklist" node
2. Add a new checklist item
3. Click on the checklist item to edit its text
(Now, if you use the on-screen stylus keyboard [the small one on the bottom of
the screen], this works, but..)
4. Click with the middle button of the d-pad to open the finger keyboard
5. Enter some text
6. See that the focus of the widget has been removed when the finger keyboard
has appeared, and therefore the text is not changed

If you need anything else, please tell me and I'll happily provide you with the
necessary info.
Comment 9 Andre Klapper maemo.org 2008-12-03 15:21:01 UTC
(In reply to comment #8)
> (Now, if you use the on-screen stylus keyboard
> 4. Click with the middle button of the d-pad

Sounds like N800 that I don't have. :-/
Comment 10 Andre Klapper maemo.org 2009-05-28 13:43:49 UTC
Ah. Confirming. N810:
1. Create a new checklist item in the right pane
2. have the physical keyboard not available
3. Xlick twice into the checklist item
4. The fullscreen keyboard appears.
5. Enter some text and use either the ⤶ or ⤓ button.

ACTUAL OUTCOME:
Text is lost.
Comment 11 Andre Klapper maemo.org 2009-06-08 15:44:39 UTC
Bug 4057 might be a duplicate.
Now if the Python deps would be sorted out for Fremantle this could be tested
again in Scratchbox against Fremantle... :-/
Comment 12 Andre Klapper maemo.org 2009-09-07 19:31:37 UTC
Hi, any testcase for Fremantle? Looks like Maemopad+ is not available yet...
Comment 13 Thomas Perl 2009-09-08 19:39:09 UTC
Created an attachment (id=1354) [details]
minimal testcase

(In reply to comment #12)
> Hi, any testcase for Fremantle? Looks like Maemopad+ is not available yet...

Attached you'll find a minimal testcase (tested only on Diablo on a N810,
because the Fremantle SDK does not have the full-screen virtual keyboard - at
least I was not able to bring it up).

How to reproduce (again, on Diablo; should be the same on Fremantle, though):

 1.) Copy testcase1163.py to your device
 2.) Open xterm and "cd" into the download folder
 3.) Enter command: python testcase1163.py
 4.) Double-click (touch) on the "test" row to start editing
 5.) Tap in the edit field until the fullscreen keyboard opens up
 6.) Edit the text and hit "Enter" (or the "hide keyboard" button)

Expected: Text is edited
Actual outcome: Text is not edited

Again, I suspect that the reason for this bug is that the treeview/cell loses
focus (and therefore editing stops) when the full-screen keyboard is opened.
Comment 14 Quim Gil nokia 2009-09-21 09:34:02 UTC
If test cases exists, should we file a bug against Fremantle?
Comment 15 Andre Klapper maemo.org 2009-09-21 16:05:03 UTC
Oops, seems like I missed Thomas' comment 13.

Confirming - still an issue.
Comment 16 Andre Klapper maemo.org 2009-09-23 11:42:21 UTC
Thomas: Does this also happen when linking against both gtk+ and hildon?
Comment 17 Thomas Perl 2009-09-23 20:34:43 UTC
(In reply to comment #16)
> Thomas: Does this also happen when linking against both gtk+ and hildon?

With the Python script, I don't "link" to any libraries (at least not in the C
sense of linking in libraries, which is what I think you mean).

I suppose pygtk on Maemo is linked against the hildon version of GTK+ if you
mean that, but I honestly don't know. The PyMaemo guys should know an answer to
that.
Comment 18 Andre Klapper maemo.org 2009-12-31 15:47:48 UTC
This has been fixed in package
hildon-input-method-framework 1:2.1.44-1+0m5
which is part of the internal build version
2009.52-10
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 19 Andre Klapper maemo.org 2010-03-15 20:53:10 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).