Bug 11511 - Media player doesn't show Ogg files after PR1.3 upgrade
: Media player doesn't show Ogg files after PR1.3 upgrade
Status: CLOSED WONTFIX
Product: ogg-support
General
: unspecified
: All Maemo
: Unspecified normal with 4 votes (vote)
: ---
Assigned To: Tuomas Kulve
: general
:
:
:
:
  Show dependency tree
 
Reported: 2010-11-01 02:15 UTC by Tony Green
Modified: 2011-07-27 11:55 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tony Green (reporter) 2010-11-01 02:15:14 UTC
SOFTWARE VERSION:
(Settings > General > About product)
20.2010.36-2
EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Install PR1.3
2. Place ogg vorbis files in /home/user/MyDocs/.sounds (or indeed have existing
files there)
3. open media player and go to "music"
4. Oggs are not visible.

EXPECTED OUTCOME:
Oggs should be visible as they were pre-PR1.3
ACTUAL OUTCOME:
Can't see Oggs. However, the media player can still recognise them, as any
added to playlists (such as "now playing") will play perfectly.
REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
100%
EXTRA SOFTWARE INSTALLED:
gstreamer0.10-ogg libogg0 ogg-support
OTHER COMMENTS:
Files are being indexed by the tracker, as they appear in
/home/user/.cache/tracker/file-meta.db - but for some reason the media player
doesn't show them.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.2.11)
Gecko/20101028 Mandriva Linux/1.9.2.11-0.2mdv2010.1 (2010.1) Firefox/3.6.11
Comment 1 Andre Klapper maemo.org 2010-11-03 00:31:30 UTC
Tuomas, can you take a look at this?
Is this a Multimedia Framework issue or an ogg-support issue?
Comment 2 Andre Klapper maemo.org 2010-11-03 00:34:28 UTC
*** Bug 11512 has been marked as a duplicate of this bug. ***
Comment 3 Tuomas Kulve 2010-11-03 06:29:35 UTC
(In reply to comment #1)
> Tuomas, can you take a look at this?

Uninstalling ogg-support and reinstalling it should fix the issue.

> Is this a Multimedia Framework issue or an ogg-support issue?

I don't know what is the actual reason for this so I don't know to which this
belongs to.
Comment 4 Tony Green (reporter) 2010-11-03 12:58:40 UTC
(In reply to comment #3)

> Uninstalling ogg-support and reinstalling it should fix the issue.


I can confirm that this does indeed fix the issue. Thanks.

A bit messy though, as both Mappero and Extra decoders support are dependent on
ogg-support, so they have to be unistalled then reinstalled as well.
Comment 5 erdferkel944 2010-11-10 00:55:31 UTC
I also lost the ability to see ogg files in mediaplayer after the 1.3 upgrade.
This appeared as the song playlist count being less than the ~4000 it was
before the upgrade.

Uninstalling and reinstalling ogg support seems to have fixed the problem.
Comment 6 Vincent Lefevre 2010-12-22 15:04:13 UTC
(In reply to comment #3)
> Uninstalling ogg-support and reinstalling it should fix the issue.

Here it doesn't because update-tracker-ontology crashes (segmentation fault).
Actually I think it crashes because of unexpected output from the tracker-files
utility. Indeed when I run manually

  run-standalone.sh tracker-files -m audio/x-vorbis+ogg

I get:

Results: 512
  /home/user/Music/perso/AgnusDei/AgnusDei01.ogg
  /home/user/Music/perso/AgnusDei/AgnusDei02.ogg
  [...]
  /home/user/Music/perso/CdB/CapillaDeIndias/CodexCompanon04.ogg
  ...

NOTE: Limit was reached, there are more items in the database not listed here

So, the problem seems to be the limit. There was no such limit before PR1.3!
Comment 7 Vincent Lefevre 2010-12-22 23:06:20 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Vincent Lefevre 2010-12-22 23:28:37 UTC
(In reply to comment #6)
> I get:
> 
> Results: 512
>   /home/user/Music/perso/AgnusDei/AgnusDei01.ogg
>   /home/user/Music/perso/AgnusDei/AgnusDei02.ogg
>   [...]
>   /home/user/Music/perso/CdB/CapillaDeIndias/CodexCompanon04.ogg
>   ...
> 
> NOTE: Limit was reached, there are more items in the database not listed here
> 
> So, the problem seems to be the limit. There was no such limit before PR1.3!

/usr/bin/tracker-register-mimetype contains:

for i 
do
    case "$i" in
        -c) shift; 
            echo ""
            shift ;;
        -a) shift; 
            run-standalone.sh tracker-files -m $1 |sed '1d' | while read line;
do touch "$line"; echo "touch $line"; done
            shift;;
        -d) shift; 
            run-standalone.sh tracker-files -m $1 |sed '1d' | while read line;
do touch "$line"; echo "touch $line"; done
            shift;;
    esac
done

But tracker-files --help says:

-l, --limit=NUMBER     Set the total number of displayed results (default 512)

So, tracker-files should be called with the -l option and a huge number.

Now I'd be surprised if this were the cause of the segmentation fault. I've
tried after removing the tracker database (.cache/tracker), and I no longer get
a segmentation fault, but only a few ogg files from the 512 listed are found!
Comment 9 Vincent Lefevre 2010-12-23 00:55:38 UTC
Now all the .ogg and .mp3 files have been found. Perhaps I should have waited a
bit longer... To summarize the problems in my case:

1. The segmentation fault was probably due to something bad in the tracker
database (perhaps some format has changed after the upgrade?). The
tracker-files utility is clearly not robust enough. The solution was to remove
the old database (.cache/tracker).

2. There's the default 512-file limit of tracker-files. This means that not all
files would necessarily be touched. But as I removed the old database, I think
I wasn't affected by this limit.
Comment 10 Tuomas Kulve 2011-05-24 10:51:08 UTC
I'm resolving this as WONTFIX as it works after some workarounds. If the file
limit is a real issue, let's create another bug report about it.
Comment 11 Tuomas Kulve 2011-07-27 11:55:23 UTC
Closing as WONTFIX.