Bug 11428 - (int-200488) Imap sync broken after update of zimbra server from 5.X to 6.08
(int-200488)
: Imap sync broken after update of zimbra server from 5.X to 6.08
Status: RESOLVED INVALID
Product: Email
General
: 5.0:(20.2010.36-2)
: N900 Maemo
: Unspecified major with 1 vote (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-10-20 22:34 UTC by stoffel.010170
Modified: 2010-12-29 00:54 UTC (History)
6 users (show)

See Also:


Attachments
Log in response to #5 (6.18 KB, text/plain)
2010-10-26 13:50 UTC, yraber
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description stoffel.010170 (reporter) 2010-10-20 22:34:36 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

After we update our zimbra server from version 5.X to 6.08, imap sync on n900
with pr1.2 don't work anymore. Nothing change on n900.



EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.10)
Gecko/20100922 Ubuntu/10.10 (maverick) Firefox/3.6.10
Comment 1 stoffel.010170 (reporter) 2010-10-20 22:46:03 UTC
this happens on two different n900 devices.
Comment 2 Andre Klapper maemo.org 2010-10-20 22:52:45 UTC
Hi stoffel.010170, thanks for reporting this!

Can you please fill out the bug template and provide the steps (click by click)
and your exact configuration?

Is this about direct IMAP access, or via Mail for Exchange?
Comment 3 stoffel.010170 (reporter) 2010-10-21 12:43:35 UTC
connect via IMAP from mail client on n900 

EXPECTED OUTCOME:

Sync of every mail folder and get new mail -> normal expectations from a mail
client

ACTUAL OUTCOME:

nothing happens. After update the zimbra server the sync between zimbra server
and n900 don't work. 
Delete and setup the account from the scratch on n900 give us no improvements. 

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:
on two different devices. both with firmware pr 1.2. One with extra-devel
enabled one without.

OTHER COMMENTS:
All other IMAP clients (thunderbird, evolution etc) on other system works as
well with zimbra 6.08
Comment 4 yraber 2010-10-26 09:01:53 UTC
Same problem here, also with PR1.3

I found something interesting in the zimbra log file (mailbox.log) :

INFO  [ImapSSLServer-9] [name=username@domain.com;ip=XX.XX.XX.XX;] imap - S:
E00004 BAD parse error: wrong character; expected ' ' but got '('

No error on the N900, I simply cannot sync my email. If I click on
"send&receive", nothing happens.

My Config
---------
N900 : Maemo5 20.2010.36-2
Zimbra : 6.0.8_GA_2661
Email protocol : IMAPs
Comment 5 Andre Klapper maemo.org 2010-10-26 13:06:10 UTC
Thanks, that's interesting.

Can you also debug Modest by starting an X Terminal window and entering

   export "CAMEL_DEBUG"="all"

to enable the debug mode of the mail library, and after that

   /usr/bin/maemo-summoner /usr/bin/modest.launch -s >
/home/user/MyDocs/.documents/log 2>&1

to start the email application. Then try to connect to the mailserver. Attach
the logfile named "log" here which will be in your Home directory (please check
for confidential data before attaching).
Comment 6 yraber 2010-10-26 13:50:24 UTC
Created an attachment (id=3133) [details]
Log in response to #5

I started the email application, clicked on "inbox" and then tried to sync
(send&retrieve).

Be aware that I changed the folder's names and also removed some lines (was
lazy changing all the dir names and it didn't seem to be relevant). I can
repost a complete anonymized log if needed.
Comment 7 xopotl 2010-12-08 13:17:52 UTC
Hello,

I can confirm it is still the same issue on PR1.3 and with Zimbra 6.0.9 GA
release AND only for the Inbox folder (all other folders seem to be fine).

sending : C00128 SELECT INBOX (QRESYNC (1 134020))
received: C00128 BAD parse error: wrong character; expected ' ' but got '('

Did anybody find a solution for this, please....

People are switching to blackberry here because their mail doesn't work !!

Thx.
Comment 8 Lucas Maneos 2010-12-09 12:29:32 UTC
(In reply to comment #7)
> sending : C00128 SELECT INBOX (QRESYNC (1 134020))
> received: C00128 BAD parse error: wrong character; expected ' ' but got '('

Thanks for the log output.  The above SELECT is perfectly valid according to
RFC 5162:

   select-param        =  "QRESYNC" SP "(" uidvalidity SP
                       mod-sequence-value [SP known-uids]
                       [SP seq-match-data] ")"

so this looks like a Zimbra bug.

It seems to be hitting other clients too, for example
<http://comments.gmane.org/gmane.emacs.gnus.general/74388> which indicates
Zimbra expects two spaces after QRESYNC.  That is clearly wrong (the syntax
above specifies one and only one SP) => INVALID.
Comment 9 Lucas Maneos 2010-12-22 01:35:13 UTC
*** Bug 11667 has been marked as a duplicate of this bug. ***
Comment 10 Chris Samuel 2010-12-29 00:54:56 UTC
The relevant Zimbra bug (#52403) includes a way to disable the broken QRESYNC
functionality in the server until an official fix is released in Zimbra 6.0.11.

http://bugzilla.zimbra.com/show_bug.cgi?id=52403#c21