Bug 1142 - (int120397/int-220650) Impossible to add authenticated RSS feeds (username & password)
(int120397/int-220650)
: Impossible to add authenticated RSS feeds (username & password)
Status: RESOLVED WONTFIX
Product: RSS feed reader
General
: 5.0:(20.2010.36-2)
: All All
: Low normal with 2 votes (vote)
: Harmattan
Assigned To: unassigned
: rss-feed-reader-bugs
: http://home.maneos.org/maemo-bug-1142...
:
:
:
  Show dependency tree
 
Reported: 2007-03-16 13:25 UTC by L. G.
Modified: 2011-04-14 15:06 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description L. G. (reporter) 2007-03-16 13:25:07 UTC
RSS & atom feeds coming from a webserver which requires login are not supported
by the newsreader.
Comment 1 Jason Carter 2007-07-23 18:01:18 UTC
Indeed, this is still a problem. For example, I use Livejournal's RSS feeds to
keep track of my friends and their blogs however there are some posts which are
private and can only be read by certain friends. You must be logged in to read
them.

Currently, the RSS feed reader sees the public posts. I'll be adding more
information to this bug soon along with some test cases to help fix it.
Comment 2 Jason Carter 2007-07-31 16:25:05 UTC
Looking at the Liferea FAQ site (http://liferea.sourceforge.net/faq.htm),
you'll notice the following:

Q: I want cookies!
A: Liferea supports cookies provided by a text file ~/.liferea_1.2/cookies.txt
which contains cookies in Netscape format. The easiest way is to copy the file
from your Mozilla profile after you created the cookies with the browser.

I figured that since we have the microb browser, we should be able to use this
trick. I did indeed find the cookies.txt file and copied it into
.osso_rss_feed_reader but it didn't seem to change anything. It's entirely
possible that the code to do this wasn't implemented in the version used by
Maemo or that it's still actually looking for ~/.liferea_version... which I
haven't tried yet.

If someone gives it a shot, please let us know.
Comment 3 Andre Klapper maemo.org 2008-06-24 16:53:54 UTC
Which exact version and hardware is this about? Does this also happen with
IT2008?
Hmm, anybody able to create an example URL / example login? :-/
Comment 4 Andre Klapper maemo.org 2008-10-20 15:10:07 UTC
Anybody can answer my questions, please? :)
I'd love to have a URL to test this.
Comment 5 Quim Gil nokia 2009-01-18 01:03:44 UTC
Are these authenticated feeds always in https?

I'm tempted of putting Bug 2807 and Bug 3885 as dependencies of this one, but I
don't know whether "a webserver which requires login" = "https"

Anyway, perhaps it is better to centraliz the discussion in Bug 3885 since it
is better reported and followed.
Comment 6 Quim Gil nokia 2009-05-18 22:56:54 UTC
Resolving as DUPLICATE. Please reopen if you disagree.

*** This bug has been marked as a duplicate of bug 3885 ***
Comment 7 Lucas Maneos 2009-06-05 11:15:56 UTC
(In reply to comment #5)
> Are these authenticated feeds always in https?

No, although the most common HTTP authentication method (Basic) sends the
password essentially in the clear so in most cases they should be (then again
people seem happy to use FTP, POP etc even on public hotspots so what do I
know).  But transport encryption (HTTPS) and authentication are separate
issues, thus reopening.

Just to muddy the waters it's also possible to do HTTPS authentication with SSL
client certificates, but let's cross that bridge when we come to it.
Comment 8 Andre Klapper maemo.org 2009-09-30 15:09:50 UTC
So can I please get a test URL for this?
Comment 9 Lucas Maneos 2009-10-01 01:25:59 UTC
Try <http://home.maneos.org/maemo-bug-1142/test.rss> using "a" as both the
username & password.
Comment 10 Andre Klapper maemo.org 2009-10-02 14:40:11 UTC
Thanks a lot!
Confirming - this is a HTTP feed, can be opened in browser, but adding it to
RSS reader shows "Unable to add feed. Address invalid."

http://a:a@home.maneos.org/maemo-bug-1142/test.rss does not work either.

Filed an internal ticket (and expecting an "It was never a requirement to
implement this" answer, but maybe Nokia will surprise me).
Comment 11 Andre Klapper maemo.org 2010-09-08 12:54:39 UTC
WONTFIX for Maemo5 according to Nokia. Now need to find out if this is still
valid in Harmattan (the version after Maemo5)...
Comment 12 Andre Klapper maemo.org 2011-04-14 15:06:14 UTC
Harmattan (the software version after Maemo5) will show an error message:
“Unable to access feed. Authentication not supported”.

So it's not planned to add HTTPS support for Harmattan, but you will at least
get a less vague error message.
Plus according to Nokia this unfortunately is a WONTFIX for Maemo5.