Bug 1129 - Media player doesn't save the timeposition on close for audio
: Media player doesn't save the timeposition on close for audio
Status: RESOLVED WONTFIX
Product: Media player
General
: 5.0/(1.2009.41-10)
: All Maemo
: Medium enhancement with 55 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-07 18:23 UTC by Ville Reijonen
Modified: 2012-03-24 11:47 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ville Reijonen (reporter) 2007-03-07 18:23:56 UTC
If I'm listening a long podcast and I need to close the media player or boot
the
device the position will be lost. So I suggest that there should be a way to
bookmark the position and continuing from the bookmark. Then I could also stop
listening an podcast and look an video and after that I could continue from
where I was before. To make it easy to implement there should be only one
bookmark per file/playlist and files which go missing would lose their
bookmarks. In the library there would be fourth icon for bookmarks and and
under
that would be the unfinished files/playlists.
Comment 1 Jake Kunnari 2007-03-13 11:15:29 UTC
Quim Gil added to CC-field
Comment 2 Hanno Zulla 2007-03-16 10:22:27 UTC
I wish to add that I have the same problem with video files. I watch my videos
on the bus and at similar locations on the go and usually have only a few
minutes to watch them.

My suggestion is not to use a manual bookmark feature. The media player should
remember the location on the file when the user last used "stop" or "close" and
should return to it.

The vdr (Linux video disk recorder) has done this in a very user-friendly way:
It always remembers locations and has a menu item to start the file from 0:00 again.
Comment 3 Luca Donaggio 2007-03-16 12:48:22 UTC
It would be nice if we could manually select the starting point from which to
resume viewing a long video too!
Comment 4 Hanno Zulla 2007-04-16 10:42:00 UTC
On vdr, the player resumes playback from a few seconds before the bookmark.
This
is very practical.
Comment 5 john 2007-04-16 18:25:27 UTC
This strikes me as a fairly fundemental need in a media player.
Comment 6 Hanno Zulla 2007-04-20 14:53:39 UTC
Please consider the following proposal:

By default, save the timeposition of the media file whenever the user stops
playback or closes the media player. You might save the position in a .-file in
the same directory as the media file (e.g. ".feature-film.avi.pos").

When the user starts playback, the media player should look for the .-file and
resume playback from, say, 15 seconds before the stored position. (A new
position should not be stored when it is less than 15 seconds before a
previously stored position for the same file.)

Thanks.
Comment 7 Hanno Zulla 2007-04-20 18:04:30 UTC
*** Bug 1225 has been marked as a duplicate of this bug. ***
Comment 8 Quim Gil nokia 2007-07-05 13:36:56 UTC
Picking this one.
Comment 9 Thomas Perl 2008-01-25 08:42:40 UTC
I would also like to have this feature. This would be one of the features the
N800 needs to replace iPods. For playing podcasts (or listening to audio
books), this feature is really needed. I would also need it for playing long
radio recordings.
Comment 10 Luc Pionchon nokia 2008-07-18 17:32:23 UTC
To add my vote: this is clearly a MUST HAVE.
Comment 11 Thomas Perl 2008-07-18 18:02:23 UTC
FYI: A GStreamer-based Resuming Audiobook/Podcast player is now available for
Chinook and Diablo: http://thpinfo.com/2008/panucci/
Comment 12 Dan Ramos 2008-07-19 08:21:33 UTC
Thanks for the link to the resuming player but that player lacks any other
functionality (no 'rewind', 'fast forward' nor seeking despite the really
useful bookmarking.

I would still like to see this feature coded into the existing Nokia media
player.  On that note--has there been any attention on this feature from Nokia?
Comment 13 Thomas Perl 2008-07-19 14:14:43 UTC
(In reply to comment #12)
> Thanks for the link to the resuming player but that player lacks any other
> functionality (no 'rewind', 'fast forward' nor seeking despite the really
> useful bookmarking.

Actually that's just a bug on first run. If you press the "Play" button while
it's playing, the audio will pause, if you resume (via the "Play" button)
again, the seeking buttons will become active again. The Double-arrows will
seek forward/backward one minute and the Single-arrows will do the same in 10
second steps. I've deliberately not included a seek bar, so one does not
accidentally move somewhere into the audiobook/podcast and have a hard time
coming back to the original position. You can still move pretty quickly (and
precise) with the seek buttons.
Comment 14 kenneth 2008-09-30 04:11:32 UTC
there are more issues with that program then just the seek bug. like say no
file history, or having to relaunch the program ech time one wants to listen to
a new file.
Comment 15 Quim Gil nokia 2008-09-30 13:01:10 UTC
In Fremantle the media player will rememember the time position you left your
files/playlists.
Comment 16 Thomas Perl 2008-09-30 18:35:24 UTC
(In reply to comment #15)
> In Fremantle the media player will rememember the time position you left your
> files/playlists.

Will the media player be available for N8x0 devices/Diablo, too?

Just so that this feature isn't implemented partially in Fremantle: As the
original poster suggested, it would be nice to have a per-file time position
remember function, not just "open last file and resume playback from there"
(which is what the bug title suggests).

In the mean time, the player mentioned in comment #11 has been moved forward to
a complete open source project (http://panucci.garage.maemo.org/) which might
be helpful for Diablo users wanting that feature right now, or for N8x0 users
in general should Fremantle not be available for N8x0 devices :/
Comment 17 Quim Gil nokia 2008-10-06 15:19:04 UTC
(In reply to comment #16)
> Will the media player be available for N8x0 devices/Diablo, too?

Too soon to tell. First we need to have Midas out (soon hopefully, and you will
be able to make it work in Diablo). Then let's have Fremantle alpha released
(before the end of the year).

> Just so that this feature isn't implemented partially in Fremantle: As the
> original poster suggested, it would be nice to have a per-file time position
> remember function, not just "open last file and resume playback from there"
> (which is what the bug title suggests).

This is what Midas should provide, yes.
Comment 18 Quim Gil nokia 2008-10-08 10:35:53 UTC
I got more details about the implementation and in fact the whole
timepositioning will be dealt by Midas together with Meta Tracker (also open
source). This means that if you are unhappy about the details of the
implementation you can always propose a patch.  :)
Comment 19 Quim Gil nokia 2008-11-26 13:03:58 UTC
Resolvinf as fixed in Fremantle
Comment 20 Thomas Perl 2009-10-20 16:24:52 UTC
(In reply to comment #19)
> Resolvinf as fixed in Fremantle

This is not really fixed for audio files in Fremantle's Media Player yet. Media
player does resume *Video* files quite nicely, but it does not yet work for
audio files (which the initial request was all about).
Comment 21 Andre Klapper maemo.org 2009-10-20 19:19:23 UTC
True...
Comment 22 Andre Klapper maemo.org 2012-03-24 11:47:07 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )