Bug 11285 - (int194337/int-194365) Bluetooth scan displays empty buttons
(int194337/int-194365)
: Bluetooth scan displays empty buttons
Status: RESOLVED FIXED
Product: UI Specification
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: Harmattan
Assigned To: unassigned
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-09-15 12:23 UTC by Kaj-Michael Lang
Modified: 2011-05-05 17:30 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot displaying the empty buttons (81.42 KB, image/png)
2010-09-15 12:23 UTC, Kaj-Michael Lang
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Kaj-Michael Lang (reporter) 2010-09-15 12:23:19 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Go to bluetooth settings interface
2. Scan for new devices


EXPECTED OUTCOME:
Display all found devices properly with icon,description,bind information 

ACTUAL OUTCOME:
Displayed buttons with nothing in them.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
nothing that touches low level bluetooth interfaces

OTHER COMMENTS:
See attached screenshot

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3)
Gecko/20100621 Firefox/3.0.13
Comment 1 Kaj-Michael Lang (reporter) 2010-09-15 12:23:54 UTC
Created an attachment (id=3083) [details]
Screenshot displaying the empty buttons
Comment 2 Andre Klapper maemo.org 2010-09-15 16:08:51 UTC
Hi,

I wonder if there's two devices around with "" IOW empty name and set to
visible?

What happens when you click one of the empty options (might also be interesting
to get a syslog for that special case, no idea though if something will be
printed)?

(Note to myself: int-123092)
Comment 3 Kaj-Michael Lang (reporter) 2010-09-17 09:00:51 UTC
Yes, it looks like someone around at work has some device with no name set
visible.

Scanning+querying on desktop with hcitool gives:
Inquiring ...
    5C:57:xx:xx:xx:xx    clock offset: 0x7c4f    class: 0x5a020c
Requesting information ...
    BD Address:  5C:57:xx:xx:xx:xx
    Device Name: 
    LMP Version: 2.0 (0x3) LMP Subversion: 0x2222
    Manufacturer: Broadcom Corporation (15)
    Features: 0xbf 0xee 0x0f 0x4e 0x98 0x19 0x00 0x00
        <3-slot packets> <5-slot packets> <encryption> <slot offset> 
        <timing accuracy> <role switch> <sniff mode> <RSSI> 
        <channel quality> <SCO link> <HV3 packets> <u-law log> 
        <A-law log> <CVSD> <paging scheme> <power control> 
        <transparent SCO> <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> 
        <enhanced iscan> <inquiry with RSSI> <AFH cap. slave> 
        <AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL> 
        <AFH cap. master> <AFH class. master>
Comment 4 Andre Klapper maemo.org 2010-09-24 13:37:51 UTC
Internal Nokia comment:
"If a device doesn't have a name then of course it is empty."
Comment 5 Kaj-Michael Lang (reporter) 2010-09-24 14:57:45 UTC
Those no-name device(s) are not mine and I can't control them. For a user,
Wwhen scanning for devices and just getting a bunch of empty buttons (no icon,
no explanation) visually it looks like something is wrong, IMO.

Displaying a generic bluetooth icon or displaying the hw address would make it
clear that there is a real device behind the button.
Comment 6 Andre Klapper maemo.org 2010-09-24 15:10:29 UTC
I totally agree. This has to be resolved in the internal UI Specifications for
Harmattan (the version after Maemo5), hence moving Product to Specs.

For Maemo5 this is a WONTFIX as the Maemo5 UI is considered stable by Nokia.
Comment 7 Andre Klapper maemo.org 2011-05-05 17:30:51 UTC
This issue has been FIXED for Harmattan (the software version after Maemo5).

Bluetooth UI Spec says now:
"Bluetooth devices view
Unnamed device: Label to be shown instead of Bluetooth device name if device
name is empty."

According to Nokia UI changes are a WONTFIX for Maemo5.