Bug 11136 - MfE: No provisioning supported (not working with Exchange Server 2007)
: MfE: No provisioning supported (not working with Exchange Server 2007)
Status: RESOLVED DUPLICATE of bug 8452
Product: Synchronization
Mail for Exchange
: 5.0:(10.2010.19-1)
: ARM Maemo
: Unspecified major (vote)
: Harmattan
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-08-15 02:38 UTC by chandan
Modified: 2011-06-22 23:28 UTC (History)
2 users (show)

See Also:


Attachments
activesync.log (167.83 KB, application/octet-stream)
2010-08-15 02:41 UTC, chandan
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description chandan (reporter) 2010-08-15 02:38:26 UTC
SOFTWARE VERSION: 10.2010.19-1.004

EXACT STEPS LEADING TO PROBLEM: 
1. MfE: Credentials
E-mail Address: chandan.chXXXXX@accenture.com
User Name: chandan.chXXXXX 
Password: xxxxxxx
Domain: dir

2. MfE: Server Settings
Server: ind.email.accenture.com [Auto-detected]
Port: 443
Secure Connection [Checked]

3. MfE: Synchronisation Content
Synchronise e-mail [Checked]
Synchronise calendar and tasks [Checked]
Synchronise contacts [Checked]
First Synchronisation: Keep Items on Device

4. MfE: First Synchronisation
Initialising Synchronisation

Message: Exchange Account Disabled. Access Refused
Message: Error in Communication with Exchange Server




EXPECTED OUTCOME:
Should have created a local account and synced with exchange server.

ACTUAL OUTCOME:
Error Message (please refer the message in step-4 above)

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:


OTHER COMMENTS:
* The root certificate for Entrust.net was not installed in my N900 by default.
I have manually installed both the Entrust.net and our server certificates.
* I am not sure about the server version or if "non provisioning devices" are
allowed. 
* Colleagues having N97 are able to access their mails using similar
credentials. 

I am trying to get more info, but as our company is little big, admins are not
that interested to answer this kind of questions. Please feel free to ask any
other details that will help to resolve the issue. Thanks.

::Certificate Verification::
Nokia-N900:/home/user/.activesync# cmcli -T common-ca -t ssl-ca -v
ind.email.accenture.com:443
97761e84cfd9e7d527b5598b0edb908477caecba ind.email.accenture.com
 trust chain(2):
   eabf10a5011e958fc955b46760a48ffd8b0f12b4 Entrust.net Secure Server
Certification Authority
   +->97761e84cfd9e7d527b5598b0edb908477caecba ind.email.accenture.com
Verified OK
Nokia-N900:/home/user/.activesync#


:: Details from OWA->Option->About ::
Mailbox owner: ChXXXXX, Chandan [chandan.chXXXXX@accenture.com]
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Outlook Web Access experience: Premium
User language: English (United States)
User time zone: (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi
Exchange mailbox address: /o=Exchange Mail/ou=APA2 Administrative
Group/cn=Recipients/cn=chandan.chXXXXX
Outlook Web Access host address: https://ind.email.accenture.com/owa
Outlook Web Access version: 8.2.254.0
Outlook Web Access host name: ind.email.accenture.com
S/MIME control: not installed
Client Access server name: INDXC3011.dir.svc.accenture.com
Exchange Client Access server .NET Framework version: 2.0.50727.3053
Client Access server operating system version: Microsoft Windows NT 5.2.3790
Service Pack 2
Client Access server operating system language: en-US
Microsoft Exchange Client Access server version: 8.2.176.0
Client Access server language: en-US
Client Access server time zone: India Standard Time
Microsoft Exchange Client Access server platform: 64bit
Mailbox server name: INDXM3121.dir.svc.accenture.com
Mailbox server Microsoft Exchange version: 8.2.176.0
Other Microsoft Exchange server roles currently installed on the Client Access
server: 
Authentication type associated with this Outlook Web Access session: Basic
Public logon: No
Comment 1 chandan (reporter) 2010-08-15 02:41:34 UTC
Created an attachment (id=3030) [details]
activesync.log
Comment 2 chandan (reporter) 2010-08-17 19:26:48 UTC
Confirmed that my mailbox in on a Exchange 2007 server.
Comment 3 Andre Klapper maemo.org 2010-08-19 15:04:52 UTC
Comment by Nokia:

"Accenture Exchange server works with provisioned devices only.
However, on Maemo5 we don't support and don't plan to support provisioning."

Trying to find out more about plans for the next software release before
closing as WONTFIX.
Comment 4 Andre Klapper maemo.org 2010-08-19 16:25:22 UTC
Seems to be planned for Harmattan. WONTFIX for Maemo5.
Comment 5 chandan (reporter) 2010-08-19 18:23:55 UTC
Thank you so much Andre.

Waiting eagerly for Harmattan and MfE provisioning support.
Comment 6 Andre Klapper maemo.org 2010-09-13 21:57:34 UTC
This has now been fixed internally for Harmattan (the version after Maemo5).
Comment 7 Andre Klapper maemo.org 2011-06-22 23:28:47 UTC
Marking as duplicate of bug 8452 where more votes and comments are.

*** This bug has been marked as a duplicate of bug 8452 ***