Bug 11130 - gPodder steals focus after updating podcasts in the background.
: gPodder steals focus after updating podcasts in the background.
Status: RESOLVED FIXED
Product: gPodder
General
: unspecified
: N900 Maemo
: Unspecified enhancement (vote)
: ---
Assigned To: Thomas Perl
: general
:
:
:
:
  Show dependency tree
 
Reported: 2010-08-13 20:45 UTC by Pavel N. Krivitsky
Modified: 2010-08-16 23:50 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Pavel N. Krivitsky (reporter) 2010-08-13 20:45:25 UTC
SOFTWARE VERSION: 2.7
EXACT STEPS LEADING TO PROBLEM: 
1a. Set gPodder to update podcasts periodically.
OR
1b. Press "Check for new episodes"
2. Set gPodder in the background.
3. Switch to, or start, another application.
3. Wait until an update finishes.

EXPECTED OUTCOME:
gPodder will notify the user when the new podcasts are available,
unobtrusively.

A good way to do this would be with the sort of notification popups that appear
when new e-mail or SMS message arrives, saying "X new podcasts available".

ACTUAL OUTCOME:
gPodder steals focus from whatever program is running in the foreground to
display the list of new podcasts, interrupting whatever the user is doing.

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED: None relevant.

OTHER COMMENTS:
I am calling it an "enhancement", since it does not impact gPodder's own
functionality, but, as far as I am concerned, this is a usability bug that
causes it to not play well with other applications on a tablet system.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8)
Gecko/20100729 Iceweasel/3.6.7 (like Firefox/3.6.7)
Comment 1 Thomas Perl 2010-08-16 22:44:18 UTC
Started working on it...
Comment 2 Thomas Perl 2010-08-16 22:45:57 UTC
Oh, and a short progress report with pictures of the current status:

http://thpmaemo.blogspot.com/2010/08/desktop-notification-support-in-gpodder.html
Comment 3 Thomas Perl 2010-08-16 23:50:14 UTC
Fix committed: http://gpodder.org/commit/bfd71006

There might be some more changes that better integrate this notification with
the gPodder main window, but the focus-stealing effect is gone now in the
development version.

The fix will be part of the next gPodder release.