Bug 11101 - widget disappearing
: widget disappearing
Status: RESOLVED INVALID
Product: Desktop platform
general
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-08-09 17:52 UTC by Brice
Modified: 2010-12-14 02:45 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Brice (reporter) 2010-08-09 17:52:37 UTC
SOFTWARE VERSION:
(Settings > General > About product)

10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. place x widget on desktops
2. use the phone (call, net, ...)
3. notice that one or serveral of the widgets disappeared (not all)

EXPECTED OUTCOME:
widget stay active.


ACTUAL OUTCOME:



REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always but time is variable.

EXTRA SOFTWARE INSTALLED:
widgets : 
foreca weather
recaller
agenda


OTHER COMMENTS:
Recaller has an option to automatically start recording when a call starts
If widget no more active, it doesn't work anymore.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.8)
Gecko/20100722 Firefox/3.6.8
Comment 1 Andre Klapper maemo.org 2010-08-09 17:58:36 UTC
Thanks for reporting this, but unfortunately this report isn't very useful
because it doesn't describe the issue well. If you have time and can still
reproduce the problem, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug, especially a concrete case. What does "x widget" stand
for? Does this happen with all three widgets that you have listed?
Comment 2 Brice (reporter) 2010-08-09 18:06:37 UTC
I use the following widgets : 
Foreca weather
Agenda
Recaller

Foreca and AGenda are on the same desskop
Recaller is on another one.

This morning, the 3 were appearing and active

After a while (calls?), only the agenda stays.

I can place them back (as if they were never selected from "desktop menu > add
widget") and it works fine ... until they disappear again.

Recaller is suspicious. I use the 2.0 version by Tom Waelti.
Comment 3 Andre Klapper maemo.org 2010-08-09 18:11:12 UTC
What other extra software is installed?
When does this happen (after how long)?

(In reply to comment #2)
> Recaller is suspicious. I use the 2.0 version by Tom Waelti.

See http://wiki.maemo.org/Recaller#Bugs in that case.
Comment 4 Brice (reporter) 2010-08-09 18:25:21 UTC
>What other extra software is installed?
all other software (less than 8) must be launched (not resident)
AccDisplay
Amazon Installer (default)
AP News installer(default)
Bullshit Bingo
Countdown timer
Crimson fields
Documents to go Installer (default)
Extended call log
Facebook installer(default)
Flashlight
foreca installer
foreca weather widget
Maemo5
Ogg support
OpenSSH client
Personal data plan monitor( but widget not used)
Recaller
Recorder
Tutorial-home-applet
Wifi switcher





>When does this happen (after how long)?
in minutes or hours. but impossible to say if it's time or event driven
I don't monitor the widget permanently. 



further, after a problem with the phone, it was totally replaced.
Same problem appeared with the old one.
Comment 5 Andre Klapper maemo.org 2010-08-11 21:13:53 UTC
http://blog.barisione.org/2010-08/disappearing-plugins/ ?
Comment 6 Andre Klapper maemo.org 2010-08-26 16:05:04 UTC
*** Bug 11204 has been marked as a duplicate of this bug. ***
Comment 7 Hans 2010-09-17 06:26:56 UTC
Have the same problem. Most probably it's caused by 'recaller'
http://talk.maemo.org/showthread.php?t=59191
Comment 8 Andre Klapper maemo.org 2010-12-13 18:32:23 UTC
Is this still a problem in 10.2010.36-2?
Comment 9 Hans 2010-12-14 02:45:50 UTC
(In reply to comment #8)
> Is this still a problem in 10.2010.36-2?

Yes (and most probably 'recaller' is causing it)