Bug 1109 - Use english strings if locale does not exist after restore (instead of logical strings)
: Use english strings if locale does not exist after restore (instead of logica...
Status: RESOLVED WONTFIX
Product: Desktop platform
Internationalization
: 5.0/(3.2010.02-8)
: All Maemo
: Low enhancement with 2 votes (vote)
: ---
Assigned To: unassigned
: i18n-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-01 12:54 UTC by Marcin Juszkiewicz
Modified: 2012-03-24 11:43 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Juszkiewicz (reporter) 2007-03-01 12:54:37 UTC
I have OS2007 running on my 770 (from Os2007on770 project). Installed
locale-extra-polish package to get pl_PL regional settings.

Today I had to reflash device. After restoring of backup I got messages like
'home_ap_home_view' instead of normal texts. After installing locale package and
reboot all is OK again.

OS should detect does user restore settings with not existing regional settings
and ask which one to choose or fall back to English.
Comment 2 Marcin Juszkiewicz (reporter) 2007-12-23 01:19:10 UTC
Closing as my 770 is not supported anyway and there is no way to officially buy
maemo powered devices in Poland.
Comment 3 Marcin Juszkiewicz (reporter) 2008-01-31 10:50:45 UTC
Reopen as this bug happens also under OS2008. 

I am starting to think that it will never solved.
Comment 4 Andre Klapper maemo.org 2008-06-24 16:06:44 UTC
Hi Marcin, locale-extra-polish is the exact package name?
Which repository is this in? any URL?
Comment 5 Marcin Juszkiewicz (reporter) 2008-06-24 17:26:03 UTC
Andre: It was locale-extras-polish from http://eko.one.pl/maemo/ repository. I
do not use that 770 anymore (it runs Poky now).
Comment 6 Andre Klapper maemo.org 2008-07-04 15:57:49 UTC
Two people on the mailing lists also stated that the problem disappears after
disabling the "give" plugin.

"After disabling the plugin i had to wait a few seconds the hildon
desktop restarts and the messages are looking well again."

This will not fix the original problem described in this bug report, but the
szmptoms are similar hence adding a comment here.
Comment 7 Andre Klapper maemo.org 2008-11-17 15:15:13 UTC
Marcin: I assume this still happens with 4.2008.36-5?
Can you provide a screenshot? (Yes, make it as easy as possible for the
developers.)
Sigh, one day I should try to reproduce all the Backup bugs... :-/
Comment 8 Andre Klapper maemo.org 2008-11-25 17:04:55 UTC
...Marcin?
Comment 9 Andre Klapper maemo.org 2009-02-27 00:27:20 UTC
One you could test:
0. Set locale to pt-BR.
1. Make a backup of settings.
2. Use "unzip" on a desktop
3. For simplicity, make another backup w/ locale en-US.
4. Use "unzip" on a desktop
5. Diff them
Comment 10 Andre Klapper maemo.org 2009-06-08 18:19:03 UTC
This is a case that is not officially covered => enhancement request.
Comment 11 Andre Klapper maemo.org 2009-10-17 00:08:01 UTC
Definitely would love to have a Maemo5 testcase here.--> moreinfo
Fremantle does provide Polish by default though. :-P
Comment 12 dark-freeman 2010-01-29 23:40:36 UTC
After Using the Internettablet (N800) for a few days, the correct localisation
just appears.
Installing a few programms maybe cures the system. 
I can imagine that some installation routine just recreates the localisation.

I use the standard german localisation. 
After reflashing the device, setting up the config from a backup, the
localisation was broken. Just like written in the other comments of this
bug-report.

It's magic.
Comment 13 Andre Klapper maemo.org 2010-02-04 10:01:28 UTC
So is there any way (exact steps) to test this again in Maemo5? Because
otherwise I'll close this either as WORKSFORME or WONTFIX... :-/
Comment 14 Marcin Juszkiewicz (reporter) 2010-02-04 11:55:30 UTC
(In reply to comment #13)
> So is there any way (exact steps) to test this again in Maemo5? Because
> otherwise I'll close this either as WORKSFORME or WONTFIX... :-/

Install Slovak or Chinese translation (both are in Extras*), switch to it, do
backup, reflash, restore backup.
Comment 15 Andre Klapper maemo.org 2012-03-24 11:43:43 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )