Bug 1100 - flasher not available for Mac OS X PPC
: flasher not available for Mac OS X PPC
Status: RESOLVED FIXED
Product: Flasher
Mac OS X
: 5.0-beta
: All Mac OS X
: High enhancement with 9 votes (vote)
: ---
Assigned To: Quim Gil
: flasher-macosx-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-26 06:59 UTC by Sean Luke
Modified: 2009-08-28 15:48 UTC (History)
6 users (show)

See Also:


Attachments
Flasher-3.5 beta for PPC Mac (197.30 KB, text/plain)
2009-08-11 13:41 UTC, Jarmo Tikka
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Sean Luke (reporter) 2007-02-26 06:59:54 UTC
Summary says it all.
Comment 1 Darren Long 2007-05-26 13:28:54 UTC
Please also ensure it's good for PPC and x86.  Source code might be useful. 
This is more urgently required due to bug999 requiring a reflash to bring the
n800 back to life.
Comment 2 Patrik Flykt nokia 2007-06-25 15:01:35 UTC
Moving to another component.
Comment 3 Ryan Abel maemo.org 2007-11-30 15:27:53 UTC
*** Bug 1965 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2008-06-23 15:37:40 UTC
very similar request to bug 1013
Comment 5 Quim Gil nokia 2008-10-31 22:57:08 UTC
Another possibility is to open the Linux flasher source code and development,
allowing third parties to contribute and maintain the versions that Nokia is
not providing officially.
Comment 6 Andre Klapper maemo.org 2008-11-26 17:47:24 UTC
In fact it's not a bug but an enhancement request to support more platforms. ->
Changing severity.
Comment 7 Andre Klapper maemo.org 2009-06-30 18:05:02 UTC
According to http://lists.maemo.org/pipermail/maemo-users/2009-June/013886.html
Flasher 3.5 is available for Mac OS X 10.5 Leopard on x86.
Confirmation welcome.

This fixes half of this bug report - PPC still left, hence changing bug
summary.
Comment 8 Ryan Abel maemo.org 2009-07-01 03:04:16 UTC
Upping severity and priority. This is as simple as checking a second box in
XCode at compile time.
Comment 9 Andre Klapper maemo.org 2009-07-01 12:38:45 UTC
I disagree that this is a blocker - it does not block testing work (but as
always, the difference between bug and enhancement can be really small).

Anyway, if Ryan is correct it should be *really* trivial to provide flasher for
Mac OS PPC.
Comment 10 Jarmo Tikka nokia 2009-07-01 12:53:33 UTC
I do not know Mac development environment myself well enough to know if PPC
binaries can be built in x86 environment. If they can we can probably release
PPC version as beta but if PPC Mac is needed for PPC binary builds this will go
to the final.
Comment 11 Andre Klapper maemo.org 2009-07-01 13:02:40 UTC
Yeah, you could release PPC support as beta and ask the community for testing.
If it's really as trivial as Ryan described this could also solve bug 1013. :-)
Comment 12 Jarmo Tikka nokia 2009-08-11 13:41:48 UTC
Created an attachment (id=1300) [details]
Flasher-3.5 beta for PPC Mac

PPC version of flasher-3.5 for initial test
Comment 13 Andre Klapper maemo.org 2009-08-27 10:04:57 UTC
*** Bug 1013 has been marked as a duplicate of this bug. ***
Comment 14 Jarmo Tikka nokia 2009-08-28 15:48:47 UTC
Just short update to add link to the generic flasher-3.5 documentation in case
someone actually wants to test this PPC version. Read file
"Readme_Maemo_Flasher-3.5_Beta.txt" from here:
http://tablets-dev.nokia.com/maemo-dev-env-downloads.php