Bug 10976 - (int-156056) Takes 12-15 sec to display Call application UI during video call when opening a missed call notification
(int-156056)
: Takes 12-15 sec to display Call application UI during video call when opening...
Status: RESOLVED FIXED
Product: Desktop platform
libosso
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(20.2010.36-2)
Assigned To: rtcomm@maemo.org
: libosso-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-07-21 19:51 UTC by Harish Koka
Modified: 2010-10-25 17:13 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Harish Koka (reporter) 2010-07-21 19:51:42 UTC
SOFTWARE VERSION:
10.2010.19-1

User online with gtalk and skype.

EXACT STEPS LEADING TO PROBLEM:
1. Establish a one way gtalk video call. I have logged in to gmail in laptop
with no webcam and placed a video call to N900 user.
2. Gmail user can see the video of user in N900.
3. Now place a skype incoming call to N900. N900 user gets a missed call.
4. Wait for the missed call notification to go to background.
5. Tap on application switcher(blinking at the top left of the screen) and then
tap on missed call notification.

EXPECTED OUTCOME:
The call application UI should be shown as soon as possible.

ACTUAL OUTCOME:
The call application UI after 12-15 sec. This is quite a long time. 
After this the call application is minimized.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2010-07-22 10:10:24 UTC
How often did you try this?
Comment 2 Harish Koka (reporter) 2010-07-22 18:55:17 UTC
(In reply to comment #1)
> How often did you try this?
> 

I have tried it 5 times and this is always reproducible.
Comment 3 Andre Klapper maemo.org 2010-08-25 11:22:53 UTC
This has been fixed in package
libosso 2.32-1+0m5
which is part of the internal build version
2010.22-2
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-10-25 17:13:45 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.