Bug 1097 - Sometimes it's impossible to unlock the device.
: Sometimes it's impossible to unlock the device.
Status: RESOLVED FIXED
Product: System software
Device lock
: unspecified
: All Maemo
: Medium normal with 1 vote (vote)
: ---
Assigned To: unassigned
: device-lock-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-25 15:29 UTC by Marius Gedminas
Modified: 2008-12-06 17:01 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marius Gedminas (reporter) 2007-02-25 15:29:18 UTC
This happened to me twice: I had Canola running in full-screen mode, I locked
the keyboard and keys, and later when I tried to unlock it, I couldn't.

When I pressed the Power key, I got the "Press [*] to unlock" message.  No
matter how many times I pressed the D-pad center key, the N800 ignored it.  The
only solution I found was to pull the battery.
Comment 1 Neil MacLeod maemo.org 2007-02-26 00:34:13 UTC
I've also had this exact behaviour - running Canola on N800, lock the device
and
then it's impossible to unlock without pulling the battery (d-pad totally
unresponsive - doesn't even make a "click" system sound when pressing
up/left/down/right/center).
Comment 2 Marius Gedminas (reporter) 2007-02-26 18:07:08 UTC
I think I should mention that this bug doesn't always appear when I lock Canola
in full-screen mode.

Also, this bug may be a duplicate of https://maemo.org/bugzilla/show_bug.cgi?id=941

I do have a recurring alarm set (9 am every morning; it doesn't always ring, but
that's a different bug).  My screen blanking is set to 5 minutes, but I do not
have automatic key locking enabled.  I do not use soft poweroff, just the
regular lock screen and keys.
Comment 3 Stephen Gadsby maemo.org 2007-08-13 23:08:18 UTC
(In reply to comment #0)
> This happened to me twice: I had Canola running in full-screen mode, I locked
> the keyboard and keys, and later when I tried to unlock it, I couldn't.
> 
> When I pressed the Power key, I got the "Press [*] to unlock" message.  No
> matter how many times I pressed the D-pad center key, the N800 ignored it.  The
> only solution I found was to pull the battery.

I've experienced the same ignoring of the D-pad center key on my manually
locked N800, though not when running Canola. I do have Canola installed, but I
don't use it.
Comment 4 Marius Gedminas (reporter) 2007-08-13 23:16:32 UTC
As far as I know, this is fixed in the latest firmware release
(2007SE_4.2007.26-8).  It was even mentioned in the release notes.  I guess
someone forgot to mark this bug as resolved.
Comment 5 Stephen Gadsby maemo.org 2007-08-16 20:05:23 UTC
(In reply to comment #4)
> As far as I know, this is fixed in the latest firmware release
> (2007SE_4.2007.26-8).  It was even mentioned in the release notes.  I guess
> someone forgot to mark this bug as resolved.

I do not know if it's been noted as fixed in the release notes for 26-8. I do
know that I'm running that release, and at this very moment this bug is biting
my N800. Pressing the power button will wake the display and show the "Now
press [*]" message. However, my N800 will not respond to the D-pad's center
key.

My N800 was locked manually, and Canola is installed but not running. The only
thing running is the RSS Feed Reader, and it's not in full-screen mode. I've
never enabled soft poweroff or edited systemui.xml in any way.
Comment 6 Charlie Brady 2007-09-27 02:34:30 UTC
(In reply to comment #0)
> This happened to me twice: I had Canola running in full-screen mode, I locked
> the keyboard and keys, and later when I tried to unlock it, I couldn't.

I have a similar, but different problem. If I press the power key, I get "Now
press [*]" and if I press that, I get "Press the following keys one after the
other: (|) and [*]" and if I press those, I get "Now press [*}", ad infinitum.

FM radio application is running and radio is playing (and I'd really like to
turn it off!).
Comment 7 Charlie Brady 2007-09-27 02:39:05 UTC
(In reply to comment #6)
> (In reply to comment #0)
> > This happened to me twice: I had Canola running in full-screen mode, I locked
> > the keyboard and keys, and later when I tried to unlock it, I couldn't.
> 
> I have a similar, but different problem. If I press the power key, I get "Now
> press [*]" and if I press that, I get "Press the following keys one after the
> other: (|) and [*]" and if I press those, I get "Now press [*}", ad infinitum.

By bad - I was tapping the "Now press [*]", not pressing the button. Duh!
Comment 8 Gene Cash 2007-09-30 23:45:49 UTC
I just installed 2007SE_4.2007.26-8 yesterday, and I'm bitten by this. I've
also installed Python 2.5, osso-xterm, openssh, edited gainroot, changed the
root password, installed the usbnet module, and moved some Opera bookmarks
around, Other than that, it's a fresh install.

I don't even get "Press [box] to unlock" when I press the power key, no matter
how I tap it or hold it down.

However the "menu" key still works, and when I bring up a menu I can use the
top pad on it. When the screen goes dim, I can tap the touchscreen to make it
bright again, but otherwise the touchscreen is ignored.

This was the first time I locked the unit since the upgrade.

I can ssh in over the USB connection, so I'm trying to figure out how to unlock
it in a friendlier manner than saying "poweroff"
Comment 9 Gene Cash 2007-10-01 00:10:55 UTC
FYI, running /etc/osso-af-init/get-devlock.sh reports "unlocked", - does this
mean the device thinks it's unlocked?
Comment 10 Stephen Gadsby maemo.org 2007-11-27 18:40:16 UTC
For me at least, this bug is appearing much more frequently in the N800 public
beta of OS2008 than it ever did in OS2007. In fact, it seems I'm more likely to
find the D-pad center button unresponsive during an attempted device unlock
than I am to find a responsive D-pad center button and get a successful unlock.

I have found a workaround though. When I attempt to unlock my N800 and find the
D-pad center button unresponsive, if I wait for the N800's display to time out
and go dark before re-attempting the unlock, then that second attempt will
usually succeed.
Comment 11 Neil MacLeod maemo.org 2007-11-27 18:48:28 UTC
Also see bug 2311 which is a more general case of this problem, and it seems to
be worse in OS2008 than any previous OS version.
Comment 12 Eero Tamminen nokia 2007-12-07 16:23:42 UTC
Comment 8 and 9 seem a different bug.  I think some application (popup?)
might be grabbing the device input and not releasing it properly.
Comment 13 Philippe De Swert nokia 2008-03-10 13:12:11 UTC
(In reply to comment #12)
> Comment 8 and 9 seem a different bug.  I think some application (popup?)
> might be grabbing the device input and not releasing it properly.
> 

Does this still occur? Due to a kernel bug the HW keys would sometimes stay
disabled. This has been fixed now. See bug #2311 for details and fix info.
Comment 14 Stephen Gadsby maemo.org 2008-04-13 15:18:25 UTC
I've not seen this bug since I upgraded to 2.2007.50-2 several months ago.