Bug 10885 - (MrAL) Cannot Connect to WPA2 (Linksys WRT54G2 Wireless Router)
(MrAL)
: Cannot Connect to WPA2 (Linksys WRT54G2 Wireless Router)
Status: RESOLVED INVALID
Product: Connectivity
WiFi
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-07-07 13:03 UTC by aldinlapinig
Modified: 2010-09-27 13:38 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description aldinlapinig (reporter) 2010-07-07 13:03:22 UTC
SOFTWARE VERSION:
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
1. I tried to connect to my linksys wrt54g2 wireless router using Wi-Fi
Protected Setup.
2. I tried both the Pin Method and pressing Done after pressing the access
button in my router.
3. I tried the other way around by creating new internet connection in the
phone settings, and making the right configuration like setting WPA2-Personal
and entering the shared key.

EXPECTED OUTCOME:
N900 should connect to the internet through linksys wrt54g2 wireless router.

ACTUAL OUTCOME:
Network connection error.         YES
Try again?                        NO

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
I can only encounter this problem with my linksys wrt54g2 with my N900... other
devices like desktop PC, laptops (win and mac), netbook (xp), and PSP can
connect without problems.

Also, my N900 can connect without a problem with the wireless routers I have in
my office (both BUFFALO and AZTECH routers). 


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6)
Gecko/20100625 Firefox/3.6.6
Comment 1 Andre Klapper maemo.org 2010-07-09 14:29:02 UTC
What Firmware version does the router have? Is it the latest?
Does setting Power Saving to "Off" help? (Settings > Internet Connections >
Connections > Edit > Next > Next > Next > Advanced > Other > Power saving) 

If you are able to reproduce this, can you please provide a syslog (see
http://wiki.maemo.org/Documentation/devtools/maemo5/syslog and
http://wiki.maemo.org/Documentation/devtools/maemo5#Installation for more
information) and then enable the wlancond debugging with the two commands
 gconftool-2 --set --type int
'/system/osso/connectivity/IAP/wlancond_debug_level' '2'
 killall wlancond
and after this if you are able to reproduce this attach the /var/log/syslog
file
from the device here.
If you are not used to Linux, after creating the syslog file you can copy the
syslog file to those folders that are visible in the Maemo File Manager by:
  * Starting X Terminal
  * cp /var/log/syslog /home/user/MyDocs/.documents/
After that you can find the file in the Maemo File Manager by going to Nokia
N900 > Documents.
Comment 2 Andre Klapper maemo.org 2010-09-27 13:38:10 UTC
Unfortunately, without more information, as requested in one of the last
comments, we are unable to do anything more about this report. Until more
information is available, I'm resolving the report as INVALID.
Please feel free to reopen this bug if you can provide the information asked
for, or if you can still reproduce this.