Bug 10870 - Open source libsms and libsms-utils
: Open source libsms and libsms-utils
Status: RESOLVED WONTFIX
Product: Licensing Change Requests
General
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified normal with 10 votes (vote)
: ---
Assigned To: Quim Gil
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2010-07-05 23:49 UTC by Graham Cobb
Modified: 2011-03-01 13:57 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Graham Cobb (reporter) maemo.org 2010-07-05 23:49:27 UTC
What component(s) or source packages/etc is the licensing change request about? 

libsms, libsms-utils

What component area is the component in if you know? (See the openness reports
at
http://mer-project.blogspot.com/2010/02/mapping-openness-of-maemo-50-pr11-and.html)

Telephony/Cellular services

What is the current licensing of the component?

L6: Package published under EULA in nokia-binaries

What licensing would you like it to be and why? Examples can be:
open source and openly developed (move to gitorious), open source (select a
license), non-free but redistributable, non-free, published in nokia-binaries,
document the functionality, etc.

At least -dev packages (header files and linkable objects) published and API
documented.  Preferably open source and openly developed (move to gitorious).

What project(s) would have benefit from this licensing change request?

Apps to send/receive SMS. 
notmynokia.

What technical purpose do you/your project(s) have for wanting the licensing
change?

Libraries provides useful tools for creating, reading and converting SMS
messages including special messages, segmentation and headers and managing
/var/spool/sms/.

notmynokia needs to be able to manipulate the SMS spool.
Comment 1 Quim Gil nokia 2010-08-10 21:35:53 UTC
Resolving as WONTFIX.

The Maemo 5 libraries will not be touched at this point unless there are severe
issues around them. All the new open development related with SMS is
concentrating on the MeeGo OS. The SMS functionality is handled entirely with
open source components. See
http://meego.com/developers/meego-architecture/comms-services for more details.
Comment 2 Graham Cobb (reporter) maemo.org 2010-08-17 02:16:39 UTC
Isn't that actually a reason to open source them now?  If they are open source,
the community can fix bugs and add enhancements now that Nokia no longer wishes
to do so. They now have no value as IP to Nokia and would be valuable to the
community.

Unless there are some modules which are not owned by Nokia, in which case I can
understand an unwillingness to go to the effort to put in place agreements to
open source them, it seems like this is the right time to open source them.

If the problem is that there are modules not owned by Nokia, can you open
source at least the header files and provide the -dev package?  That would
allow the community to, if they felt it important enough, work out how to use
the APIs even without documentation.
Comment 3 Quim Gil nokia 2010-08-17 02:19:48 UTC
I'll ask.
Comment 4 Quim Gil nokia 2010-08-18 19:25:21 UTC
I sent an email to the maintainers asking about the current situation of these
packages and about any discussion ref opening them. Will report here once I get
new information.
Comment 5 Quim Gil nokia 2010-08-20 02:56:58 UTC
I got first answers and I asked new questions. In the meantime I learned some
things.

The recommended way for app developers to handle SMS is through QMessage, part
of the Qt Mobility API http://doc.trolltech.com/qtmobility-1.0/qmessage.html .
If you are missing a feature in that open source library you are encouraged to
file a request or propose a patch.

See also
http://blogs.forum.nokia.com/blog/kate-alholas-forum-nokia-blog/2010/02/14/easy-to-use-sms-and-messaging-api-to-maemo-5

libsms and libsms-utils will be replaced at some point by the corresponding
functionality of oFono. The code currently exists and you are invited to follow
and get involved in the development. See sms and smsutil at
http://git.kernel.org/?p=network/ofono/ofono.git;a=tree;f=src;h=b12bd14b2635937f4c6c2c057eaee10d041052a5;hb=HEAD

In the meantime, it looks that some related functionality plans to be provided
by open source components in MeeGo-Harmattan, where oFono is not implemented
yet. I have asked more information about this.

About bugfixing Maemo 5, are there any bugs related to these libraries that are
not being addressed? Relevant enough to go ahead with the work of opening these
components.
Comment 6 Quim Gil nokia 2010-08-20 21:26:57 UTC
More:

In Fremantle the SMS control binds to and uses the ISI protocol. The ISI API
and protocol is open and available at in http://wirelessmodemapi.com

If we change the Nokia license of the code to (L)GPL, then SMS drags the modem
control protocol out as well. Otherwise any opening requires more work in the
Cellular stack for no clear benefit.

On the other side, the protocol, messege headers and usage is opened above the
oFono modem plugin. oFono has the isi-modem plugin development started,
although is not fully there yet: 
http://git.kernel.org/?p=network/ofono/ofono.git;a=tree;f=drivers/isimodem;h=56066a2f14df7983b485c32268a7b9ed1aaa843a;hb=HEAD

Conclusion: we see no benefit introducing changes in the Circuit Switched Data
for Fremantle. The proper work is being done in the oFono project and the
benefit is to contribute full blown SMS support into oFono core for everybody's
benefit.

Resolving as WONTFIX, then.
Comment 7 Joerg Reisenweber 2011-01-21 14:15:08 UTC
(In reply to comment #1)
> Resolving as WONTFIX.
> 
> The Maemo 5 libraries will not be touched at this point unless there are severe
> issues around them. 

There are severe issues: 8347

> All the new open development related with SMS is
> concentrating on the MeeGo OS. The SMS functionality is handled entirely with
> open source components.

This is about getting missing bits fixed in *maemo*. See
https://bugs.maemo.org/8347 
I'd say it's not asking for too much to have Nokia share a bit of
documentation, header files, and help, if not entirely opening up source of
these libs and daemons, to get such a basic feature like SMS-CB working in
maemo. 
The community once more is willing to fix elementary things that Nokia missed
to implement/support, and it's just politically correct if Nokia helps on that
effort.
I'm requesting to reopen this ticket.
Comment 8 Jonathan Wilson 2011-03-01 13:57:29 UTC
BTW, the existence of ofono and its code should mean that the "we cant release
bits of telephony stack because it exposes details of how to talk to the modem
at low level" argument made in the past is less valid now.