Bug 10864 - (int187710/int-194002) call log missing non-cellular call options for numbers without contacts
(int187710/int-194002)
: call log missing non-cellular call options for numbers without contacts
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified minor (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-07-05 09:46 UTC by Jack Tanner
Modified: 2010-10-04 15:04 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jack Tanner (reporter) 2010-07-05 09:46:00 UTC
SOFTWARE VERSION:
(Settings > General > About product)
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Use the dial pad to dial a number that doesn't belong to any contact. 
2. Call via any method (e.g., cellular, Google Talk)
3. Talk, hang up.
4. Open the call log and try to call the same number using a non-cellular
calling method (e.g., Google Talk)

EXPECTED OUTCOME:
Have an option to change calling methods.

ACTUAL OUTCOME:
Only cellular option is available.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
The One Ring for Google Talk

OTHER COMMENTS:
This is not a duplicate of bug 8159. In that bug, the call log contains actual
contacts, not "contactless" numbers. With a contact, one can click on the call
log entry and then on the avatar to switch calling methods. With a contactless
number, there's no avatar, and no way to switch calling methods.
Comment 1 Jack Tanner (reporter) 2010-07-05 09:48:14 UTC
Just to clarify, this report is not about *switching* calling methods vs.
what's in the call log for a contactless number. (Although it would be nice to
be able to switch.) This is about not even being able to reuse the prior
calling method if the prior calling method was non-cellular.
Comment 2 Andre Klapper maemo.org 2010-07-22 15:41:16 UTC
Confirming. A workaround could be to create a contact, but that takes a while.

Any proposal on how to fix this in the User Interface (though it's probably a
WONTFIX for Maemo5 anyway)?
Comment 3 Jack Tanner (reporter) 2010-07-22 19:20:57 UTC
One mildly hackish solution is for the Phone app to create a temporary fake
contact. That is, picking up from step 3 in the bug report, it could work like
this:

4. Open the call log and pick the same number.
5. Phone app creates a temporary fake contact ("TFC") that doesn't belong to
any existing address book. (It may also need a temporary fake address book.)
The TFC gets a default avatar, and it also gets all the available calling
methods (cellular, SMS, plus all configured VOIP methods). Whatever calling
method was used previously is given to the contact by default; tapping the
avatar brings up the menu of other calling methods. This is exactly the same UI
that's used for real contacts.
6. After the call is dialed, the TFC (and temporary address book) is deleted.

Presumably the TFC gets some kind of UID (hash of phone number, calling method
and timestamp?) in step 5 so that it's easy to delete in step 6.

If there's no way to capture the event that the call is completed and it's time
to delete the TFC, step 6 could be replaced by a cron job that deletes all
contacts in the special TFC address book.
Comment 4 Andre Klapper maemo.org 2010-09-22 21:16:47 UTC
WONTFIX for Maemo5 according to Nokia, keeping this open to address it in the
version after Maemo5.
Comment 5 Andre Klapper maemo.org 2010-10-04 15:04:09 UTC
In Harmattan (the software version after Maemo5) all the commands are available
for unsaved numbers as well, hence closing as FIXED for Harmattan.