Bug 10829 - (libsdl-mixer1.2) upgrade libsdl-mixer1.2 to version 1.2.8
(libsdl-mixer1.2)
: upgrade libsdl-mixer1.2 to version 1.2.8
Status: RESOLVED FIXED
Product: System software
general
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified enhancement (vote)
: Harmattan
Assigned To: unassigned
: system-software-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-06-30 12:00 UTC by Daniel Spies
Modified: 2010-10-26 19:34 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Daniel Spies (reporter) 2010-06-30 12:00:34 UTC
SOFTWARE VERSION: 5.0:(10.2010.19-1)

EXACT STEPS LEADING TO PROBLEM: 
1. Open X Terminal
2. Type "dpkg-query --show libsdl-mixer1.2"
3. See it printing "libsdl-mixer1.2 1:1.2.6-5+0m5"

EXPECTED OUTCOME:
See it printing a version >= 1.2.8

ACTUAL OUTCOME:
It is version 1.2.6 from year 2004 (?)

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Lots of...

OTHER COMMENTS:
libsdl-mixer1.2 version 1.2.6 is from 2004 iirc (it's so old it's not
documented any more). This is old and most of the software available these days
depends on libsdl-mixer >= 1.2.8. Also, most of the software available wouldn't
probably have a problem with the version of libsdl-mixer being upgraded. Please
consider upgrading the package to 1.2.8 or higher.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-06-30 13:14:50 UTC
This will not happen for Maemo5 as this requires retesting lots of stuff - too
late in this development cycle.

However, http://repo.meego.com/MeeGo/builds/trunk/daily/core/repos/source/
lists SDL_mixer-1.2.11-11.5.src.rpm so this will be FIXED in Harmattan (the
next version after Maemo5 that will be based on MeeGo). WONTFIX for Maemo5.
Comment 2 Daniel Spies (reporter) 2010-07-01 13:00:13 UTC
I semi-fixed this myself with renaming the package to libsdl-mixer1.2.8 and
libsdl-mixer1.2.8-dev (http://maemo.org/packages/view/libsdl-mixer1.2.8/
http://maemo.org/packages/view/libsdl-mixer1.2.8-dev/)
Comment 3 Iker 2010-10-26 19:34:06 UTC
I think that my problem could be related to this bug. I'm getting the following
warning in the application manager log (PR1.3):
apt-worker: Ignoring version from wrong domain: libsdl-mixer1.2
1:1.2.6-5+0m5+ogg+mp3
apt-worker:
/var/lib/apt/lists/repository.maemo.org_extras_dists_fremantle-1.3_free_binary-armel_Packages
Do you know how to fix it?

Thanks.