Bug 10817 - Caller ID showing "unknown number" for all incoming calls
: Caller ID showing "unknown number" for all incoming calls
Status: RESOLVED WORKSFORME
Product: Telephony
General
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-06-28 18:46 UTC by Felipe Lerena
Modified: 2010-08-31 17:13 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Felipe Lerena (reporter) 2010-06-28 18:46:13 UTC
SOFTWARE VERSION:
10.2010.19-1.002

EXACT STEPS LEADING TO PROBLEM: 
1. Just call from any phone number from any operator (cell or land).

EXPECTED OUTCOME:
The callers phone number

ACTUAL OUTCOME:
"unknown number"

REPRODUCIBILITY:
always
Comment 1 Felipe Lerena (reporter) 2010-06-28 18:49:48 UTC
Operators:
all the cellphone operators in argentina:
Movistar, Claro, Personal.
all the land operators:
Telefonica, Telecom

My operator is Claro
Comment 2 Andre Klapper maemo.org 2010-06-28 19:00:02 UTC
So you call the N900 from a landline phone...

Why are you sure that the number from the landline phone is actually sent? Did
you try with other phones whether it is displayed?
How many digits does the landline number have (without the country prefix)?
Comment 3 Felipe Lerena (reporter) 2010-06-28 19:19:47 UTC
Yes, It is sending the caller ID
It's sending 10 numbers in this format "1112345678"
"11" being the area code and "12345678" being the line number
Comment 4 Andre Klapper maemo.org 2010-06-28 19:24:44 UTC
(In reply to comment #3)
> Yes, It is sending the caller ID

My question actually was "Why do you know". See comment 2.
Comment 5 Felipe Lerena (reporter) 2010-06-28 19:31:02 UTC
I know it because I connect my SIM card to the phone I used every day until I
got the n900. And I can assure you it's sending the Id.
It's for all the phone numbers, not only for my land line.
Comment 6 Andre Klapper maemo.org 2010-06-29 17:53:48 UTC
When you call from landline to the N900, is the number afterwards shown in the
"Recent Calls" list in the N900 "Phone" application, or does it say "Unknown
number"?
In case it is shown, can you call back?

Also it would help to have a syslog with a debugging variable added to the
environment, for example by adding the line below to the file
/etc/osso-af-init/af-defines.sh (you have to be root to do this, see
http://wiki.maemo.org/Root_access ) before creating the syslog:

export RING_DEBUG=all

For information how to provide a syslog please see
http://wiki.maemo.org/Documentation/devtools/maemo5/syslog and
http://wiki.maemo.org/Documentation/devtools/maemo5#Installation for more
information.
If you are not used to Linux, after creating the syslog file you can copy the
syslog file to those folders that are visible in the Maemo File Manager by:
  * Starting X Terminal
  * cp /var/log/syslog /home/user/MyDocs/.documents/
After that you can find the file in the Maemo File Manager by going to Nokia
N900 > Documents.
Comment 7 Andre Klapper maemo.org 2010-08-31 16:16:54 UTC
Can you answer comment 6?
Comment 8 Felipe Lerena (reporter) 2010-08-31 17:02:34 UTC
Andre, It was not working until I flashed the device for other purpose. It is
not happening anymore.
Comment 9 Andre Klapper maemo.org 2010-08-31 17:13:23 UTC
Ah, okay... Thanks for the feedback.