Bug 10756 - (int-176574) lsb_release -a says Debian, not Maemo
(int-176574)
: lsb_release -a says Debian, not Maemo
Status: NEW
Product: Core
general
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified normal (vote)
: 5.0+
Assigned To: unassigned
: core-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-06-23 13:10 UTC by Neal H. Walfield
Modified: 2010-08-02 16:57 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neal H. Walfield (reporter) 2010-06-23 13:10:30 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Run lsb-release -a

EXPECTED OUTCOME:

Output says Maemo.  (Ubuntu, for instance, modified this to say Ubuntu.)

ACTUAL OUTCOME:

Output says Debian, specifially:

[sbox-FREMANTLE_ARMEL: ~] > lsb_release -a
LSB Version:   
core-2.0-arm:core-2.0-noarch:core-3.0-arm:core-3.0-noarch:core-3.1-arm:core-3.1-noarch:core-3.2-arm:core-3.2-noarch
Distributor ID:    Debian
Description:    Debian GNU/Linux testing/unstable
Release:    testing/unstable
Codename:    n/a



REPRODUCIBILITY:

always

EXTRA SOFTWARE INSTALLED:

lsb-release 3.2-15osso2

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9)
Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Comment 1 Neal H. Walfield (reporter) 2010-06-23 13:13:01 UTC
Similar output is displayed when running the lsb_release (version 3.2-15osso2)
on the device:

Nokia-N900-42-11:~# lsb_release -a

No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux testing/unstable
Release:    testing/unstable
Codename:    n/a
Comment 2 Andre Klapper maemo.org 2010-06-23 13:16:47 UTC
Thanks for the report!
Confirming.

STEPS on device:
1. sudo gainroot
2. apt-get install lsb-release
3. lsb_release -a