Bug 10740 - Wrong voice number shown in call log after calling a contact via SIP
: Wrong voice number shown in call log after calling a contact via SIP
Status: RESOLVED DUPLICATE of bug 8159
Product: Chat & Call & SMS
Call Application UI
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified minor (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-06-21 14:18 UTC by phd
Modified: 2010-06-29 16:35 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description phd (reporter) 2010-06-21 14:18:37 UTC
SOFTWARE VERSION:
(Settings > General > About product)
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Create a contact with both voice number(s) and SIP address(es).
2. Call the contact via SIP.
3. Look at the contact in the recent calls list (call log); it correctly shows
the contact has been called via SIP; but tap on the contact to call it again -
it only shows voice number(s), not SIP address(es).

EXPECTED OUTCOME:

After tapping the contact in the call log I expect to see the called SIP
address or at least the full contact's card (all its voice numbers, SIP/Skype
addresses, etc.) with the called SIP address at the top.

ACTUAL OUTCOME:

Only voice numbers from the contact's card. (If the contact only has SIP
addresses but not voice numbers - the correct SIP address is shown which is ok.
If the contact has also a Skype address and has been called via Skype - the
correct Skype address is shown after tapping on the contact. The problem is
manifested only when calling a contact that has both voice numbers and SIP (and
perhaps Skype) and has been via a SIP call.)

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

Always.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

I set severity "minor" for the ticket because the problem is not that big.
There is a workaround: after tapping the contact I can tap its avatar, see the
entire card and select the SIP address to call. But still it's a problem worth
fixing.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3
Comment 1 Saturn 2010-06-26 13:37:17 UTC
Seems like duplicate of
https://bugs.maemo.org/show_bug.cgi?id=8159
Comment 2 Andre Klapper maemo.org 2010-06-29 16:35:01 UTC
True. Thanks :)

*** This bug has been marked as a duplicate of bug 8159 ***