Bug 1069 - (int-55922) Touchpad loss of pressure sensitivity?
(int-55922)
: Touchpad loss of pressure sensitivity?
Status: RESOLVED FIXED
Product: Core
X Server
: unspecified
: All All
: Medium major with 8 votes (vote)
: ---
Assigned To: Maemo QA (deprecated)
: Maemo QA (deprecated)
: http://www.internettablettalk.com/for...
:
:
:
  Show dependency tree
 
Reported: 2007-02-18 03:21 UTC by Neil MacLeod
Modified: 2008-12-06 16:04 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neil MacLeod (reporter) maemo.org 2007-02-18 03:21:24 UTC
Please read this forum post:
http://www.internettablettalk.com/forums/showthread.php?t=4690

I've checked my N800 using maemopad+ and I too have a loss of pressure
sensitivity, in my case in the area usually occupied by the right hand vertical
scrollbar. This maemopad+ behaviour would appear to be confirmed in other
application as I am sometimes unable to scroll pages vertically when dragging
the scrollbar thumb - I usually have to attempt two or three drags before the
scrollbar responds and moves the page (there is no "click" on the first failed
attempts, suggesting the stylus is not registered by the touchscreen).

Is the uneven touchpad behaviour a hardware or software/firmware problem? If it
is a hardware issue, will it be resolved under a warranty return?
Comment 1 Harm 2007-02-18 11:15:32 UTC
Same here; vertical scrollbar area. Where the to and bottom area are slightly 
more sensitive.
Comment 2 Neil MacLeod (reporter) maemo.org 2007-03-24 14:28:40 UTC
With firmware 3.2007.10-7 I still have a loss of touchscreen pressure
sensitivity in the vertical scrollbar region - the updated firmware has not made
any obvious improvement.
Comment 3 Jussi Kukkonen 2007-05-07 08:07:13 UTC
(In reply to comment #0)
> Is the uneven touchpad behaviour a hardware or software/firmware problem? If 
> it is a hardware issue, will it be resolved under a warranty return?

Fyi: it is a HW issue and the screen does get replaced under warranty, at least 
this was my 
experience (in Helsinki).
Comment 4 Neil MacLeod (reporter) maemo.org 2007-05-07 08:20:01 UTC
I should have updated this bug sooner.

Yes, it is a hardware issue and a warranty repair (replacement of the LCD
display) will resolve the issue - I'm in the UK.

I received my unit back from repair in mid April after 5 weeks, and the
sensitivity issue is completely fixed although I now have an unusual problem
where the touchpad calibration is slightly mis-aligned in the bottom left
corner of the screen. Stylus clicks are being registered however the stylus
position is being detected about 8-10 pixels higher than where I am actually
clicking on the screeen. No amount of re-calibration will resolve the issue.
C'est la vie!

I suppose this bug should be closed? Could be marked as INVALID since it's not
a software/firmware problem.
Comment 5 Jake Kunnari 2007-07-06 13:22:43 UTC
Fixed in latest IT OS 2007.
Comment 6 Neil MacLeod (reporter) maemo.org 2007-07-06 16:53:39 UTC
Thanks for fixing the problem, but a plea to Nokia concerning future "hardware"
faults:

Quite a few users shipped their devices back to Nokia for warranty repairs to
fix this problem which now turns out to be resolved by software.

Nokia could have avoided all of those warranty repairs and avoided causing
their owners this aggravation by posting a single, solitary, note in this bug
report confirming this to be a software issue and advising us to wait for the
next firmware release. It wouldn't have taken much to do this.
Comment 7 Quim Gil nokia 2007-07-09 08:16:57 UTC
Just to clarify things: from the warranty repairs it was found out that some
devices had real hardware problems while others had a problem elsewhere.
Further research was done, followed by the development of the software
improvements that have been implemented in the last release.

Like its customers, Nokia is also interested avoiding unnecessary warranty
repairs. Until releasing the touchscreen improvements users/Nokia could not
figure out what device was affected by a hardware problem or not. We could not
tell to users to wait until the next release to find out themselves, not even
providing a date for the next release (which we could not provide). And this is
how the story evolved.

We hope that after this release touchscreen related issues will drop
significantlyn and this will stop being an issue. People sending back their
devices have helped fixing this issue in a way that would have been almost
impossible for ourselves alone.