Bug 10674 - (int-187144) Settings > My Nokia crashes the Settings Application
(int-187144)
: Settings > My Nokia crashes the Settings Application
Status: RESOLVED FIXED
Product: Settings and Maintenance
Control panel
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified major (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: control-panel-bugs
:
: crash
:
:
  Show dependency tree
 
Reported: 2010-06-14 23:46 UTC by Mahmoud Kassem
Modified: 2010-10-25 17:12 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mahmoud Kassem (reporter) 2010-06-14 23:46:33 UTC
SOFTWARE VERSION: 10.2010.19-1.003

EXACT STEPS LEADING TO PROBLEM: 
1. Settings > My Nokia

EXPECTED OUTCOME:
Open My Nokia app

ACTUAL OUTCOME:
internal error. Application "Settings" closed

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
syslog:
Jun 14 23:40:42 Nokia-N900-42-11 syslogd 1.5.0#5maemo7+0m5: restart.
Jun 14 23:40:49 Nokia-N900-42-11 maemo-launcher[2967]: invoking
'/usr/bin/controlpanel.launch' 
Jun 14 23:40:49 Nokia-N900-42-11 maemo-launcher[2967]: opening of
/usr/bin/controlpanel.launch took 7507 usec 
Jun 14 23:40:50 Nokia-N900-42-11 fmtxd[2969]: GLIB WARNING ** default - No
marshaller for signature of signal 'Condition'
Jun 14 23:40:53 Nokia-N900-42-11 maemo-launcher[972]: child (pid=2967)
terminated due to signal=11 
Jun 14 23:40:53 Nokia-N900-42-11 maemo-launcher[972]: no child 2970 found in
the kindergarten. 
Jun 14 23:40:53 Nokia-N900-42-11 maemo-launcher[972]: child (pid=2970)
terminated due to exit()=0 
Jun 14 23:40:59 Nokia-N900-42-11 exiting on signal 15
Comment 1 Andre Klapper maemo.org 2010-06-15 00:41:31 UTC
Hi,
can you please install Crash Reporter from the SDK Tools repository in order to
send coredumps directly to Nokia?
See http://wiki.maemo.org/Extras-testing#Tools_for_testers for a how-to.
If you are offered to add a comment for sending the coredump file, please
mention this bug number (like "see bugs.maemo.org bug number xxxx").
Also, a filename will be displayed after uploading the coredump. Please add the
name of that file here in the bug report.
Comment 2 George Stephanos 2010-08-21 04:29:15 UTC
Tested & Confirmed.
Comment 3 Andre Klapper maemo.org 2010-08-21 13:19:52 UTC
...but still need a crash reporter ID.
Comment 4 George Stephanos 2010-08-21 14:01:37 UTC
(In reply to comment #3)
> ...but still need a crash reporter ID.
> 

It's controlpanel-0830-11-1544.rcore.lzo.
Comment 5 Andre Klapper maemo.org 2010-08-23 16:14:01 UTC
(In reply to comment #0)
> REPRODUCIBILITY:
> (always, less than 1/10, 5/10, 9/10)

Missing...
Comment 6 George Stephanos 2010-08-23 17:56:10 UTC
Strange. I'm sure I uploaded it. Anyway, here's another one:
controlpanel-0830-11-29239.rcore.lzo
Comment 7 Alban Crequy 2010-08-24 14:25:23 UTC
Do you have a SIM card in your phone?
- If so, what is the country of your SIM card?
- If not, is the control panel crash also reproducible with a SIM card?

What country did you configure in the regional settings?
Comment 8 George Stephanos 2010-08-24 16:13:38 UTC
(In reply to comment #7)
> Do you have a SIM card in your phone?
> - If so, what is the country of your SIM card?
> - If not, is the control panel crash also reproducible with a SIM card?
> 
> What country did you configure in the regional settings?
> 


I do have a SIM card. I'm from Egypt. I used to have Egypt in my Regional
Settings but since I didn't want Arabic numbers to show up in each app, I set
it to the US.
Is that the problem ?
Comment 9 Mahmoud Kassem (reporter) 2010-08-24 23:37:06 UTC
Egypt too, regional settings Egypt and device language English (UK).
Comment 10 Andre Klapper maemo.org 2010-08-31 13:24:43 UTC
This has been fixed in package
cherry 0.25-1+0m5
which is part of the internal build version
2010.35-1
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 11 Andre Klapper maemo.org 2010-10-25 17:12:03 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.