Bug 10667 - "list.remove(x): x not in list" error prevents any sync
: "list.remove(x): x not in list" error prevents any sync
Status: RESOLVED FIXED
Product: Hermes
General
: unspecified
: N900 Maemo
: High blocker with 1 vote (vote)
: ---
Assigned To: Andrew Flegg
: general
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-06-13 20:02 UTC by Dawid Lorenz
Modified: 2010-07-03 12:17 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot of the error message (122.49 KB, image/png)
2010-06-13 20:04 UTC, Dawid Lorenz
Details
Output of running Hermes in cli (72.55 KB, application/octet-stream)
2010-06-14 02:08 UTC, Dawid Lorenz
Details
Log + screenshot of Python error message in Terminal (64.55 KB, application/x-gzip)
2010-06-28 16:56 UTC, Dawid Lorenz
Details
Log created in response to comment #10 (7.24 KB, application/x-gzip)
2010-06-29 01:59 UTC, Dawid Lorenz
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Dawid Lorenz (reporter) 2010-06-13 20:02:46 UTC
SOFTWARE VERSION:
0.8.2

EXACT STEPS LEADING TO PROBLEM: 
1. Start Hermes.
2. Start "Refresh" or "Retrieve" action.
3. Wait.

EXPECTED OUTCOME:
Sync finishes correctly.

ACTUAL OUTCOME:
Sync process quits while "Processing contacts..." with following error message:
"Something went wrong: list.remove(x): x not in list"

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
All account options (Facebook, LinkedIn, Twitter and Gravatar) are enabled and
authorised.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.3)
Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3
Comment 1 Dawid Lorenz (reporter) 2010-06-13 20:04:59 UTC
Created an attachment (id=2873) [details]
Screenshot of the error message
Comment 2 Andrew Flegg maemo.org 2010-06-13 20:13:45 UTC
See also:
  http://talk.maemo.org/showpost.php?p=713076&postcount=207
  http://talk.maemo.org/showpost.php?p=713240&postcount=210

----------

This can probably be worked around by disabling Twitter. It isn't always seen,
so more detail is needed to narrow down the problem.

Can you:

1. Open X Terminal
2. Run /opt/hermes/bin/hermes >MyDocs/hermes.log.txt
3. Attach the hermes.log.txt. It will be exposed over USB mass storage, or will
appear in the root of your N900 in a standard Maemo file selector.

I suspect it's related to Twitter network problems.

Also, what's your Twitter username? How many people do you follow?
Comment 3 Dawid Lorenz (reporter) 2010-06-14 02:07:00 UTC
(In reply to comment #2)
> This can probably be worked around by disabling Twitter. It isn't always seen,
> so more detail is needed to narrow down the problem.

Indeed, disabling Twitter account has "solved" the problem.

> Can you:
> 
> 1. Open X Terminal
> 2. Run /opt/hermes/bin/hermes >MyDocs/hermes.log.txt
> 3. Attach the hermes.log.txt. It will be exposed over USB mass storage, or will
> appear in the root of your N900 in a standard Maemo file selector.

Will do.

> I suspect it's related to Twitter network problems.
> 
> Also, what's your Twitter username? How many people do you follow?

@adlorenz, followi 62 people.
Comment 4 Dawid Lorenz (reporter) 2010-06-14 02:08:09 UTC
Created an attachment (id=2876) [details]
Output of running Hermes in cli
Comment 5 Andrew Flegg maemo.org 2010-06-24 12:38:04 UTC
(In reply to comment #4)
> Created an attachment (id=2876) [details] [details]
> Output of running Hermes in cli

Did the error occur when you ran Hermes this time? The log doesn't seem to
contain any indication of an error, which is worrying.
Comment 6 Dawid Lorenz (reporter) 2010-06-28 16:55:37 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Created an attachment (id=2876) [details] [details] [details]
> > Output of running Hermes in cli
> 
> Did the error occur when you ran Hermes this time?

Yes, it did, but apparently outside the log. I've re-ran the test (with Twitter
account enabled back), will attach a log AND screenshot of error in a minute.
Comment 7 Dawid Lorenz (reporter) 2010-06-28 16:56:19 UTC
Created an attachment (id=2944) [details]
Log + screenshot of Python error message in Terminal
Comment 8 Andrew Flegg maemo.org 2010-06-28 16:58:34 UTC
(In reply to comment #7)
> Created an attachment (id=2944) [details] [details]
> Log + screenshot of Python error message in Terminal

Thanks, for my future reference: I should've asked you to run:

/opt/hermes/bin/hermes >MyDocs/hermes.log.txt 2>&1

Not sure how I forgot that.
Comment 9 Andrew Flegg maemo.org 2010-06-28 22:16:01 UTC
*** Bug 10690 has been marked as a duplicate of this bug. ***
Comment 10 Andrew Flegg maemo.org 2010-06-28 22:46:39 UTC
Could someone experiencing this error do me an enormous favour? (Since I can't
reproduce it)

1) Open X Terminal
2) Run 'sudo gainroot'
3) Run 'wget -O /opt/hermes/lib/org/maemo/hermes/engine/twitter/service.py
http://bleb.org/software/maemo/service.py'
4) Run '/opt/hermes/bin/hermes >MyDocs/hermes.log.txt 2>&1'

I suspect the problem is a double-match; the above "service.py" version avoids
the problem, but may not produce the most optimal result.
Comment 11 Dawid Lorenz (reporter) 2010-06-29 01:59:08 UTC
Created an attachment (id=2947) [details]
Log created in response to comment #10

This time "Refresh" action has completed properly, however application got
stuck with progress bar not progressing for couple of minutes during
"Finalising..." stage.
Comment 12 Andrew Flegg maemo.org 2010-06-29 21:59:50 UTC
(In reply to comment #11)
> 
> This time "Refresh" action has completed properly, however application got
> stuck with progress bar not progressing for couple of minutes during
> "Finalising..." stage.

Did it eventually complete, though? It could've been, with so many changes to
commit that osso-abook was just plain slow!
Comment 13 Andrew Flegg maemo.org 2010-06-29 22:00:39 UTC
I suspect this will be reproducible if the Twitter URL for an individual is
against two separate contact records (or similar forms of duplicates).
Comment 14 Andrew Flegg maemo.org 2010-07-03 11:25:59 UTC
Fixed in 2da81a4b9d0d5ed474173bbe6bcffee76eed6775, this will be released in
0.8.3 this weekend.

https://garage.maemo.org/plugins/ggit/browse.php/?p=hermes;a=commit;h=2da81a4b9d0d5ed474173bbe6bcffee76eed6775
Comment 15 hotzigetty 2010-07-03 12:17:11 UTC
(In reply to comment #14)
> Fixed in 2da81a4b9d0d5ed474173bbe6bcffee76eed6775, this will be released in
> 0.8.3 this weekend.
> 
> https://garage.maemo.org/plugins/ggit/browse.php/?p=hermes;a=commit;h=2da81a4b9d0d5ed474173bbe6bcffee76eed6775
> 

Thanks!!