Bug 10640 - (int175481/int-214590) Going online with Skype after lots of Skype chats on another machine freezes device for minutes
(int175481/int-214590)
: Going online with Skype after lots of Skype chats on another machine freezes ...
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified major (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
: performance, use-time
:
:
  Show dependency tree
 
Reported: 2010-06-10 20:59 UTC by paulaner
Modified: 2011-05-05 17:25 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description paulaner (reporter) 2010-06-10 20:59:31 UTC
SOFTWARE VERSION:
(Settings > General > About product)
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Use Skype on desktop during day (a lot of chats)
2. Go online with n900 (with online status in skype)


EXPECTED OUTCOME:
Device goes online and can be used

ACTUAL OUTCOME:
Devices goes online, starts recieving skype chats and freezes until it recieves
all messages. It almost can't be controlled. This situation can take up to
several minutes.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.55 Safari/533.4
Comment 1 Andre Klapper maemo.org 2010-06-11 00:19:34 UTC
Hi,
how to you go online (WiFi or mobile data connection, and does this make a
difference)?

Which EXTRA SOFTWARE is installed?

Can you check which processes use the CPU, e.g. by running "top" in X Terminal
(you can zoom out to see the complete process name)?
Comment 2 paulaner (reporter) 2010-06-16 09:28:35 UTC
This happens in both cases -- WiFi and GPRS connections and there is no
difference, despite when it happens with GRPS it more annoys because when I go
to online with GPRS i activelly use device, for example I use Maps application.
And when device go online WiFi, usually it means device do it in backrgound.

This is resource:
CPU: 67.5% usr 15.0% sys  0.0% nice  2.3% idle 14.2% io

Here are top programs eating CPU.
 8611  1602 user     R    19936  8.0 19.9 /usr/sbin/browserd -s 8611 -n
RTComMessagingServer 
 8610  1039 user     R    14272  5.7 19.9 /usr/bin/rtcom-messaging-ui           

I will try to get more examples of "top".

I don't have many apps installed. Hope the following list will help.

$ ls /usr/share/applications//hildon/ 
BatteryGraph.desktop                  googlelatitude.desktop               
osso-addressbook.desktop
FBReader.desktop                      hildon-application-manager.desktop   
osso-backup.desktop
as-daemon.desktop                     hildon-control-panel.desktop         
osso-xterm.desktop
birthday.desktop                      image-viewer.desktop                 
osso_calculator.desktop
browser.desktop                       intellisyncd.desktop                 
osso_lmarbles.desktop
calendar.desktop                      keepassx.desktop                     
osso_notes.desktop
camera-ui.desktop                     kernel-power-deinstall.desktop       
osso_pdfviewer.desktop
catorise-browser.desktop              maemo-mapper.desktop                 
osso_rss_feed_reader.desktop
catorise-calendar.desktop             maemo_recorder.desktop               
osso_sketch.desktop
catorise-image-viewer.desktop         maemoblocks.desktop                  
ovi.desktop
catorise-modest.desktop               maemosec_certman_mimehandler.desktop 
phototranslator-alpha.desktop
catorise-osso-addressbook.desktop     mahjong_startup.desktop              
powatool.desktop
catorise-rtcom-call-ui.desktop        mbarcode.desktop                     
qstardict.desktop
catorise-rtcom-messaging-ui.desktop   mediabox-mc.desktop                  
quicknote.desktop
chess_startup.desktop                 mediaplayer-decoders.desktop         
qussd.desktop
cpufrequi.desktop                     mediaplayer-ogg.desktop              
rtcom-call-ui.desktop
dtg.desktop                           mediaplayer.desktop                  
rtcom-messaging-ui.desktop
evince.desktop                        modest.desktop                       
spbbrainevolution.desktop
extcalllog.desktop                    mussorgsky.desktop                   
speedcrunch.desktop
filemanager.desktop                   mycontacts.desktop                   
tutorial-launcher.desktop
flashlight-applet-launcher.desktop    nokia-maps.desktop                   
user-guide.desktop
foreca-weather.desktop                opendune.desktop                     
vertsmsru.desktop
garnet-vm.desktop                     opera.desktop                        
worldclock.desktop
Comment 3 Bartosz Taudul 2010-06-21 14:54:05 UTC
Confirming. Skype hogs the CPU for quite a while after changing status to
online. This happens both on wifi and gsm connections.
Comment 4 Andre Klapper maemo.org 2011-05-05 17:25:40 UTC
Checked two times in internal Harmattan builds (Harmattan is the software
version to be released after Maemo5): "it seems this issue in not reproducible,
I have configured my own account with many chat after long time and UI was
behaving normally, there is some sluggishness but it's mostly because contact
import etc, but not too bad like freeze etc."

Closing as Fixed in Harmattan.
According to Nokia this unfortunately is a WONTFIX for Maemo5.