Bug 10567 - Display stutters after lifting the phone when incoming call arrives with the phone upside down
: Display stutters after lifting the phone when incoming call arrives with the ...
Status: RESOLVED DUPLICATE of bug 10613
Product: Chat & Call & SMS
Call Application UI
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal with 6 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-06-05 10:30 UTC by Harish Koka
Modified: 2010-06-17 15:29 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Harish Koka (reporter) 2010-06-05 10:30:38 UTC
SOFTWARE VERSION:
10.2010.19-1

Sim inserted in N900 and registered to cellular operator.
Phone is Upside down lying on table.

EXACT STEPS LEADING TO PROBLEM:
1. Place and incoming call to the phone.
2. When the phone rings the incoming call, lift the phone(Do not answer) and
check the display.

EXPECTED OUTCOME:
Incoming call UI should be displayed.

ACTUAL OUTCOME:
Display stutters.

REPRODUCIBILITY:
always
Comment 1 Johannes Twittmann 2010-06-08 17:13:59 UTC
Some More Info from http://talk.maemo.org/showthread.php?t=54556


EXACT STEPS LEADING TO PROBLEM:

1. Cover the proximity sensor (the right of the speaker and left of the smaller
camera)
2. recieve a call to the phone
3. then uncover the proximity sensor.

OR

1. put the phone in your pocket (in portrait orientation)
2. recieve a call to the phone
3. take the phone out of your pocket (in portrait orientation) while ringing

ACTUAL OUTCOME

the phone UI flips quickly to landscape then back to portrait. The UI takes a
second to rotate back to portrait. THEN you can answer a call.

WORKAROUND:

1. Go to Phone.
2. Select Phone word.
3. Go to Turning control.
4. Choose from Display orientation -> Landscape.
5. Make sure that Launch by turning is off.
Comment 2 Andre Klapper maemo.org 2010-06-08 20:04:07 UTC
I wonder if this is related to bug 10279 (also see comment 3 there)
Comment 3 Olli Nevalainen 2010-06-11 13:05:05 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Andre Klapper maemo.org 2010-06-14 19:07:03 UTC
Is this the same as bug 10613?
(Also see the video linked from there.)
Comment 5 Andre Klapper maemo.org 2010-06-17 15:29:35 UTC

*** This bug has been marked as a duplicate of bug 10613 ***