Bug 10535 - (int-173498) Incremental search function is broken for "select objects" dialogue in html form elements like drop-down menus or multiple choice element lists
(int-173498)
: Incremental search function is broken for "select objects" dialogue in html f...
Status: RESOLVED DUPLICATE of bug 5526
Product: Browser
User interface
: 5.0:(10.2010.19-1)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: browser-bugs
: https://bugs.maemo.org/query.cgi?form...
:
:
: int-123249
  Show dependency tree
 
Reported: 2010-06-03 19:20 UTC by Uwe Kaminski
Modified: 2010-06-09 15:23 UTC (History)
4 users (show)

See Also:


Attachments
HildonLiveSearch example (4.62 KB, text/plain)
2010-06-03 19:36 UTC, Alberto Garcia Gonzalez
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2010-06-03 19:20:16 UTC
For web form elements like drop-down menus or these boxes where you can choose
one or more entries there is a search field in the top of the "select objects"
dialogue where you can search elements inside of the drop-down menu. Input to
these search field does not work. 

The search field seems to be available only if there are many list elements.

STEPS TO REPRODUCE THE PROBLEM:
1. Open the browser
2. Go to https://bugs.maemo.org/query.cgi?format=advanced
3. Tip into the list called "Product" on the left side. -> a select objects
dialogue including all the list elements comes up to let you choose elements
finger friendly.
4. Select the search field and begin to input the word "calendar"

EXPECTED OUTCOME:
The calendar element is selected.

ACTUAL OUTCOME:
nothing happens. As written in Bug 6099 in further versions of the firmware it
was possible to select objects by using capital letters if the list entries
also use these at the beginning of a word.

REPRODUCIBILITY:
always

This at least happens in multiple choice list elements and drop-down menus.
Comment 1 Alberto Garcia Gonzalez 2010-06-03 19:36:29 UTC
Created an attachment (id=2821) [details]
HildonLiveSearch example
Comment 2 Alberto Garcia Gonzalez 2010-06-03 19:38:12 UTC
HildonLiveSearch works fine (I've just attached an example) so I guess
something's wrong in the browser.

Moving bug there.
Comment 3 Andre Klapper maemo.org 2010-06-09 15:00:10 UTC
Confirming.
Comment 4 Andre Klapper maemo.org 2010-06-09 15:23:38 UTC
Marking as dup of bug 5526 and reopening that one.

*** This bug has been marked as a duplicate of bug 5526 ***